Guest Wifi settings and some other setup questions

Hello all,

I have searched the forum and it didn't come up with an answer, but forgive me if it has been asked before.

I have the TP-Link WDR4300 flashed with OpenWrt 22.03.5. It is going to be used behind the ISP gateway as a wifi router and started with the default configuration within LuCI. For the Guest wifi I'm following this guide: Guest wifi dumbap which is written for 18.06.1 and is quite similar but slightly different.

When I go to Network>Interfaces>Edit>General Settings, it says next to 'Device': 'unspecified'. It was not mentioned in the link above.
Q: Should I leave it like that?

Q: If I don't need IPv6 (when my ISP is not offering this yet), do I need and can I disable it?

Under Network>Firewall>Traffic rules>Add>General Rules>'Guest DHCP', 'Guest DNS' and 'Block Guest Access to Private Network' rules I have created, is says under 'Source address', 'Destination address' and 'Source Mac Address' in the above mentioned link: any. This option is now gone.
Q: Is it the equivalent of -- add ip -- which is the option now?

I'm not going to use uhttpd to listen to the external/WAN ports, basicly I'm not going to use it at all.
Q: Is it by default enabled/installed on 22.03.5? Or does it need to be downloaded as a package? Then I need to do nothing.

Thank you.

Then how did you browse to:

This is uhttpd (web server running LuCI web GUI) - are you saying that you don't plan to use the web GUI after setup?

In any case, yes.

You can:

  • Leave as-is
  • Delete IPv6 wan6 interface
  • Disable

There's no need to disable it.

Hope this helps - and perhaps others can chime in on the other questions.

1 Like

Ah, okay thanks, didn't know it was for running LuCI, I thought it was for listening to ports only. I'm going to continue to use the web GUI so I need to disable it to listen to the external/WAN ports. I got an error trying, I need to replicate the error if it occurs.

Thanks for the info.

1 Like

Maybe @vgaetera iis willing to answer? Thanks!

Question for anyone who wants to answer, it is much appreciated:
The ISP cable router and modem (Compal CH7465LG) is into router mode, and not bridge mode. Provider is also offering IPv6 btw.
Q: I can't find a special NAT section, but it has IP and Port filtering, under 'protocol' I can find: all, UDP, TCP, UDP/TCP, Sender IP, Destination IP. Is this the NAT section?

I don't prefer to setup my OpenWrt router as a exposed-host, but use NAT.
I'm reading here that the default option of the OpenWrt router is a cascaded router (double NAT).
Q: I guess it is already setup like I prefer? I'm just checking email, surf and watch streams, no gaming.

Sorry for all the questions.

Can you show a screenshot of what you're referring to?


I can't take a screenshot with the settings opened.
Protocol: all, UDP, TCP, UDP/TCP
Source and Destination address: all, single, range


Protocol: TCP, UDP, Both


Device: unspecified.


--add ip-- instead of any? I can only add specific ipaddresses.

openwrt3
Other device options, when I click on 'unspecified':
Bridge br-lan
Ethernet Switch the0
Switch VLAN eth0.1 and eth0.2
Wireless Network: Master OpenWrt lan, lan and guest
Alias interface: @ Guest, lan, wan, wan6

Maybe someone who has setup the Guest Wifi under 18.06 and upgraded to 22.03.5, is willing to check the settings under
Network>Interfaces>Edit>General Settings:
*'Device'
and
Network>Firewall>Traffic rules>Add>General Rules>'Guest DHCP', 'Guest DNS' and 'Block Guest Access to Private Network'

  • 'Source address',
  • 'Destination address'
  • 'Source Mac Address'