Guest interface : ip6assign and ifname

The default LAN interface config seems to be:

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

The guest interface, from the doc, can be configured this way

uci set network.guest="interface"
uci set network.guest.type="bridge"
uci set network.guest.proto="static"
uci set network.guest.ipaddr="192.168.3.1"
uci set network.guest.netmask="255.255.255.0"

I have 2 (naive) questions:

  1. Why does the guest config not include an ifname? In my mind, it needs to have an ifname, so that the interface can actually be applied to a physical port. I would expect to set it to the wifi port. Why is it not present in the doc?

  2. ip6assign is not present in the guest config. What is the impact of that? Does it mean the guest network will not support ipv6?

It does need to include its own VLAN, unless you want to use it wireless-only.

Yes, but you can (should-) add IPv6 with a dedicated subnet set via ip6assign as well.

2 Likes

Thanks for your quick response.

Yes, I want it wireless only. Is it not necessary to add the ifname in that case?

In what part of the config can I do that? What issue can arise if I don't do it? (I do not have a need for IPv6, so I'd prefer not enable it, simply to keep the config as simple as possible).

  1. no, the bridging for wireless is done from within the wireless configuration

  2. Same as with LAN, ip6assign/ ip6hint apply accordingly.

2 Likes
  1. Ah, got it. So the ifname in the lan config refers to the ethernet port, not the wifi radio

  2. Ok, thanks

@slh sorry to ask again, but I feel I am missing something. I am quite happy not to have IPv6. It seems IPv6 only makes things marginally faster right now. But from your comment, I feel I might be missing something more.

I am tempted to remove "ip6assign" on all my network interfaces, including the lan, so that they only respond to IPv4. That way, I feel I can avoid the additional complexity of IPv6. Is that a reasonable thing to do? Can I also remove the wan6 interface?

Since you have followed the how-to, there's an extra part to easily provide IPv6 to the guest network:
https://openwrt.org/docs/guide-user/network/wifi/guestwifi/extras#ipv6

2 Likes

Thanks for that. I had seen it. But what is the downside of NOT enabling IPv6? I'd rather not enable it if I don't have to.

1 Like

There are IPv6-only services, so IPv6 connectivity is required to access them.
Even if it is not apparent now, it will definitely be in the foreseeable future.
It also increases the fault tolerance of services operating in dual-stack mode.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.