Hi,
I'm able to tag wireless interface to a Vlan ID and into the GRE tunnel, and Wireless devices are getting a DHCP IP from the remote servers.
Currently, I'm trying to extend the same VLAN tag to the LAN ports similar to the wireless interface, but unsuccessful.
Any suggestions please? I have added the working configurations and diagram.
LAN config:
# looking for a solution to add the LAN interfaces to the GRE tunnel with Vlan tag 100.
#So the host on the LAN can get a DHCP IP from the remote server on vlan 100.
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option device 'br-lan'
GRE config:
config interface 'gre1'
option type 'gre'
option proto 'gretap'
option ipaddr '10.15.6.193'
option peeraddr '10.0.43.100'
config interface 'gretun_100'
option type 'bridge'
option ifname 'gre4t-gre1.100'
option proto 'static'
option vlan_filtering '1'
option ip6assign '60'
config interface 'gre_100'
option ifname 'gre1.100'
option network 'gretun_100'
option mtu '1500'
Wireless config:
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'gretun_100’
option mode 'ap'
option encryption 'none'
option macaddr '30:23:03:dc:87:0a'
option ssid 'abc-OpenWRT'