GPS based NTP in LEDE with ntpd only

A while back a post was made saying that it was possible to have ntpd communicating directly with a GPS receiver but when I click the link to that thread in another one I get transferred to an error message saying that post is private or was deleted. How would I get this working instead of trying to get gpsd and ntpd communicating with each other.

Running LEDE ?
LEDE was years ago...

I just want a simple single program solution. getting gpsd and ntpd to communicate with each other is turning into a frustrating experience. I followed the tutorial TO THE LETTER posted here https://openwrt.org/docs/guide-user/services/ntp/gps and can't get other computers to communicate with ntpd but can seem to get ntpd to acknowledge gpsd.

You have probably noticed

The referenced article link goes to the old forum, of which there is archive in

You should divide that into two parts:

  • Getting GPS connected to the ntpd and the time of the router itself adjusted properly.
  • Propagating NTP time via ntpd to others.

If the first goes ok, (like it almost sounds above), you are actually just asking about ntpd config here, not about GPS problems.

Edit:
I hope that you noticed that some of the config examples contain script leftovers: "emit" and quotes etc. stuff.

I did notice that but now gpsd is crashing with an error
gpsd:ERROR can't run with neither control socket nor devices and when I run gpsd in a debug mode it says control socket create failed, netlib error -1. I have searched online for information about this but I can't find anything. One of those instances where if you say "Google it" that only leads to more frustration. In the configuration file both a valid socket and device are listed the device happens to be detected as /dev/ttyACM0 as it is a U-Blox device which has worked perfectly in the past. It is getting a 3D position fix and is locking onto a total of 20 satellites as well.