GoFlexNet - hostname forgot after reboot


#1

Hi all,
I tried to install LEDE 17.01.1 and snapshots on my Seagate GoFlexNet. But when I tried to configure anything in /etc/config/system (like hostname, timezone, ..), these changes are lost after each reboot.

I tried to do the configuration by modifying file directly, using luci or uci.

uci set system.@system[0].hostname='test'
uci commit
reload_config

Till the reboot, changes are visible, but after reboot, they are lost.
Thank you for any help.


#2

Can you try to re-flash LEDE and see if the behaviour changes ? Maybe go back to stock then re-flash LEDE again. I've seen another thread with similar symptoms and that did the trick.


#3

I tried to reflash is several times. Still same...
I don't have a problem with UFI partition. Everything else is saved there, onlt /etc/config/system not.


#4

Hello,

I am experiencing the same problem, which may be related to the fact that the overlay/data partition is not mounted at boot, probably due to some problem with the UBI fs coming from a previous OpenWrt installation using such filesystem.

Did you solve the problem in the meantime?
Thanks!