GoFlex Home as wireless NAS

How would I go about turning my GoFlex Home into a wireless NAS?

Since the GoFlex Home doesn't have Wifi I would guess: By using a Wifi dongle on its USB or connecting it to other Wifi hardware?

I guess the first thing to do is find a Wifi card which OpenWrt supports.

If I insert one, how do I tell if it is supported?

Some use search quite effectively on common topics, both here and on the wiki.

2 Likes

Yes! Found this :slight_smile:

Needed to run this first to see what Wifi adapter I had:

opkg install usbutils

I followed the instructions so far but couldn't manage to see a wlan interface when running ifconfig, and didn't see the file /var/run/hostapd-phy0.conf .

Any ideas on what I'm missing?

Here is my /etc/config/wireless:-

t
config wifi-device 'radio0'
<------>option type 'mac80211'
<------>option channel '11'
<------>option hwmode '11g'
<------>option path 'platform/ocp@f1000000/f1050000.ehci/usb1/1-1/1-1:1.0'
<------>option htmode 'HT20'
<------>option disabled '0'

config wifi-iface 'default_radio0'
<------>option device 'radio0'
<------>option network 'lan'
<------>option mode 'ap'
<------>option ssid 'OpenWrt'
<------>option encryption 'none'

The examples I've seen specify a device name of 'wl0' rather than 'radio0', although I don't suppose that makes any difference...

I'm using OpenWrt 18.06.2.

Here's a section from my log:-

Wed Mar 20 20:05:20 2019 user.info kernel: [  119.191131] kmodloader: loading kernel modules from /etc/modules.d/*
Wed Mar 20 20:05:20 2019 kern.info kernel: [  119.200645] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
Wed Mar 20 20:05:20 2019 kern.info kernel: [  119.208690] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
Wed Mar 20 20:05:20 2019 kern.info kernel: [  119.399872] usb 1-1: reset high-speed USB device number 2 using orion-ehci
Wed Mar 20 20:05:21 2019 kern.info kernel: [  119.610728] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
Wed Mar 20 20:05:21 2019 kern.info kernel: [  119.646727] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5370 detected
Wed Mar 20 20:05:21 2019 kern.debug kernel: [  119.654400] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Wed Mar 20 20:05:21 2019 kern.info kernel: [  119.655780] usbcore: registered new interface driver rt2800usb
Wed Mar 20 20:05:21 2019 user.info kernel: [  119.673971] kmodloader: done loading kernel modules from /etc/modules.d/*

Which suggests the adapter has been detected. Is there any way to activate it?

You’re likely missing the driver or another module that is needed.

Does iw phy recognize it?

1 Like

https://forum.archive.openwrt.org/viewtopic.php?id=56033

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb
root@OpenWrt:~# opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb`
Package kmod-rt2800-lib (4.14.95+2017-11-01-9) installed in root is up to date.
Package kmod-rt2800-usb (4.14.95+2017-11-01-9) installed in root is up to date.
Package kmod-rt2x00-lib (4.14.95+2017-11-01-9) installed in root is up to date.
Package kmod-rt2x00-usb (4.14.95+2017-11-01-9) installed in root is up to date.

????

Your /etc/config/wireless is pretty strange. Did you hand edit that? <------> isn't from OpenWrt config, as far as I know.

Have you properly run wifi detection? Have you rebooted after installing the modules?

1 Like

/etc/config/wireless was created by running wifi config as I was instructed in the guide above.

Looks like I ran wifi before enabling the device. After enabling it and running wifi again it shows up.

Thanks for the suggestion,

On to the next hurdle.... :slightly_smiling_face:

2 Likes

Moving on.... what do I need to do to turn this Access Point into a remote data point, ie a NAS I can take with me anywhere, but only access it via wifi? I think this means using hostapd, but I've never used that and don't how it works. Is there a simple/basic guide to setting it up? My understanding is that I should change the option mode in /etc/config/wireless from 'ap' to 'hostapd'. Is that correct?

Yes, turn the AP on in Luci. No I’m not Kidding.

Where do I look?

Network -> Wireless

?

I don't see any option for doing this.

Yes, this is where you look. All OpenWrt Wikis explain this.

Can you explain more clearly what you're not seeing?

Feel free to use the Wiki to get answers to your inquires!

https://openwrt.org/docs/guide-quick-start/basic_wifi

1 Like

Can you stop a minute and think about that question? :slight_smile:

Earlier I asked if I should look using LuCI under Network -> Wireless for turning on AP because I don't see it. Something similar to this appears

If I run uci show wireless, I see:-

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.channel='11'
wireless.radio0.hwmode='11g'
wireless.radio0.path='platform/ocp@f1000000/f1050000.ehci/usb1/1-1/1-1:1.0'
wireless.radio0.htmode='HT20'
wireless.radio0.disabled='0'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='OpenWrt'
wireless.default_radio0.encryption='none'

that radio0.mode is set to ap. Is this what was referred to? It was already set.

As I said I have never setup hostapd before and don't know what to expect, but I'm assuming there will be some option for setting the IP address of wlan0. So far I haven't come across an OpenWrt wiki which explains what is involved.

@balanga

While I sympathize that the advanced installation/configuration instructions you have followed in the past have been outdated and targeted to users with a good understanding of what they are doing, I reiterate that I strongly suggest that you not blindly follow any instructions for configuration or installation without understanding what the steps are expected to perform, so that you don't fall into that trap again. Checking the dates of the posts (or wiki edit that changed the section) can provide insight into if those instructions may no longer be current.

This, however, is normal configuration. Have you tried the obvious:

image

For the vast majority of users, there is no need to interact with hostapd or wpa_supplicant or their configuration directly.

1 Like

I'm totally lost at your responses.

OK...
Again...

I was asking for more clarity, as that is the same page I see; and I would just hit EDIT or ADD.


Screenshot%20from%202019-03-21%2014-08-42

Your image shows the EDIT and ADD buttons, so what are you not seeing/understanding/have instructions for?

Or this

image

2 Likes