GliNet Gl-MT1300 switch settings from stable to snapshot

I've got myself an GL-MT1300 travelrouter, the default firmware is pretty ok, but just for testing en fun I'm trying to install snapshot on it.
(the default is there own fork of OpenWrt 19.07.7)

The most things are straight forward, only I can't get my head around the switch settings from stable to snapshot.

Can anyone point me the way to make this work in snapshot?
( I know it's using the DSA switch framework now, instead of the out-of-tree swconfig drivers before, but I just don't get the new way. Not enough brainpower I guess) :wink:

This is my /etc/config/network file in 19.07.7


config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fdf0:2645:b44f::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option hostname 'GL-MT1300-7d3'
   option ipaddr '192.168.8.1'

config interface 'wan'
   option ifname 'eth0.2'
   option proto 'dhcp'
   option hostname 'GL-MT1300-7d3'
   option metric '10'

config interface 'wan6'
   option ifname 'eth0.2'
   option proto 'dhcpv6'
   option disabled '1'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '0 1 2 3 6t'

config switch_vlan
   option device 'switch0'
   option vlan '2'
   option ports '4 6t'

config interface 'guest'
   option ifname 'guest'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.9.1'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option bridge_empty '1'

config device 'wan_dev'
   option name 'eth0.2'
   option macaddr '94:83:c4:0e:a7:d3'

config device 'lan_dev'
   option name 'eth0.1'
   option macaddr '94:83:c4:0e:a7:d4'

config interface 'wwan'
   option proto 'dhcp'
   option metric '20'

config interface 'tethering'
   option proto 'dhcp'
   option ifname 'eth1'
   option disabled '0'
   option metric '5'


This is how it looks in Luci on 19.07.7

This might help:

That makes things much clearer! Thx for the link.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.