Glib2 failing to build in Ubuntu 22.04

Upgraded to Ubuntu 22.04 and tried to build in it today and ran into an error - glib2 failed to build, just needed to install distutils for python3

sudo apt-get update

sudo apt install python3-distutils

Just leaving this here in case anyone else runs into this error.

1 Like

Ahh thanks, I did a few searches here in the forum before posting, but didn't run across that.

suggest you do not use the new v22.04, using v20.04 is good enough for coming 2 more years.

1 Like

See the link from @RadioOperator above for Ubuntu 22.04 prerequisites provided by @hnyman and alternative prerequisites provided by @RadioOperator

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.