GL.iNet GL-B1300 Spectrum Internet problem

I have a GL.iNet GL-B1300 router w/ v21.02.03, DHCP doesn't seem to getting IP assignment from Spectrum Internet(the modem is Arris TM1602AP2 provided by Spectrum). The same settings works fine with x86/64 & TP-Link Archer A7. Here'e the relevant section of /etc/config/network:

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'
	option broadcast '1'
	option peerdns '0'
	list dns ''
	list dns ''

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '56'
	option peerdns '0'
	list dns '2620:fe::fe'
	list dns '2620:fe::9'
	option ip6assign '64'

Any suggestions?

Clone the WAN side MAC from the working, to the non working device.

Did that, doesn't work.

Then use tcpdump to sniff the traffic, see what happens.

I had similar lack of DHCP when I briefly tried a GL-B1300 on it.

My wild guess is that the modem is latching onto the first MAC address it sees from any packet, not just dhcp requests. It wouldn't surprise me if the modem is so incompetent it's seeing some special reserved mac address, deciding that surely it must be the router's mac address, and then ignoring all DHCP requests from the real MAC address once that comes long. Because obviously that different MAC address is a second router, right? :person_facepalming:

I ended up giving up on the GL-B1300 for that and other reasons... and when I recently tried using it again as an AP, the throughput was absurdly low. That's actually how I found this topic: searching for GL-B1300.