GL.iNET Flint 2 (GL-MT6000) discussions

oops, missed that, thanks!
I just installed r26329-cffd3ad8d7, it seems to work fine.

tried the attended sysupgrade yesterday and it worked fine, it was something i was putting off doing as i didn't want to have to set the router up again if the upgrade broke.

i can install qosify and begin tinkering with it now.

1 Like

When I did testing using iperf3 Wifi I found strange speeds. When I was doing reverse test, i.e. the traffic directed from a pc connected using cable a laptop located in the opposite corner of the house ~distance 16m I get the speed ~300Mbits/sec. When I do direct test, when my laptop sends the data it is approximately 3 times slower. That was on original firmware v4.5.2 which I have had when I bought. Have not yet tested after the upgrade.

My iperf3 tests were the opposite (slow receive, normal transmit). I'm still trying to figure out why. Currently, I'm just blaming Windows, since I haven't noticed any problems with Android or Linux.

The strange thing was that messing with iperf3's --dscp option would give normal throughput results. So, you might try that. DSCP 1, 24, or 32 as a starting point. 0 is default.

I started a thread about it over here: DSCP seems to affect WiFi download speeds

attended sysupgrade no work for me, last snap

Anyone having issue when wifi speed in one direction is slower?
When I test in reverse when PC which connected using cable sends the data to laptop the speed is 300-340 Mbits/s
When I test direct when laptop send the data to the same pc the speed is 100 Mbits/sec. Is that me or someone also have same problems?

TCP Reverse ~ 340 Mbits/sec

📦[john@ubuntu-2204 ~]$ iperf3 -c 192.168.8.104 -t 120 -i 20 -R
Connecting to host 192.168.8.104, port 5201
Reverse mode, remote host 192.168.8.104 is sending
[  5] local 192.168.8.122 port 48400 connected to 192.168.8.104 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-20.00  sec   761 MBytes   319 Mbits/sec                  
[  5]  20.00-40.00  sec   825 MBytes   346 Mbits/sec                  
[  5]  40.00-60.00  sec   833 MBytes   349 Mbits/sec                  
[  5]  60.00-80.00  sec   838 MBytes   352 Mbits/sec                  
[  5]  80.00-100.00 sec   830 MBytes   348 Mbits/sec                  
[  5] 100.00-120.00 sec   777 MBytes   326 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-120.04 sec  4.75 GBytes   340 Mbits/sec  369             sender
[  5]   0.00-120.00 sec  4.75 GBytes   340 Mbits/sec                  receiver

iperf Done.

TCP Direct ~ 100 Mbits/sec

📦[john@ubuntu-2204 ~]$ iperf3 -c 192.168.8.104 -t 120 -i 20
Connecting to host 192.168.8.104, port 5201
[  5] local 192.168.8.122 port 38352 connected to 192.168.8.104 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-20.00  sec   242 MBytes   102 Mbits/sec    0   1.35 MBytes       
[  5]  20.00-40.00  sec   242 MBytes   102 Mbits/sec    0   2.07 MBytes       
[  5]  40.00-60.00  sec   234 MBytes  98.0 Mbits/sec    0   2.07 MBytes       
[  5]  60.00-80.00  sec   242 MBytes   102 Mbits/sec    0   2.07 MBytes       
[  5]  80.00-100.00 sec   239 MBytes   100 Mbits/sec    0   2.07 MBytes       
[  5] 100.00-120.00 sec   241 MBytes   101 Mbits/sec    0   2.07 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-120.00 sec  1.41 GBytes   101 Mbits/sec    0             sender
[  5]   0.00-120.07 sec  1.40 GBytes   100 Mbits/sec                  receiver

iperf Done.
📦[john@ubuntu-2204 ~]$ 

I just experienced something like this on all devices after a reboot. I went 11 days with pretty great reliability and throughput, then after a reboot my download went from ~800mbit to ~200mbit (and ultimately 50mbit) and the entire WiFi network (2.4 & 5g) became unstable, with iperf3 tests showing zero throughput for ~3 second stretches. The logs had nothing interesting. The temperature shot up from its average of 47c to 52c for no reason that I could see via top/htop.

I'm on 23.05.3. I tried the default and most recent MediaTek WiFi firmware with no change.

I switched my WiFi back to my Asus RT-N66U for now.

Hmm when this occur and you have no other interference sources such as usb sticks connected, could you show the output of:

cat /sys/kernel/debug/ieee80211/phy0/mt76/reset

im suspecting something here, similar as issue https://github.com/openwrt/mt76/issues/865 and maybe also https://github.com/openwrt/mt76/issues/866

See my last message on issue 866.

Is there any traffic which may be heavy? udp streams or multicast?, or devices with their own transmit power setting?

1 Like

No issues with an actual openwrt snapshot.

Respectfully, you keep posting your stock gl.inet firmware results, but this thread is about openwrt. If you have questions about stock firmware, you should visit the official gl.inet forum.

5 Likes

you should upgrade to the latest snapshot, its is very stable and has a lot of bug fixes. since this device is realively new, it makes more sense to be on snapshot than stable (just my opinion).

2 Likes

Agreed and for those paying attention to the changelog they put many of the mt76 fixes into 23.05 branch last week, so for those that prefer that 23.05.4 will have most of them.

mt76 still is more up to date in main though that's likely why it works so well for most of us running snapshots (including driver update that just went in today).

5 Likes

That's logical but I think, as a part of the OpenWrt community, we shouldn't push people towards using the snapshots, especially considering that it's hard to troubleshoot when everyone's running a different snapshot.

1 Like

I can appreciate where you’re coming from, however I disagree with it being hard to troubleshoot. One can see all the commits before and after the snapshot that’s being run… so if a commit broke something, it’s typically quite easy to uncover.

That being said, if someone is choosing to run snapshots they should always save several of their recent working images for those “just in case” moments. Makes for an easy rollback.

6 Likes

Are the new drivers in the latest main snapshot? I upgraded but I am still getting the old drivers. I am on version r26381-9db53fb6aa. I did manually update to the latest ones though.

They are.
phinn was talking about this commit:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=ed23d4d00dcc26f69da6a2fbb89f21d99f3e25d9
It is included in your snapshot.

Maybe you are mixing up the drivers and firmware versions?
I think the latest MediaTek WiFi firmware, that some people were testing here, is not included in main.

2 Likes

This is correct. Firmware is still on the 2022 version in current snapshots, but may be manually replaced if one desires.

I am curious why the new 2024 version isn't being included in snapshots though...?

1 Like

Oh, got it. That’s exactly what I was talking about. Sorry for the misunderstanding on my part.

They would probably need to be pushed upstream to linux-firmware by Mediatek first.

3 Likes

For the curious:

FYI, there were some 20240411 firmware files released that I (and possibly others) had issues with.

So far the 20240507 firmware has been rock solid for me.

5 Likes

I agree that the 0507 driver has been great. Better WED performance for sure.

2 Likes