GL.iNET Flint 2 (GL-MT6000) discussions

I'm using OpenWrt SNAPSHOT r25219-6e2962d4c5 for my GL-MT6000. I have multiple VLANs being used on both radios. I've noticed that both radios start randomly giving "Device is not active" and the APs on them start showing "Wireless is not associated". It seems to change and when I disable one AP another one will come online. I don't think I can use any of the wireless networks when this happens.

I did find that if I manually disable all of my 5GHz APs and restart my router, I am able to use all of the 2.5GHz ones just fine. If I manually enable all of the 5GHz ones after that reboot, I can use both radios just fine and I haven't run into any issues today since doing that. If I reboot, I go back to the same issue.

Disabling all 5GHz APs before and after rebooting is my current workaround, but is there a way to make it so this isn't happening? I removed all of the explicit MAC addresses for my lan devices, but left the explicit MAC for eth1 there, which is what let me get this working at all.

I am happy to share any configuration files if you need them, if this is something that needs to be fixed on OpenWrt's side. If it is something that I can configure, I would love to know if there's a way to do so.

Thank you!

You're not alone. I have the same oddball problems but I can't be clear as to what is happening and so I can't explain what is happening yet. Restarts and reboots don't fix it sometimes. It seems that I only have problems after flashing an update.

My fix (temp) when I can't get it to clear is...

rename /etc/config/wireless to anything. I use wireless.OFF

Then reboot router and let Openwrt create it's own wireless
now your radios are working but not configured.

Go and delete the new /etc/config/wireless and then rename your old renamed wireless.OFF back to wireless.

Now log out and log back in. Give it a few seconds and check your wireless network setup.

Your old original wireless config will be back and functioning.

Sounds crazy. Sounds stupid. Sounds like BS. Maybe so.
But mine will then run without fail until the next flash update.

This firmware is in beta and it is a pretty young version.
base-files package is updated ALL the time. Gotta wander if that my have something to do with it. Alot of testing on drivers is going on right now too.

Once I get mine running it's just as solid as can be. I love it.

You can always delete wireless and reboot and then rebuild your wireless config from scratch step by step. Tedious but likely fix it too.

I run five vlans and a guest network with trunk lines to AP's. Sounds like our setups my be similar.

Add this in your startup (while we wait for the issue to get sorted out or understood).

sleep 40 && wifi reconf

To me seems like a race condition in bringing the radios up, it is not 100% deterministic. The above workarounds it.

I have this MT6000 affected and my Dynalink WRX36. The more virtual devices (or mesh points) you add the more probable it becomes to me.

FYI, since my Dynalink boots slower, that one is using a delay of 80 seconds before doing the wifi reconf.

2 Likes

Unfortunately that doesn't do anything. Manually running wifi reconf after it boots also doesn't do anything. Manually disabling and restarting the radios and APs doesn't let me connect to any of the APs on either radio.

I'm not sure if these are related, but I see these errors in my system.log:

Sun Feb 18 21:35:38 2024 daemon.notice netifd: radio1 (5234): Device setup failed: HOSTAPD_START_FAILED
Sun Feb 18 21:36:08 2024 daemon.notice netifd: radio0 (5233): Command failed: ubus call hostapd config_set { "phy": "phy0", "config":"/var/run/hostapd-phy0.conf", "prev_config": "/var/run/hostapd-phy0.conf.prev"} (Request timed out)
Sun Feb 18 21:36:08 2024 daemon.notice netifd: radio0 (5233): Device setup failed: HOSTAPD_START_FAILED
Sun Feb 18 21:39:18 2024 daemon.notice netifd: radio0 (7232): Command failed: ubus call hostapd config_set { "phy": "phy0", "config": "", "prev_config": "/var/run/hostapd-phy0.conf" } (Request timed out)

The problem sounds like some timing problem / race in reading the 5 Ghz firmware blob in time before the radio should be initialised. The first boot after flashing may take longer that normally, as overlayfs is being created etc.

Likely nothing. Base-files is actually updated quite rarely. Its versioning just claims so, as it is based on the total commit count, not changes in the package itself.

Maybe it is a symptom of the race described here?:

If affected, then the phy will have incorrect mac address at boot. It will fix itself if you do anything causing the phys to be "hotplugged" again. Which matches the description.

In my case, I "fixed" the issue by disabling block mount, as this was causing delays making the phys lose the race every time. But that's an arbitrary fix. The underlying problem is still there, and can't be fixed unless we get the driver to configure the proper mac addresses

Hi Togehter,
i use the MT6000 with VLANs... (SNAPSHOT r0-fba79f3)
but i get only one DHCP working on the Fint 2...

i need DHCP for IOTstixi and KIDS
but only IOTstixi works

i hope somebody can help... THANKS

Network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd15:3f05:8c49::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'
	option bridge_empty '1'

config device
	option name 'lan1'
	option macaddr '94:83:c4:a2:b6:3a'

config device
	option name 'lan2'
	option macaddr '94:83:c4:a2:b6:3a'

config device
	option name 'lan3'
	option macaddr '94:83:c4:a2:b6:3a'

config device
	option name 'lan4'
	option macaddr '94:83:c4:a2:b6:3a'

config device
	option name 'lan5'
	option macaddr '94:83:c4:a2:b6:3a'

config interface 'lan'
	option device 'br-lan.10'
	option proto 'static'
	option ipaddr '192.168.2.32'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	option delegate '0'

config device
	option name 'eth1'
	option macaddr '94:83:c4:a2:b6:38'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'eth1:t'
	list ports 'lan1:t'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'

config bridge-vlan
	option device 'br-lan'
	option vlan '15'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '110'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '130'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '210'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '230'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '310'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '330'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '877'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '888'
	list ports 'eth1:t'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '999'
	list ports 'eth1:t'
	list ports 'lan1:t'

config interface 'GAST'
	option proto 'static'
	option device 'br-lan.999'
	option ipaddr '192.168.99.32'
	option netmask '255.255.255.0'
	option gateway '192.168.99.20'

config interface 'IOTstixi'
	option proto 'static'
	option device 'br-lan.330'
	option ipaddr '192.168.33.32'
	option netmask '255.255.255.0'
	option gateway '192.168.33.20'
	list dns '192.168.33.20'

config interface 'KIDS'
	option proto 'static'
	option device 'br-lan.15'
	option ipaddr '192.168.15.32'
	option netmask '255.255.255.0'
	option gateway '192.168.15.20'
	list dns '192.168.15.20'

config interface 'LANroby'
	option proto 'static'
	option device 'br-lan.110'
	option ipaddr '192.168.11.32'
	option netmask '255.255.255.0'
	option gateway '192.168.11.20'
	list dns '192.168.11.20'

config interface 'LANstixi'
	option proto 'static'
	option device 'br-lan.310'
	option ipaddr '192.168.31.32'
	option netmask '255.255.255.0'
	option gateway '192.168.31.20'
	list dns '192.168.31.20'

config interface 'LANulli'
	option proto 'static'
	option device 'br-lan.210'
	option ipaddr '192.168.21.32'
	option netmask '255.255.255.0'
	option gateway '192.168.21.20'
	list dns '192.168.21.20'

DHCP

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'GAST'
	option interface 'GAST'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'IOTstixi'
	option interface 'IOTstixi'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'
	list dhcp_option '3,192.168.33.20'
	list dhcp_option '6,192.168.33.20'

config dhcp 'KIDS'
	option interface 'KIDS'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'
	list dhcp_option '3,192.168.15.20'
	list dhcp_option '6,192.168.15.20'

config dhcp 'LANroby'
	option interface 'LANroby'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'LANstixi'
	option interface 'LANstixi'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'LANulli'
	option interface 'LANulli'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'

.config

#Flint2MT6000
CONFIG_TARGET_mediatek=y
CONFIG_TARGET_mediatek_filogic=y
CONFIG_TARGET_mediatek_filogic_DEVICE_glinet_gl-mt6000=y
CONFIG_TARGET_PACKAGES_mediatek_filogic_DEVICE_glinet_gl-mt6000=y
CONFIG_TARGET_PROFILE="DEVICE_glinet_gl-mt6000"
CONFIG_TARGET_MULTI_PROFILE=n
CONFIG_TARGET_ALL_PROFILES=n
CONFIG_TARGET_PROFILE="DEVICE_glinet_gl-mt6000"
CONFIG_TARGET_PER_DEVICE_ROOTFS=y
CONFIG_TARGET_OPTIMIZATION="-O2 -pipe -mcpu=cortex-a53"


#MBEDTLS
CONFIG_PACKAGE_wpad-basic-mbedtls=m
CONFIG_PACKAGE_wpad-mbedtls=y

#servicesandtools
CONFIG_PACKAGE_curl=y
CONFIG_PACKAGE_wget=y
CONFIG_PACKAGE_arp-scan=y
CONFIG_PACKAGE_bind-host=y
CONFIG_PACKAGE_irqbalance=y

#luci
CONFIG_PACKAGE_luci=y

#Sonstiges
CONFIG_PACKAGE_luci-ssl=y
CONFIG_PACKAGE_luci-app-statistics=y

Theres a few things strange to your configuration :slight_smile:

Since you use a strange ipaddr and a lower dns i want you to concentrate to your dhcp here:

you start for clients is already 100, but your dns shows 20 as a client, you should also be carefully with the range, since your ipaddr shows 192.168.15.32 as gateway ip, but your start is 192.168.15.100 for dhcp clients until 192.168.15.250, just make sure your clients dont go over 254 :slight_smile:

And then i see you specify the default route to gateway 192.168.15.25 but does this router exist?

And then i see multiple entries of this here:

eth1 is supposed to be the port serving wan, but lan1 - lan5 these are lan ports which includes one of the 2.5gb ports aswell, i suspect these entries are wrong.

Hi everyone,
My structure looks something like this

thus the gateway for all other networks except for LAN is 192.168.*.20

I used auc to try to upgrade to the lastest SNAPSHOT version, and I think I broke my device. I tried reset and connectivity using LAN1 and WAN, but I don't get any where, the device flashes blue twice then reboots every 90s or so. I tried failsafe mode in the documentation below, but the device does not seem to change is behaviour. Anythin else I can try before opening it up and trying to get console??

https://openwrt.org/toh/gl.inet/gl-mt6000
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

1 Like

Try OEM recovery mode.
Connect PC to MT6000 via LAN2 (1G port).

1 Like

hi,
can somebody please measure the power consumption idle / load / wifi on/off / 2.5gbe vs 1gbe link?

thanks in advance :slight_smile:

@m80, you sir are my favorite person of the day! it worked using LAN2. Thank you.

Documentation probably needs to change:

"Connect your computer to the Ethernet port (either LAN or WAN) of the router. You MUST leave all other ports unconnected."

1 Like

i forgot the Firewall settings for DHCP... now it works... sorry

If you've only ever flashed sysupgrade images, you can use GL.iNet's built-in uboot recovery environment to flash a working image by holding down the reset button for 30 seconds while powering on the router.

That language was taken directly from Gl.inet. Now that we have a better approach I just updated the doc page based on your recovery.

Link, please,

Our device page has been linked countless times on this thread just scroll up a little my dude.

[https://openwrt.org/toh/gl.inet/gl-mt6000]

Something is broken with auc, I would stay away from it: The OpenWrt Firmware Selector - #718 by f0ff886f (that thread has more breakages)

1 Like

Sigh, too late for me.
I did auc this AM, router kept loop booting.
Starting all over, again, bummer deal...

1 Like