GL.Inet AR750S OpenVPN Doesn't Reconnect on Reboot

Hello all!
I've just received my gl.inet AR750s (slate). I'm trying to enable openvpn on startup using /etc/init.d/openvpn.

When I enable the service, the router connect to my own openvpn AS. But after a reboot, it doesn't reconnect.... In ubuntu, i used to edit /etc/default/openvpn to uncomment the autostart=all. But i can't seem to find the equivalent in Luci.

Can anyone try to help me please? i need to get this going for tomorrow!! (Friday april 5th 2019)

Thanks a lot!

Are you running GL.iNet firmware, or OpenWrt itself? If running the GL.iNet firmware (which I consider to be very good and is very close to recent OpenWrt), have you upgraded to the most recent version? v3 (as I recall) has an even better UI/UX than the previous versions.

It’s gl Inet firmware and I believe it’s the latest version

I don't have one of mine on GL.iNet firmware handy, but if you go to "Advanced Settings" you should see the LuCI interface. There should be page with the services there listing them. Clicking on "Enable" for OpenVPN should enable the service at boot.

If not, the start-up services are enabled through symlinks in /etc/rc.d/ which generally can be enabled by /etc/init.d/some_service enable

That’s what I did /etc/init.d/openvpn enable

It connects right away, but it does not after a reboot

Is this a client or a server?

You might want to search the wiki and here, as well as changing the title to something like "OpenVPN Doesn't Reconnect on Reboot" to attract some with more experience with the specifics of start up of the VPN client or server.

1 Like

It’s a client. I have an openvpn AS on amazon ec2

logread -e openvpn

still have no luck....
whatever i do, the openvpn service gets disable at startup after a reboot.
The logread show nothing after a reboot, because the service got disabled..... i can't figure it out....

I must say that it's the original gl.inet firmware. I tried installing openwrt but the router didn't accept the snapshot that is listed for this router.

Anyway, if you guys can come up with something it would be amazing!

After MANY trial and errors.. i think i have found the problem. There's 2 reason i can think of and you guys can maybe tell me what's is the real reason.

1st: When enabling openvpn service (service openvpn enable) the symlink was showing in /etc/rc.d as S90openvpn. In this folder, there was 2 other services starting with S90, S90startvpn and S90vpn-service. I disabled them both and now S90openvpn is still present after a reboot (was disapearring before).

2nd: The startvpn service was competing with the openvpn service for access to file or port or whatever and startvpn service was winning....

These are the two reason i can think of..... maybe it's something else but ever since i disable both startvpn and vpn-service services, the openvpn service survive a reboot. I will not mark as solved since i don't know the exact reason yet!