GL-AR750S, OpenWrt 22.03.2, ZeroTier won't start/work

I've just flashed a GL-AR750S 'Slate' to OpenWRT 22.03.2 (successfully, can log into LuCi and SSH and have internet connectivity) and then installed the "zerotier" package. I'm following these two guides to get set up, both of which seem very straightforward for my simple usage:

I have my ZT network added and the config looks exactly how it should, but when I reboot, the ZeroTier service doesn't appear to start on its own (the guides seem to indicate that it should) because I get an error (zerotier-cli: missing port and zerotier-one.port not found in /var/lib/zerotier-one) if I try to use "zerotier-cli info" or "zerotier-cli status". If I start the service manually with "zerotier-one -d", then "zerotier-cli status" shows that it's online, but the ZT interface still doesn't show up under "ip a". I don't know what I've done wrong.

Sorry if this is a super stupid problem; I just thought I could follow the guides and get it working without having to mess around with anything deeper (which I'm not equipped for). Apparently not.

I ended up resolving this by doing nothing more than reflashing and starting from scratch. I have no idea what was wrong the first time; as far as I can tell, I followed exactly the same series of steps, but this time everything worked as advertised out of the box.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.