Gigabit port on the router redmi AX6S doesn't work

I've recently installed OpenWRT on a redmi AX6S router as described here. Everything works fine, except that the three ports of the router that should be Gigabit ports are not working as Gigabit ports. While I'm connected on Wifi it reaches the full speed of my internet (300Mb/s), but while connected on the cable it reaches only around 90Mb/s.

Is there any test I can do to troubleshoot why the Gigabit ports are not working properly? I've tried installing an older OpenWRT version to see if something would change, but the result is still the same.

I haven't tested these ports speed with the stock firmware, so by now I can't tell if it's a problem with the router or if it's a problem with OpenWRT... I know the documentation page gives me the link for downloading the stock firmware. But I'm not quite sure how I could proceed to go back to the stock firmware to check if that's a router's problem. I've tried flashing it using Luci's interface but after rebooting it's back on OpenWRT. Could someone help me on how I can go back to the stock firmware?


welcome to this forum.
Which model of this device do you have, RB01 or RB03? What kind of test did you do? Internet speed tests will change with time, 5 minutes later the speed is not the same.
Better test device speeds on LAN (only). Between 2 devices, through router(s) if you want.
Check the used ethernet cables, many differences in quality is there (eth5, eth5e, eth6, straight through, patch etc.).

Be aware that the device already runs -a highly customized version- of OpenWrt.

You tried also an older version, but that is also v22? Did you try a v21 or v19 version?

To test (cable) connectivity you could use iperf3 (install via GUI).
You only need another linux or OpenWrt device as server (iperf3 -s).
with: iperf3 -c [ip-address] you can test the connection.
Try this also vice versa (make client server and server -> client).

Hopefully you can test 'real' speeds now.



Thanks for the response... I tried making the tests you suggested now, but the results are still the same, both using iperf3 from the computer to the router or from the router to my computer... I get around 100Mb/s of speed:


I tried this test with a small cable directly connected on my notebook... If I try this same test using its WiFi instead of the cable I get the 300Mb/s speed... Also, alternatively if I connect this same cable on my ISP router (not the one with OpenWRT) I get speed around 300Mb/s on Online speed tests like So the issue is only with the Gigabit port of the Xiaomi AX6S router.

My router is the Chinese device (RB03)... About the OpenWRT version, I'm not sure if I'm missing something, but on the page I can only find OpenWRT versions between V22.03.02 and V22.03.0... There's no V21 or V19 to flash with the router AX6S I think...

I should probably have tested it with its stock firmware before installing OpenWRT... The way it's now I'm not sure if it's an OpenWRT issue or if the router that I've bought that should have 3 Gigabit ports doesn't have 3 Gigabit ports. :thinking:


I didn't know there are no V21 or lower versions for your device, sorry.
As I wrote earlier: the OEM firmware is also -a highly customized version- of OpenWrt.
So I doubt if the speed will increase with that firmware.

You could try the following settings within the gui: Network / Firewall

The second option comes up when selecting the first.

Maybe you run some tooling on OpenWrt, like adblockers or proxies. These could slow down WAN - LAN traffic. Try the speed with these turned off?


I've taken today to make some tests and I ended up getting to the conclusion it was really a cable issue. I have some small cables that look the same here and I probably mixed up them on my first tests... Apparently, some of them are working fine and others are not (they only reach 100Mb/s).

So that wasn't an OpenWRT issue in the end... Thanks for the responses!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.