Getting error on upgrading script - Linksys e8450

Hi, I am not able to upgrade packages, getting error below

Please advise.

Maybe trying to install latest packages on a stale snapshot.

Install the latest snapshot.

Dear @anon89577378, I tried to update snapshot using OpenWrt menu option after it i am facing below issue, now i have tried to reset is using reset button, power on/off but no luck. i am not getting up.

Please suggest.
Thanks in advanced.!

Looks like you started a new thread on that issue, so let's continue there...

So now, i have 100+ packages asking update, when i am trying to upgrade it showing as below
Please suggset.

don't update snapshot builds, you'll break more than you'll fix.

and risk another soft brick.

Dear @frollic , I need to add DNS encryption but due to out of date scripts not able to do.
Please suggest.

i am also do not want to update frequently, could you please suggest which version is stable so i can install it in one go.


then just install the package, don't update the whole thing, or does the dns encryption package require all these other packages updated ?

there's no stable for the device, it's to new, it'll be stable in the next major release, coming after 21.02.

1 Like

Thanks @frollic for your advise, i have installed https-dns-proxy
my result as follows, it looks not working, i followed its related article and troubleshooting section, no success. kindly advise on it

root@OpenWrt:~# nslookup localhost
Server:         localhost
Address:        [::1]:53

Non-authoritative answer:

Non-authoritative answer:
Address: 2a03:b0c0:3:d0::1af1:1

how i can check its working for me

what's not working ?
post the link to the "related article" you used.

No idea what should be result, and how i can identify it works. i ma using below

then how do you know it doesn't work ? :wink:

Swap the Google DoH for Adguard family, then try to surf to some porn site, if you can't, it's working, and change back to google.
Or if you know some sites blocked by your ISP, try accessing those using the current setup.

It means, no porn site will work if DNS Encryption is working? but on my side i cant open any porn site. our government already blocked all porn sites :grinning:
another way to test it?

If they blocked them all, they should work again, if your setup is doing what it's supposed to.

Yes, I got few links, I am able to open porn sites
Configuration on my side as below


problem solved then ?

1 Like

Okay, I got your point now. Thanks @frollic, but I want to block porn permanently and want DNS encryption too. how I can take both advantage?

Replace the google DoH with the Adguard family DoH ?

1 Like

is this manual process or any plugin can resolve it easily?
using this can i block some social sites too?