Getting 150 Mbps instead of 450 Mbps

Hello, I have been using openwrt since more than a year now, with two wan connections, a very nice working config thanks to mwan3, my router its a TPLINK TL-WR940N V4 (US) with wifi N and 3x3 MIMO, capable of providing 450 Mbps of wireless speed in the stock firmware. But with the following parameters i'm just getting 150 Mbps:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT40'
        option legacy_rates '1'
        option country 'VE'
        option noscan '1'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'cars'
        option key '******************'
        option encryption 'psk-mixed+ccmp'
        option wmm '1'

iw list

Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * outside context of a BSS
        Band 1:
                Capabilities: 0x11ee
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                        * 2412 MHz [1] (22.0 dBm)
                        * 2417 MHz [2] (22.0 dBm)
                        * 2422 MHz [3] (22.0 dBm)
                        * 2427 MHz [4] (22.0 dBm)
                        * 2432 MHz [5] (22.0 dBm)
                        * 2437 MHz [6] (22.0 dBm)
                        * 2442 MHz [7] (22.0 dBm)
                        * 2447 MHz [8] (22.0 dBm)
                        * 2452 MHz [9] (22.0 dBm)
                        * 2457 MHz [10] (22.0 dBm)
                        * 2462 MHz [11] (22.0 dBm)
                        * 2467 MHz [12] (22.0 dBm)
                        * 2472 MHz [13] (22.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

iw dev wlan0 info | grep channel

channel 11 (2462 MHz), width: 40 MHz, center1: 2452 MHz

Windows Speed

I don't if the problem may be my devices, anyone knows how to check that? Thanks

You have tested this and seen those speeds? Or you just read the marketing BS?


I don't really check that, but I think my model should be able to support that theoretical speed due to the router’s hardware.

You cannot change that to 11n?

Other than that, the speed that you refer to is the one reported by the windows? Don't have too much faith on that. This is theoretical speed according to modulation, signal strength, band etc.

Should I? I saw on openwrt documentation that hwmode 11g + adding HT40 or HT20 is the correct way to set up the WiFi N band, there’s a better and precise way to test my local speed? When I use HT20 my speed goes down to 72 Mbps

Your 11g setting is correct

Is your PC capable of 450Mbps, the screenshot show 5 bars signal so it is possible that is the highest speed the PC can perform at is 150Mbps.

Check the specs for your PC and its wifi

Also under Luci , you can go to
under associated stations section you can see the speeds for each device.

1 Like

First off, realize that the link modulation speed will vary with load and other conditions, even when a couple meters away.

Second, just because the link modulation supports, say 450 Mbps, doesn't mean that you're going to get 450 Mbps of throughput in any real-world situation. There's overhead of moving "real" packets, as well as channel congestion, including that of the AP operating things such a beacons. Getting 80% of that in a real-world situation would be, in my opinion, very good.

Edit: 802.11n only can provide 150 Mbps per link, see, for example Higher rates are only possible if the client and AP properly support and negotiate multi-link ("MIMO") connections.

802.11n's speed may go up to 150 megabits per second if there are not other Bluetooth, microwave or Wi-Fi emissions in the neighborhood by using two 20 MHz channels in 40 MHz mode.

Third, your router's CPU may not be able to handle 450 Mbps at all. A 750 MHz, single-core MIPS processor may not be able to do anything with the packets at that rate, even if the wireless could supply them to the CPU.

Edit: Further, your router only supports 100 Mbps Ethernet.


As Jeff said not only does router have to support MIMO but also the other device needs it, which means it must have 3 separate antennas and various other hardware and drivers etc for MIMO. It never happens in the real world except maybe between two wifi routers in a cabin in the woods.


With a 1 antenna and 40Mhz channel the maximum speed you will get is 150Mbps

1 Like

Thanks for all you anwers guys, I realize that the problem is the devices connected to my network, most of them doesn't support MIMO and therefore local speeds higher than 150 Mbps.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.