Get IP but cannot route traffic to fiber optic gateway

I just upgraded my ISP to fiber optic. The carrier, Frontier, gave me a XGS-PON ONT FOX222 gateway. They also provided an eero pro 6 router. It all came up and worked OK. So I plugged my OpenWRT router ethernet port into the LAN port on the eero router. It kept my LAN unchanged and routed fine. (Although my inbound ports are all blcoked by the eeros)

So this worked:
PC > OpenWRT Router > eeros 6 pro > FOX222 > internet

Then I removed the eero 6 router and put my OpenWRT router directly into the FOX222 gateway. It gets an IPv4 and IPv6 address, but nothing routes. The PC cannot send traffic, and the diagnostics page cannot get any results. Even ping to fails.

I thought maybe the FOX222 was somehow locked to the MAC of the eeros router, so I plugged a PC directly into the FOX222 to test that theory. The PC worked fine directly connected to the gateway.

So I put my OpenWRT router back in the middle and everything stops.

I saw some posts here that suggested a few things, but none worked. I changed the "Use broadcast flag" and the "Force link" flag on the eth0 connection, but it didn't affect it. Those topics all seemed related to obtaining an IP from the carrier. That part works. I just can send traffic.

Does anyone have any ideas?

Router: Linksys EA6350v3
OS: OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 branch git-22.083.69138-0a0ce2a

Did you already try a factory reset (firstboot) of the ea6350v3? Based on your description, plain DHCP (so the default for OpenWrt) appears to work, but maybe you still have conflicting old configurations set (or an IP overlap between WAN and LAN).

What is the IPv4 address your OpenWrt box gets? If it is in the network, your problem will be solved by changing the subnet of the OpenWrt LAN.

That's a good thought. The IP of the OpenWRT router is in the same range the eeros router shows when it is connected, and the same range the PC showed when I bypassed both routers. The WAN address is in the 50.45.x.x range. Mine LAN is in the 192.168.0.x range. So that doesn't seem like the problem.

Thanks. Good suggestion. I had not tried it, but it is a great test. I reset it, and it came up at the defaults and got an external IP (50.48.x.x), but had the exact same problem. It must be some kind of filtering by the fox222 gateway or the ISP.

Try to ping a known place on the Internet by IPv4 such as If that works then you likely have a DNS issue rather than no Internet connection at all.

Does a traceroute (to anywhere) show the IP of the ISP's first router on the other end of the fiber? It may or it may not. If you get that IP try to ping it, both from the OpenWrt OS and from a LAN PC. These routers are usually configured to answer pings but not always.

Yes, I tried this, right from the diagnostic of the router and ping by IPv4 address doesn't work, either.