General OpenWrt support for Xiaomi AX3600 (Part 2)

Can you connect locally tftp 127.0.0.1 and type status?

yes, status works and get C0A80101.img as well. That also produces an output from the dnsmasq command: "sent /srv/tftpboot/C0A80101.img". I connected to the 192.168-ip of the notebook, not localhost. So it is bound to the correct interface as well

I think the tftp part is working. The prerequisite DHCP/BOOTP part is not: tcpdump on eth0 shows Request from router mac but no responses like an ip offer

I went the windows route and succeeded. With the help of your translations it was much easier this time :slight_smile: I now have ssh access to the original firmware.

It is unclear how to proceed now: There are two root partitions again, but current openwrt image has just one. Will flashing the initramfs-factory.ubi to mtd13 "just work"? I guess I'll just try - what can possibly go wrong now...

Update: it just worked. I had to switch to partition 1 as the documentation describes although I first didn't do it. Anyways, now there is just one partition. Looks good! Thanks for the support!

2 Likes

Follow the wiki steps - Install the firmware. It works fine

3 Likes

Roaming is not working with official SNAPSHOT of Xiaomi AX6
My english is not that well, will try to explain..
When using 802.11r there is no roaming at all.
Everything is set correctly with same mobility domain.
Need to turn OFF and ON the wifi to connect the 2nd AP, even when im standing near the AP.
Flashed back to original xiaomi rom, the roaming working flawlessly...

Any clue about it?

Not sure if this has been already solved, but I'd like to bring it up again.
I believe my isp server has blacklisted me because of the continuous requests because now I cannot connect to the wan anymore even on the original firmware and have to call support

Right after the timeout and disconnect described in the following forum I have constant pado timeout errors on the wan and are no longer able to get an ip

It'd like to know if in the final version there is a fix for this or if special configuration is needed.
Also, I cannot find any straightforward procedure to install the latest (stable?) version of openwrt and cannot find it on the releases website

Cannot help with wan stuff, but your way to latest openwrt. But beware, I'm not an expert on this, just a user (with a little background knowledge).

There are no stable versions yet, just snapshots. Look here (fixed url)

There were some config braking changes (network devices renamed, one root partition format) before the move from robimarkos github firmwares to openwrt firmwares. The exact way depends on your current version.
I had a too old version (from Jan 6th) with a bug and got a softbrick using "normal" sysupgrade, so I recommend going to the latest robimarko github release first and then to the openwrt snapshots.

The cure in my case was a ubiformat of openwrt's initramfs-factory.ubi followed by a sysupgrade. After that I could restore my old config backup (edit: which had the new network device names already). I guess this should always work, too, regardless of the starting point.

I shouldn't have issues as I just overwrote openwrt with the original firmware.
So then from here, having ssh access, how do I cleanly install a decent openwrt version which I will be able to upgrade to the stable one in the future?

**Edit
I was running this version Adding OpenWrt support for Xiaomi AX3600 (Part 1) - #9258 by imben

**Edit 2
I have now seen the link and a post above saying to follow the instructions on the wiki page for ax3600, but that still seems to be installing openwrt in dual boot mode, is that how I'm supposed to do it?
I've seen some comments about a single partition and 2 versions, what are those about, which is the better version?

I still have that config file and would love to be able to import it, but I don't think it's going to happen

I was about to quote the edit2 link :slight_smile:

Original firmware and most robimarko firmwares used 2 root partitions.
Openwrt will just use one (there is no choice). This is done using the ubiformat followed by sysupgrade.

Whether your config file works depends on too much to verify. Just try. I did, and it worked perfectly.
Only thing to consider: the network device names have changed recently and so have to be changed in your config backup if it is from before that time or your device will become inaccessible. The procedure is quite straightforward (untar, find/sed, tar) - there are recipes in this thread, basically replace all occurances of eth0 with wan and eth1-3 with lan1-3
If your config should not work, use factory reset (for ax3600: power off, press and hold button, power on, after 10s red led blinks: release button) -> openwrt with 192.168.1.1 on lan1 port and no root password

If you are on the stock firmware, please just follow the guide on Xiaomi Mi AIoT Router AX3600 Install the Firmware in the wiki.
This instructions don't install the firmware in dual-boot mode. We now have only single firmware partition with OpenWrt.
The openwrt-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi is to migrate to single firmware and the second flash with
openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-sysupgrade.bin
is to install OpenWrt "for real".

Thanks to both and @rossini @joba-1 for the help.
I have finally installed the latest snapshot and did the upgrade to single partition.
As expected there is no luci. Moreso, given that I need to setup a pppoe connection with a vlan I cannot install luci without doing that first.
So I'm now at the amazing search to web to learn how to setup stuff from commandline phase
*Edit
Dammit there's not even nano in here, I have to do stuff in vi :frowning:

i prefer winscp in this case (on Win), there you have a "normal" text editor

But if u're on linux, then MC, shell connect and then you have mcedit

I'm afraid there's no sftp server either

once you have your pppoe connection going it is just a matter of

opkg update
opkg install luci

learn vi once pays back for decades :stuck_out_tongue:

if you need to copy stuff, use scp (no sftp needed):

scp /your/file root@axhost:/tmp

winscp should work as well...

1 Like

I thought about just getting the package and installing it manually, but I can't find it in
https://downloads.openwrt.org/snapshots/targets/ipq807x/generic/packages/

**because it's in
https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/

winSCP uses SSH:
image

2 Likes

Just use the online imagebuilder and add luci + nano-full in your image :wink:

https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ipq807x%2Fgeneric&id=xiaomi_ax3600

3 Likes

Hmmm I bricked my ax3600 when updated from Robi's Marko builds 2 months old to latest snapshot. Now I recover it via TFTP but .... uboot request C0A81F66.img file instead of standard xiaomi firmware. Question is can I rename miwifi_r3600_firmware_5da25_1.0.17.bin to C0A81F66.img and it will be properly flashed without overwritting uBoot?

OK, renamed file to what he requested and it flashed and booted.

1 Like

Hi. I just tried to get my ax3600 to Openwrt. I followed the steps shown on https://openwrt.org/toh/xiaomi/ax3600 but my router keeps doing nothing but a reboot after the sysupgrade command. And yes, I tried it with stopped wpad service. It just reboots with a new clean system in Openwrt also with a new ssh fingerprint. What am I doing wrong? What is supposed to happen at this point. Sorry for these noob questions.
After the sysupgrade command it says "commencing upgrade, closing all connections" thats it.

1 Like

Is it now in a reboot loop, or after booting you can connect via ssh?

1 Like