General OpenWrt support for Xiaomi AX3600 (Part 2)

Continuing the discussion from Adding OpenWrt support for Xiaomi AX3600 (Part 1) - #10133 by Baden.

Previous discussions:

1 Like

I created a build for AX3600 and DL-WRX36 from the official openwrt

for the AX3600:
if a 1 part release from Robi was already flashed

uci set system.@system[0].compat_version=1.0
and then sysupgrade

^^ everything works :wink:

for the DL-WRX36:
if a 1 part release from Robi was already flashed
I did the same as with the AX3600
but then had no more connection over the network
(only after a reset on the device)
^^ does anyone have the same problem?

I upgraded yesterday from the pre-iface-rename release to the snapshot version from openwrt already, I had almost no issues (I had to delete 1 5g master mode config, as the 5g wasn't coming up; after recreating the config - everything worked)! Thanks again @robimarko and others, that was not an easy job!

1 Like

Please post your config of your dumb ap.
For me it seems you doing something wrong. There should not be a firewall on an ap or wan/lan.

I updated two WRX36 w/o any issues, however, I was already on Jan 9 snapshot that had new interface naming.

hmm i was on an version with the new names too...


If I understand your problem, I will detail how I updated my mesh access point.
Because we have to disable wpad we have to find a solution to update our AX3600 differently than the router.

  1. I start by resetting the device with the button
  2. I transfer the firmware in tmp with my computer by the default address
  3. As we did a reset the default WPAD is off so I run the command by PUTTY
    sysupgrade -n /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-sysupgrade.bin
  4. Once updated I modify the network file in /etc/config/ by adding a fixed address with the address of the gateway and the dns to be able to have access to the internet
config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.XXX.XXX'
	option netmask ''
	option ip6assign '60'
    option gateway 192.168.XXX.XXX
    option dns 192.168.XXX.XXX
  1. I reconnect with the new address with PUTTY
opkg update
opkg install luci
  1. Now that luci is installed, I can easily access the software
    I uninstall wpda-basic
    I install wpda-mesh-openssl
  2. I delete in firewall the two lines. Save
  3. In system startup: stop and disable dnsmasq, firewall, odhcpd
  4. I import my backup file and restart
1 Like

I have two routers with one (Secondary) connected in Wireless Repeater Mode. I have wired LAN port of Main Router to WAN port of Secondary Router. Once I flash openwrt firmware, how do I go about setting up the Secondary Router? I assume the above mesh instruction is only if I connect them wirelessly right?

Are there any instructions for how to configure both routers as dumb APs and connect them to a different router probably?

For update to last version, now I try to use the Luci functionality 'system -> Attended Sysupgrade'.
I found one new version :

but I have one error when I try to update :

It is not the new way to update ?


I wouldn't go as far as calling it "the new way" to update, but it's an option.

Here it's falling over over a deficiency in opkg (and in extention asu, using opkg) with two alternative -exclusive- provider of the same functionality, the hardware optimized (faster) libwolfsslcpu-crypto vs the unoptimized default libwolfssl. Both provide the same functionality (one fast, relying on ARM64 hardware crypto extensions, the other slower in software), but they can't be co-installed (as they're claiming the same object files to be their own).

For more advanced package managers, this would be a case for a Conflicts/ Provides/ Replaces dependency relation, but opkg isn't quite as smart - and you're complicating the issue with ASU here. It's not unexpected at all, to see ASU fall over conflicting and/or changed installed default packages in an upgrade - on the face of it, it simply tries to install everything present in the old image on top of the contents of the new to-be-created one, which will fail -badly- in cases like this (as issues are reported, the heuristics may be adapted to fix this particular issue, but technically it knows even less about package relations than opkg itself).

You will need to guide opkg (and if possible, ASU) here, explicitly pulling in libwolfsslcpu-crypto and keeping out libwolfssl (or vice versa).

That aside, new snapshot builds are appearing roughly daily, that doesn't mean you'd need to install each and every (new-) one of them, find out your own cadence you're comfortable with (maybe weekly, maybe every fortnight or monthly), but daily would be a bit excessive, unless you really know what you're doing and why.


is a bug/issue raised at regarding the libwolfssl conflict message ... )

I want to use the AX3600 as dump AP: DHCP Client in WAN and a WLAN connected to the WAN Interface, clients should get an IP Adress from the main router. That works not, clients do not get an IP Address. If i make the same on LAN Interface (without using the wan port) that works.
If I use WAN Port as DHCP Client and use the LAN Zoen with different IP Subent, that work too. But i want to have both:
privat WLAN connected with WAN (same IP Net as Main router) and guest WLAN connected with LAN on the AX3600 with different subnet. But the clients oft the private WLAN, connected with WAN do not get an IP Adress

Of course.
Here it is only my first update after the long and beautiful (all messages reading !) travel with Ansuel/Roby/... repository :slight_smile:
After this trying (only for curiosity) I will follow the official stable version except all ~6 months with an update of software.

Dumb AP doesn't use WAN interface, you need to connect the dumb AP LAN port, to your router LAN port.
Read the wiki, follow the steps there.

my dumb AP configuration

Bellow is my dumb AP configuration, but my router IP is, if your router is, you must use your .1. subnet, replace all my .0. with your .1.


1- Dumb AP LAN interface must have a static address on the same subnet as the main router's LAN interface:
(also make sure the dump AP IP is not dynamic distributed by your router DHCP server to other machines)


2- Configure the DNS server:

3- Disable dhcp server:

If you have further questions about dumb AP, please open a thread asking or PM.

1 Like

Now that AX3600 is present in official channel, is there any FAQ on how to convert to single partition from robimarko's snapshots w/o softbricking and TFTP:ing Chinese FW from scratch?

yes use the wiki..................

1 Like

Completely forgot about wpad thing and I bricked mine. When I press and hold reset the led is blinking for a few secs and then the orange light is constant. I cannot unbrick it. Any solutions?

Stopping WPAD is needed to make sure the flash happens; Worst case, no flash; Which means it can't softbrick.

Did you come from an old build with 2 partitions and not migrate or had already migrated to single partition and the brick occurred when transitioning to official builds?

You can unbrick following the instructions here in wiki.
You should grab the official openwrt built files at this point, not Robi's.

TFTP explained in Wiki.
For Chinese text in web screen of firmware I have see into Youtube to have the goods 'clicks' because I don't understand !