Geforce Now throttled/packages lost with OpenWrt

Hello all

I am a longtime lurker and user of OpenWrt for quite some years and in general quite happy with the possibilities. However recently I encountered some issues where I am not sure how to continue.

So recently I purchased a year access to Geforce Now. A nice alternative to console gaming (in combination with a Nvidia Shield) by streaming the games from an Nvidia server. My connection is 100/100 mbit fibre internet from T-Mobile in the Netherlands. I replaced my ISP provided Vigor with a Netgear R6220 and TP-link Media Converter. In all scenario's my connection works as it should. Except with Geforce Now.

The connection is always capped at 10mbps with roughly 10% package loss (based on their test). This is also experienced in- game. When there is a lot going on in screen the image quality dives and the stream starts stuttering. So tried a bunch of trouble shooting from the Nvidia website which didn't helped. I also tried using another router today (an tp link c2600 with openwrt) which also didn't work.

I once tested the service at my brother's place (also T-Mobile) where it worked as expected. He has an ISP modem (an Huewei). This leads me to believe that is my modem. But I don't what would be the next step in troubleshooting this.

I hope somebody here might have some ideas where I can look next. An alternative would be to use the Vigor again (at least to confirm that it really is OpenWrt) but even then I would be very much inclined to figure out why it doesnt work on OpenWrt.

Thanks in advance for any future comments.

Unfortunately you're not very specific about your connection type and the hardware (in particular the "TP-link Media Converter" or the "Vigor"), which makes it hard to provide advice, given the usual confusion of fttc+vdsl or ftth I'm not even really confident about your actual connection type (symmetric bandwidth kind of suggests ftth, but…).

Personally I'm not really familiar with Draytek's ftth devices, but based on their (business oriented) VDSL modem firmware, I would expect (hope) it to have a 'modem' mode (unless the potential ISP branding has removed that option), which would reduce it to a mere media converter without its own router functionality (their VDSL modems can do this). Testing this would confirm if your "TP-link Media Converter" is indeed the culprit, which would be one of my top suspects.

The ISP modem is this model:

The ISP removed the modem mode so I would be stuck using it as a router as well.

The media converter is the TPlink MC220L.

It is indeed FTTH.

Why would you think that the MC220L is the first suspect? Because then it would be an easy fix, I would just buy some other device to do this.

I still don't really understand the situation, the Vigor 2860 would be a VDSL2+vectoring modem-router, but the MC220L is just an ethernet to SFP media converter, which either takes a VDSL modem in SFP form factor or a SFP single-mode/ multi-mode fibre transceiver. These SFP/ SFP+ modules matter quite a bit as well.

The ISP setup is that the SFP module is inserted in to the vigor.

I opted to change that because I didn't want use their router.

So the SFP module is plugged in to the MCL220. Which converts it to ethernet. The ethernet cable is plugged in to the WAN port of my OpenWrt device.

Regarding the SFP module I just reused the ISP provided one.

So I swapped out the OpenWrt router with the ISP provided router/modem solution (the one which supports the SFP module directly) and it is showing exactly the same behavior. So the it seems the culprit is indeed my ISP or Nvidia themselves. From a dutch forum I understood that other people, who have a similar setup with the same ISP, do not have the same issues with Geforce Now. So I am starting to suspect that my fibre connection might be compromised. Anyway I am happy that it is not OpenWrt (or my media converter for that matter)

And you don't suspect your 10 Mbps connection whatsoever???

Well one out of twenty times when I'm running the network test from Nvidia it hits 40mbps with a package loss of 50-80%. I suspect that due to the packet loss it is being capped somehow...

Anyway if my 4g phone can do 20mbps with <0.1% package loss then my 100mbps fibre connection should be able to top that.


Which one is it...100 or 10?

Right..... So the nvidia test which I run always gives back these stats (10mbps)

While my actual internet connection is much faster. (100mbps)

Edit: for what it's worth it's not the openwrt router or the TPlink mc220l. The culprit would have to be something both this setup and the ISP setup share. Like the SFP module, or the fibre cable (perhaps it's contaminated), or the routing used by my ISP.

Anyway this topic can be closed tbh