[GCC 7.2 BUILD] Optimized TP-Link Archer C7 V2 AC1750 LEDE Firmware

Now you know :wink:

i already knew lol thats why i was asking, sorry i didnt ask him "hey @root why did you take bbr out of the equation?"

n00b@user$~/sh wheresbbr.sh
permission denied
cli0brand0@lede$sudo sh wheresbbr.sh

im horrible @comicrelief sighs

ok so this is how i do it:

git clone https://git.openwrt.org/openwrt/openwrt.git lede
cd lede

./scripts/feeds update -a
./scripts/feeds install -a

i then open /home/user/lede/target/linux/ar71xx/config-4.9 and added


copied files from @r00t github to buildroot directory which is /home/user/lede/
including .config modifying that to my flavor

place the patches in fixes folder like one of the users on this thread stated, or just cp patches file from @r00t master zip to your buildroot directory that you downloaded and run this:

for i in patches/*.patch; do patch -p1 < $i; done
make menuconfig
or make defconfig
or make oldconfig
make -j 4 or make -j1 V=s

make defconfig default configuration file im going to sync the build with i believe
i use -j 4 because i have four cores per socket
i got this information by running lscpu

does that sound about right?

Do not forget to include CONFIG_NET_SCH_FQ, which is not included by default if I remember correctly. BBR must be used with the fq qdisc.

1 Like

thanks!, ill check the config-4.9 and place it in there.

It's not necessary to edit the config files manually if you look at the r00t patches there's:
If you look inside:
So if you apply that patch you will get BBR.

idk maybe its me but for some reason when i ran the patch compared to modifying it myself it would finish the build, asking me what i wanted as default. where as when i would use the patches, some of them didnt work and .... 'world' failed. i was thinking maybe it was something wrong with 7.3 gcc? idk

After the feed update/install you need to patch the lede source (with the r00t patches), here's the first gotcha, some files are different because they have been updated by the LEDE programmers and the patch don't apply correctly, so you need to "re-make" the patch with the diff command. Well after correcting the patches (a tedious and boring task) and apply them, you must copy the .config file, after that run "make menuconfig" (if you need to make some changes you can do this here) and exit.
If you don't want to make changes just run make menuconfig and exit (it will ask to save your changes-> press yes).. if you don't run make menuconfig and save, when you run make it will ask for defaults.

I've not seen any problems with gcc or packages, the only problem occurs when you remake the patch with the wrong data.
I compile a new build every 1 week because of that, sometimes then the LEDE source gets updated a patch or two gets broken.

well thanks for that piece of info!! being different is tedious sometimes :frowning: anyways clio i appreciate all your assistance, hopefully ill figure this all out in time :slight_smile:


According to https://en.wikipedia.org/wiki/List_of_WLAN_channels the maximum power transmit for channel 149 is 25mW (In Europe).
Now I have my C7 v2 on channel 149 and the Tx-Power is 13 dbm (19,9 Mw), as far as I know Archer C7 is 30 Mw capable. Why is not working in 25 Mw? Any idea?

Thanks a lot,

-> Can I adjust the transmit power?

i think i found the problem with patches in the patches-4.9, looks like 221-kernel-mtune-74kc.patch.patch should probably only be 221-kernel-mtune-74kc.patch as well as
222-kernel-branch-likely-74kc.patch.patch, you think that could be an issue?

I'm almost sure that some patches won't work and need to be remade.

yeah theres a few of em, mtune, remove-debug, lzma-loader, and bbr those need to be revised.i thought that the patches-4.9 had an extension problem, but i guess applything @r00t patches just as they are caused the .patch.patch issue.

the patch.patch files aren't incorrect, they don't patch a file, they create a new file.

so when the patch file shows blah_blah.patch.patch thats not an issue?

This is my 812-enable-bbr-patch:
I don't know if it's working, I've not checked it.

--- /dev/null 2018-01-17 18:12:36.438735787 -0300
+++ ./target/linux/ar71xx/config-4.9 2018-01-17 20:25:07.000000000 -0300
@@ -462,3 +462,7 @@

ill try it right now.

... you shuld compare with yours first.