Fujitsu Futro S920 + OpenWrt random reset

I got a Fujitsu S920 with AMD GX-222GC and naturally I installed OpenWrt.

All good, except it's not stable, reboots when I do a speed test and also randomly the rest of the time.

The specs are:

  • FUJITSU FUTRO S920/D3313-G1, BIOS V4.6.5.4 R1.16.0 for D3313-G1x 08/13/2018
  • AMD GX-222GC SOC with Radeon(TM) R5E Graphics (family: 0x16, model: 0x30, stepping: 0x1)
  • dell x3959 intel pro/1000 PT dual-port gigabit ethernet
  • 4G ram, 32M reserved for video
  • 8G mSATA

tried the following:

  • changed the thermal paste on the CPU and added a fan on top
  • fan on the x3959 radiator
  • extra 3000 microF capacitor on the 19v input

I tried
OpenWrt 22.03.0-rc5 r19523-bfd070e7fa / LuCI openwrt-22.03 branch git-22.167.28394-8a4486a
and 21.02.3 using 64 bit version generic-ext4-combined

LE: RAM looks ok on memtest, and looks stable on some burn tests with iperf3

how can I debug this ?, is there something output on the serial line when the crash occurs ?

Thx,
Geo

Open a ssh session, and run htop, see if you can see anything at the time of reboot, the session should freeze when it happens.

a second ssh session running logread ; logread -f might also provide further information.

'logread -f' doesn't get a chance to output anything.
Is the kernel configured to output a kernel panic or something on a serial line ?

It outputs on serial where available.

Does the system crash, even if you remove the ethernet traffic?
Does it crash on both Intel ports ?
Does it crash if you use the built in NIC, and some external USB dito?

tried different combinations with the x3959 card and it still crashes, even replace'it with an identical one.
removed the x3959 and added tp-link ue300 dongle, all good so far and the speeds are ok also.
On the other side I did some burn tests with the x3959 using iperf3 ( multiple threads, both ways the same time ) on debian 11.4 and no crash.

Perhaps it's a power issue?
What's the power rating for that intel chip/card?

Was the Debian test on that same host?
Did you compare the CPU load between Debian and OpenWRT, during those tests?
Was the Iperf3 test done in the same subnet, or doing routing?

x3859 specs are saying 4.95W, s920 is about 20w, power source is rated for 35w
added extra 3000 microF capacitor on 19v

yes, Debian 11.4 on the S920
the test was performed on the same subnet, no routing.
have not compared cpu loads.

It's the routing that requires resources, if possible, redo the tests, and compare the CPU load, while doing it.

tested while routing in private network, all fine in all combinations with +940 Mbits/sec results.
For some reason when put on the ISP wire random crashes occur.
In the end I replaced the Intel x3859 card with tp-link TG-3468 - same chipset as the one onboard.

tp-link TG-3468
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Onboard
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

the measured performance is the same w/o the heat and random crashes.
thx

1 Like