Fritzbox 7530 as wan bridge

I'm trying to replicate the configuration I had on my TP-Link w8980, on a Fritzbox 7530.

The aim is to have it function as a dsl to ethernet adaptor, with all traffic passing through untouched to my main router which handles DHCP.

This works fine using the w8980 with the following config.

root@wan-br:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd32:7c0d:e0cf::/48'

config dsl 'dsl'
        option ds_snr_offset '0'
        option line_mode 'vdsl'
        option firmware '/lib/firmware/vr9-B-dsl.bin'
        option annex 'b'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '192.168.1.2'

config device
        option name 'dsl0'
        option macaddr 'ec:08:6b:6a:8a:bc'

config interface 'wan'
        option proto 'none'
        option device 'br-wan'

config device
        option name 'eth0'

config device
        option name 'lan1'

config device
        option name 'lan2'

config device
        option name 'lan3'

config device
        option name 'lan4'

config device
        option type 'bridge'
        option name 'br-wan'
        list ports 'lan4'
        list ports 'dsl0'
        option bridge_empty '1'

When I try to replicate this with the 7530, I get really odd results. Some things work (ping, traceroute), some things don't at all (most web pages) and speed is very slow.

This is the config from the 7530.

root@br-wan:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd68:864b:a113::/48'
        option packet_steering '1'

config dsl 'dsl'
        option annex 'j'
        option ds_snr_offset '0'
		option line_mode 'vdsl'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'

config device
        option name 'dsl0'
        option macaddr '3C:A6:2F:55:32:94'

config device
        option name 'eth0'

config device
        option name 'lan1'

config device
        option name 'lan2'

config device
        option name 'lan3'

config device
        option name 'lan4'

config device
        option type 'bridge'
        option name 'br-wan'
        list ports 'dsl0'
        list ports 'lan1'
        option bridge_empty '1'

config interface 'wan'
        option proto 'none'
        option device 'br-wan'

Does anyone know what's going on? Am I even doing this the right way?

Do you mean it should work like a pure modem, where your main router will get a public IP from the Fritz!Box or do you want to use the routing function of the Fritz!Box and do a double NAT?

Fully bridge two ports (dsl0>lan1), unmanaged. Factory firmwares usually describe it as 'bridge mode'.

I don't think the AVM firmware offers this function. I'm starting to think there's a reason.

Yes, this function isn't available anymore on the stock firmware since a few years. Afaik the last version with it was 6.50 or 6.7x.

But with OpenWrt it is still doable. Only i don't know how to do it.

Let's ask someone who might have the knowledge:
@moeller0 Aren't you using a 7520 as a modem with another router?
Maybe you could give us a hand?

In the meantime, maybe this contribution from him will help.

1 Like

Here is how my /etc/config/network looks like:

root@OpenWrt_FB7520:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcd:4cf3:765d::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option tone 'b'
	option annex 'b'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ip6assign '60'
	option device 'br-lan.42'
	list ipaddr '192.168.100.1/24'

config device
	option name 'dsl0'
	option macaddr '98:9B:CB:C0:F5:BB'

config interface 'wan'
	option device 'dsl0'
	option proto 'none'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '42'
	list ports 'lan1:t'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '7'
	list ports 'lan1:t*'

config device
	option type '8021q'
	option ifname 'dsl0'
	option vid '7'
	option name 'dsl0.7'

config device
	option type 'bridge'
	option name 'br-dsl'
	list ports 'br-lan.7'
	list ports 'dsl0.7'

config interface 'MODEM'
	option proto 'none'
	option device 'br-dsl'

This works for me... my router tags PPPoE packets as VLAN7 which are passed through the FB as is (but note I opted for having the DSL interface also tag VLAN7, so the router to DSL bridge can use any other VLAN ID as well0. To access the OpenWrt GUI on the 7520 I use VLAN42 so I can access the nice Status -> DSL Status page easily.
Also note that in this configuration the FB has no internet access itself! I pondered whether to have the 7520 get Internet from my primary router via yet another VLAN, but opted for keeping things obviously safe, hacking into the 7520 will not get you a path around my firewall.... But I think others have configured the rest of the FB to act e.g. as an additional AP in the internal network.

Note however that with DSA br-lan defaults to not using a VLAN tag, which makes it a tiny bit involved in changing br-lan to use VLAN-IDs. I think you first need to change Custom)

then save but not apply this change, then navigate to Network-> Devices an click configure for br-lan and configure the Bridge VLAN filtering tab appropriately:

Also make sure to add the dsl bridge and dsl vlan tag in the device section:

Then you should be able to save and apply the whole caboodle.

For installation purposes I also added a WLAN on the 7520 to allow me some access in case my VLAN games failed, but things are stable now and I disabled both radios to save some energy....

Hope this helps.

1 Like

AVM did offer that in the past and at one point removed it, as far as I know without any official rationale.
I have two not mutually exclusive hypothesis:
a) AVM wants to trade in value-added routers, not in "dumb/dedicated" modems
b) the ISPs that likely are big customers of AVM (a least in Germany some of the smaller ISPs often supply branded Fritzboxen as provider router), and those ISPs might not actually want to make it easy for endusers to move away from the provider router (or at least a router that offers TR-069/369 for remote configuration)

But these are purely speculative....

Mind you, Fritzboxen still do offer a PPPoE Passthrough mode, so if the ISP requires PPPoE one can simply not configure the PPPoE credentials in the Fritzbox itself and activate PPPoE passthrough to get something approximating a bridged-modem with stock FritzOS, not sure how well this is supported by AVM.

Final note after switching to OpenWrt it becomes pretty easy to use @janh's excellent go-dsl tool to get diagnostic values out of the Modem:

this is in addition to luci-mod-dsl which offers nice information from the OpenWrt GUI's Status-> DSL Status page:



1 Like

@moeller0 thanks for the advice. I'll try this approach and report back.