Fritzbox 7412 - DSL Connection Established - No Internet

Hello,

I installed OpenWrt on a Fritzbox 7412 and extracted the DSL firmware. I followed this advice: VDSL+VoIP Fritz!Box to OpenWRT-on-FB-7412 migration cheat sheet The VDSL Connection in the Overview has this output:

DSL Status
Line State: UP [0x0]
Line Mode: G.993.5 (VDSL2 with down- and upstream vectoring)
Line Uptime: 6m 38s
Annex: B
Profile: 17a
Data Rate: 121.055 Mb/s / 32.179 Mb/s
Max. Attainable Data Rate (ATTNDR): 133.398 Mb/s / 40.516 Mb/s
Latency: 655.23 ms / 0.0 ms
Line Attenuation (LATN): 10.9 dB / 10.2 dB
Signal Attenuation (SATN): 10.9 dB / 10.0 dB
Noise Margin (SNR): 7.4 dB / 13.0 dB
Aggregate Transmit Power (ACTATP): -1.9 dB / 14.3 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES): 1 / 0
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 170 / 170
Header Error Code Errors (HEC): 0 / 0
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID: Broadcom 193.218
Power Management Mode: L0 - Synchronized

BUT: The 7412 has no internet connection, I cannot update the OpenWrt software sources on the device and my connected devices (Laptop directly connected through the eth0 port and in the future a wifi router) have no connection to the internet.

My network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '####:####:####::/48'
        option packet_steering '1'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option ds_snr_offset '0'
        option line_mode 'vdsl'
        option tone 'bv'
        option firmware '/lib/firmware/vr9-B-dsl.bin'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.22.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0'
        option force_link '0'

config interface 'wan'
        option proto 'pppoe'
        option username 'H1und1/################@online.de'
        option password '###############'
        option ifname 'dsl0.7'
        option ipv6 'auto'

config device 'wan_dsl0_dev'
        option name 'dsl0'
        option macaddr '##:##:##:##:##:##'

Can somebody help me with this? Thank you.

You could try dsl0.8 here, apparantly some lines provided by 1&1 need 8, not 7.

Otherwise you should have a look into the system logfile what the PPPoE client complains about.

1 Like

I forgot the firmware version: OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363

dsl.07 seems to work better with me.

he are some screenshots of the network interface, the dsl connection and the network.

The Device seems to be connected, but I can't update the internal software sources. Maybe it's the networking settings?

/etc/config/dhcp

                                                                                            
config dnsmasq                                                                              
        option port '0'                                                                     
        option rebind_protection '1'                                                        
                                                                                            
config dhcp 'lan'                                                                           
        option interface 'lan'                                                              
        option ignore '1'                                                                   
                                                                                            
config dhcp 'wan'                                                                           
        option interface 'wan'                                                              
        option ignore '1'                                                                   
                                                                                            
config odhcpd 'odhcpd'                                                                      
        option maindhcp '0'                                                                 
        option leasefile '/tmp/hosts/odhcpd'                                                
        option leasetrigger '/usr/sbin/odhcpd-update'     ```

/etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'wan lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'
        option enabled '0'``````

renewed /etc/config/network

config interface 'loopback'                                                                       
        option ifname 'lo'                                                                        
        option proto 'static'                                                                     
        option ipaddr '127.0.0.1'                                                                 
        option netmask '255.0.0.0'                                                                
                                                                                                  
config globals 'globals'                                                                          
        option ula_prefix '####:####:####::/48'                                                   
        option packet_steering '1'                                                                
                                                                                                  
config atm-bridge 'atm'                                                                           
        option vpi '1'                                                                            
        option vci '32'                                                                           
        option encaps 'llc'                                                                       
        option payload 'bridged'                                                                  
        option nameprefix 'dsl'                                                                   
                                                                                                  
config dsl 'dsl'                                                                                  
        option annex 'b'                                                                          
        option ds_snr_offset '0'                                                                  
        option line_mode 'vdsl'                                                                   
        option firmware '/lib/firmware/vr9-B-dsl.bin'                                             
        option xfer_mode 'ptm'                                                                    
        option tone 'bv'                                                                          
                                                                                                  
config interface 'lan'                                                                            
        option type 'bridge'                                                                      
        option proto 'static'                                                                     
        option ipaddr '192.168.22.1'                                                              
        option netmask '255.255.255.0'                                                            
        option ip6assign '60'                                                                     
        option force_link '0'                                                                     
        option ifname 'eth0 pppoe-wan'                                                               
                                                                                                  
config interface 'wan'                                                                            
        option proto 'pppoe'                                                                      
        option username 'H1und1/##########@online.de'                                    
        option password '#############'                                                                
        option ipv6 'auto'                                                                        
        option ifname 'dsl0.7'                                                                    
                                                                                                  
config device 'wan_dsl0_dev'                                                                      
        option name 'dsl0'                                                                        
        option macaddr '##:##:##:##:##:##'      ``````

Multiple mistakes in the configuration like:

  • Bridged pppoe-wan and eth0 under lan
  • No dhcp server in lan
  • No nameserver defined
  • wan interface in lan firewall zone

Better reset to defaults and start from the beginning, do only the needful to bring up the dsl and the pppoe. Everything else will just work.

2 Likes

I have a static address on my notebook. The problem is that the router itself cannot even update its own software sources.

@trendy

Thank you, is there something I should do especially after I reset it? I only want it to dial in the Internet. No routing function.

This configuration part looks correct and is essential for the internet connection:

config atm-bridge 'atm'                                                                           
        option vpi '1'                                                                            
        option vci '32'                                                                           
        option encaps 'llc'                                                                       
        option payload 'bridged'                                                                  
        option nameprefix 'dsl'                                                                   
                                                                                                  
config dsl 'dsl'                                                                                  
        option annex 'b'                                                                          
        option ds_snr_offset '0'                                                                  
        option line_mode 'vdsl'                                                                   
        option firmware '/lib/firmware/vr9-B-dsl.bin'                                             
        option xfer_mode 'ptm'                                                                    
        option tone 'bv'                                                                          
                                                                                                 
config interface 'wan'                                                                            
        option proto 'pppoe'                                                                      
        option username 'H1und1/##########@online.de'                                    
        option password '#############'                                                                
        option ipv6 'auto'                                                                        
        option ifname 'dsl0.7'                                                                    
                                                                                                  
config device 'wan_dsl0_dev'                                                                      
        option name 'dsl0'                                                                        
        option macaddr '##:##:##:##:##:##'

Leave the rest to defaults.

1 Like

It works!

Thank you both!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.