Fritz 7412 slow internet connection

i managed to install OpenWrt on the router. After applying some tipps from this thread VDSL+VoIP Fritz!Box to OpenWRT-on-FB-7412 migration cheat sheet
It works well - however it is very slow. From possible:

Data Rate: 111.883 Mb/s / 42.463 Mb/s
Max. Attainable Data Rate (ATTNDR): 133.841 Mb/s / 43.615 Mb/s

I only get around 30.000 Mb/s. I wonder if this has something todo with the line mode:

Line Mode: G.993.2 (VDSL2, Profile 17a, with down- and upstream vectoring)

Shouldn't this be G.993.5? And if so, how can I set it?

I connected a 7350 to the same DSL Port, which got the Line Mode: VDSL2 17a G.Vector (ITU G.993.5). A speed test shows 100 Mbit. Does anyone know how I can change this setting in OpenWrt?

That sounds about right if you run Smart Queue Management / traffic shaping on the AVM Fritz!Box 7412.
Its CPU power is poor.

You might verify the CPU bottleneck by watching its CPU load with e.g. htop while doing a speed test.
If you see one of the two cores constantly at 100%, then that is likely the cause.

Also I have the impression that the switch from OpenWRT 19.07 to OpenWRT 2021.02 worsened the situation.

This aspect I do not know much about.

I did some testing. Load average is < 1 when I do a speed test. Disabling SQM did not show any improvements. The CPU might be poor but I don't think it's the main issue here.

As it seems I am using a slightly different firmware version than you do. The sha1sum does not match. I need to investigate that.

Ok, I have tried firmware version and, with no notable differences in speed. It's always sth. between 25 and 30 Mbit. I also changed from Annex B to Annex J which didn't change anything. I guess this setting does not matter for vdsl connections. Unfortunately, I am nowhere close to @eomanis speed of 80 MBit. And openwrt always shows the wrong line mode of G.993.2 instead of G.993.5 (as in the fritz box or with the stock rom). For me, this might be the closing chapter for OpenWrt I am out of ideas currently. :cry:

Side note: OpenWrt decided on it's own to switch back to Annex B no matter the setting in the DSL options menu.

Opened a bug report for the wrong line mode here:

I gotta say this was at the very beginning when I had no SQM running, and with OpenWRT 19.07.

Now, with SQM and on OpenWRT 21.02, I only get effective 37 MBit/s down and about the same speed up. This is despite the broadband modem having a stable sync with data rates of 109 MBit/s down and 42 MBit/s up.

I am very sure that processing power is the bottleneck for me, because I see this in htop while the speed test is running:

Note that CPU0 is saturated. This is the CPU core that receives all broadband modem interrupts, as can be seen from the vrx200_*: interrupt counters:

root@router:~# cat /proc/interrupts 
           CPU0       CPU1       
  7:  183601493  133293651      MIPS   7  timer
  8:     422814     395552      MIPS   0  IPI call
  9:    3253833   15239590      MIPS   1  IPI resched
 63:   29694735          0       icu  63  mei_cpe
 72:   54743360          0       icu  72  vrx200_rx
 73:   76305039          0       icu  73  vrx200_tx
 75:          0          0       icu  75  vrx200_tx_2
 96:  124697346          0       icu  96  ptm_mailbox_isr
112:        304          0       icu 112  asc_tx
ERR:          1

For what it's worth, due to not having reasonable CPU power, I am using the simplest SQM mode possible, as using e.g. queueing discipline cake with SQM scripts piece_of_cake or layer_cake reduces the throughput to something around 20 MBit/s.

# Available queue disciplines: See directory /var/run/sqm/available_qdiscs
# Available SQM scripts: See directory /usr/lib/sqm
uci set sqm.eth1.qdisc='fq_codel'
uci set sqm.eth1.script='simplest_tbf.qos'

I have G.993.2 as well:
"mode": "G.993.2 (VDSL2, Profile 17a, with down- and upstream vectoring)"

According to this web site, G.993.2 with profile 17a is not a known combination; also G.993.2 is supposed to not have vectoring and only have up to 50 MBit/s downstream.

Since it says Profile 17a, with down- and upstream vectoring I am inclined to believe that this is a bug in the reporting, and it is really using G.993.5 instead.


@erikp As an fellow 7412 owner I can assure that is not a bug . Device is slow but it should hit ~80Mbit routing with software offload and packet_steering via LAN . DSL to WiFi is maybe half of above . My sync is 67Mbit so only that I could test.
I also run custom build with with pull 4353 and 4339 and with VPE-IRQ patch with modem only .It just work for me.
Also based on Your sync reports 100Mbit can be limiting factor with modem mode . ex 7360 7362sl is cheap gigabit version
utilization in modem mode with ~60Mbit download

root@7412:~# cat /proc/interrupts
           CPU0       CPU1
  7:  123169933  121810525      MIPS   7  timer
  8:  237527855    1476214      MIPS   0  IPI call
  9:    6619849   17186286      MIPS   1  IPI resched
 63:   59145772          0       icu  63  mei_cpe
 72:         18  298950174       icu  72  xrx200_net_rx
 73:         20  449483288       icu  73  xrx200_net_tx
 96:  715806710          0       icu  96  ptm_mailbox_isr
112:     123560          0       icu 112  asc_tx
113:          0          0       icu 113  asc_rx
114:          0          0       icu 114  asc_err
126:          0          0       icu 126  gptu
127:          0          0       icu 127  gptu
128:          0          0       icu 128  gptu
129:          0          0       icu 129  gptu
130:          0          0       icu 130  gptu
131:          0          0       icu 131  gptu
144:         38     236583       icu 144  ath9k
161:          0          0       icu 161  ifx_pcie_rc0

@eomanis thx for reporting back. Well in that case it might be just a minor display bug. :slight_smile:

@nicefile it's good to know that more is theoretically possible with a custom build. In my tests, I ran the speed test's directly from the OpenWrt device, so no wifi involved. I will check on the building system of OpenWrt once I have the time. For the moment I will be using the 7412 as a mere mesh node, without the modem functionality. That works great!