Fresh install unable to connect ROKU

Hows goin fellas? so I finally got around to installing openWRT 19.07.3 .img 19.07.5 .bin yesterday. the install went really smooth and it seems to be working great. I can already tell im going to love it, but my old ROKU Express 3910 2.4N band cant find the network. all my other devices phones laptops etc don't have an issue on either 2.4 or 5GHz. my roku is all i have for watching tv so its a necessary device. I've tried all the channels and bands that are available graphically without any change. almost all of my settings are the defaults so far i didn't make any changes to the firewall or really much else aside from setting passwords...
My device is linksys WRT1900ACS

root@OpenWrt:/etc# cat openwrt_release openwrt_version 
DISTRIB_DESCRIPTION='OpenWrt 19.07.5 r11257-5090152ae3'
 and config is  
root@OpenWrt:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'US'
	option txpower '8'
	option htmode 'VHT80'
	option channel '108'
	option legacy_rates '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option country 'US'
	option htmode 'HT20'
	option txpower '8'
	option channel '11'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr ''
	option key 
	option ssid '2.4GHz'
	option isolate '1'
	option encryption 'psk2+ccmp'

config wifi-iface 'wifinet2'
	option network 'lan'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option isolate '1'
	option key 'sorryifindmyselfunabletopostthis'
	option ssid ''

config wifi-iface 'wifinet3'
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio1'
	option mode 'ap'
	option network 'IoTV'
	option disabled '1'

the bottom wifi3 was a troubleshooting thing i was playing with it wasn't working prior.
actually i was just reading through my post you think its the isolation?


If you scan for networks on the Roku, does it see any wifi at all?

yeah i can find the neighbors and it worked on the stock FW changing isolation settings didn't help....

well i guess you can count this as solved i went and bought one that can connect to Ethernet now its working fine and i can take my time playing with the old one figure out why it wont connect... if i figure it out ill post it if somebody else runs into the same issue maybe it will help...

Start by resetting it.

Yeah I already went through all the basic steps before I posted things like resetting it I've also tried all the encryption settings bands and channels... Interesting the new one that can search on 5G band and is substantially newer can't find the wireless network either I can find the neighbors and it's brand new It doesn't matter because I can connect it hardwired but it's interesting It makes me wonder why.... Considering all my other devices that I've tried to connect so far can find it....