WRT1900ACS running Openwrt connected to the ONT via the INTERNET port.
TL-SG105E switch connected to port 1 on the WRT1900ACS. All of my client devices are connected to this switch.
Our ISP provides the internet over VLAN 35, and I've got the Openwrt router configured as such and it works fine.
The ISP provides a ZTE H298A router which integrated VOIP functionality and has two telephone ports at the back. Checking settings for VOIP on this router shows the following:
It appears to be separate VLAN 46. I'd like to be able to connect the H298A router to the TL-SG105e switch and have the VOIP data be forwarded. I'm guessing this would work if I could connect the H298A's WAN port to one of the LAN ports on the back of the TL-SG105e and somehow forward VLAN 46 to it. Is that possible?
Yes use the WRT1900 switch to bridge over vlan 46, tagged on a port for the old ISP router and tagged to the ONT.
SInce it is DSA you'll need to rearrange to bridge-vlans to get proper hardware switching.
Put all the Ethernet ports (including wan) into one bridge.
Create bridge-vlans 1 (for LAN), 35 (ISP), and 46 (VoIP).
Members of these bridge vlans are wan tagged in both 35 and 46, the port for the old router (VoIP box) tagged in 46, and the other lan ports untagged in 1.
Change lan device to br-lan.1, wan device br-lan.35.
VLAN 46 has no interaction with OpenWrt software, but you may need to declare a dummy interface of proto none, device br-lan.46 to properly instantiate the bridge.
Thanks for the reply, I'm currently trying to process it.
I would like to also mention that I also have a PPPoE interface setup on wan.35 which allows me to connect to the internet. How is does that factor into the changes you have suggested? For reference here is my current configuration:
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr '....'
config device
option type '8021q'
option ifname 'wan'
option vid '35'
option name 'wan.35'
config interface 'internet'
option proto 'pppoe'
option device 'wan.35'
option username '....'
option password '....'
option ipv6 'auto'
option mtu '1492'
option peerdns '0'
Put all the Ethernet ports (including wan) into one bridge.
So from Network>Devices, change the existing br-lan bridge to also include the wan port, right?
Create bridge-vlans 1 (for LAN), 35 (ISP), and 46 (VoIP).
From Network>Devices click on Add device configuration and then create three new VLAN (802.1q) devices with VLAN IDs of 1, 35 and 46. Would the base device be the bridge mentioned above, br-lan?
Members of these bridge vlans are wan tagged in both 35 and 46, the port for the old router (VoIP box) tagged in 46, and the other lan ports untagged in 1.
So basically I'm creating a separate network between lan1-3. Then, I'm allowing packets tagged with 35 coming from WAN to enter the router (but they're not being routed anywhere). I'm creating another network between lan4 and wan that only passes in packets tagged with 46.
Change lan device to br-lan.1,
So from Network>Interfaces, edit the LAN interface and change it's device to from br-lan to br-lan.1
wan device br-lan.35.
Similarly from Network>Interfaces, change the PPPoE interface device from wan.35 to br-lan.35
VLAN 46 has no interaction with OpenWrt software, but you may need to declare a dummy interface of proto none, device br-lan.46 to properly instantiate the bridge.
By "proto none" do you mean selecting "Unmanaged"?