Force client (my OpenWrt device) to connect only via 5GHz

Hello. I'm using OpenWRT on Raspberry Pi 3B+ as a wireless client to connect to some dualband AC AP (which is not under my control) and I want to force it to use 5GHz band exclusively.

I haven't found anything which could do that in . The band seems to be completely ignored on clients.

You can set the BSSID (ie. MAC address) of the AP (5GHz) in OpenWrt client This way the OpenWrt will only connect to the 5GHz.
LuCI --> Network --> wireless. Click on SCAN (5GHz) and you will have the BSSID of the 5GHz wifi you want. You can add it afterward, and there is a checkbox to force to link only to this one.


If you setup the STA config on the 5GHz radio, it will only use 5GHz.

1 Like

Raspberry 3B+ does not have two radios. It has one dual band radio and you can only use on band at the same time. It literally has only one phy entry in iw list.

I have no checkbox in Luci but just specifying a correct BSSID works. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.