Flashing OpenWrt FritzBox 3370


I was following https://openwrt.org/toh/avm/fritz.box.wlan.3370 but I could not get into ftp mode of bootloader for a while...

Then I found https://wiki.freifunk-dresden.de/index.php/Router_einrichten_AVM and ran eva_ramboot.py openwrt-22.03.3-lantiq-xrx200-avm-fritz3370-rev2-hynix-initramfs-kernel.bin successfully. OpenWrt is running on my FritzBox, but as soon as I reboot, its constantly flashing red "Info". It seems like its stuck. What to do?

PS: Also tried the same procedure with micron, but result is the same...

Now your openwrt is only started from ftp .To flash it you must then use sysupgrade image to "upgrade" openwrt .

I did this in luci and upgraded to openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-sysupgrade.bin ... same red blinking error occurs instantly after reboot

Connecting without the script also works now...

but still got an error

ftp -n
Connected to (
220 ADAM2 FTP Server ready
ftp> quote USER adam2
331 Password required for adam2
ftp> quote PASS adam2
230 User adam2 successfully logged in
ftp> binary
200 Type set to BINARY
ftp> debug
Debugging on (debug=1).
ftp> passive
Passive mode off.
ftp> quote SETENV linux_fs_start 0
---> SETENV linux_fs_start 0
200 SETENV command successful
ftp> quote MEDIA FLSH
200 Media set to MEDIA_FLASH
ftp> put /path/openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-kernel.bin mtd1
local: /path/openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-kernel.bin remote: mtd1
ftp: setsockopt (ignored): Permission denied
---> PORT 10,137,0,31,209,47
502 Command not implemented
ftp: bind: Address already in use
ftp> put /path/openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-filesystem.bin mtd0
local: /path/openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-filesystem.bin remote: mtd0
ftp: setsockopt (ignored): Permission denied
---> PORT 10,137,0,31,222,229
502 Command not implemented

please try boot eva ramboot + sysupgrade using version 21.02.5 .Also you might run ssh and then dmesg to see if nand flash get detected

I just installed OpenWrt 22.03.03 successfully using lftp following https://wiki.freifunk-dresden.de/index.php/Router_einrichten_AVM#Anleitung_f.C3.BCr_FritzBox_3370_unter_Ubuntu_.2F_Debian

Replace XXX either with hynix or micron, depending on your model cpu.


  1. Install lftp
  2. Rename openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-XXX-squashfs-eva-kernel.bin to mtd1
  3. Rename openwrt-22.03.3-lantiq-xrx200-avm_fritz3370-rev2-XXX-squashfs-eva-filesystem.bin to mtd0
  4. Create a separate file named adam2-commands with the following commands:
login adam2 adam2
quote USER adam2
quote PASS adam2
quote SETENV linux_fs_start 0
put mtd1
put mtd0
quote REBOOT
  1. Change your local ip to
  2. Open a terminal where all three files are stored and run lftp -f adam2-commands

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.