Flashing Google WiFi Not Working

Hello All,

So, I'm trying to repurpose a box of 6-7 Google WiFi AC-1304s and I'm following the installation guide here:

I have tried several dozen flash drives, but can't get any of them to boot OpenWRT to finish the copy to flash storage.

The flash drives I'm using are booting fine for the Google WiFi recovery image, but the factory.bin snapshot file that I wrote with either BalenaEtcher or dd refuses to boot when I press the SW7 button. It simply starts booting back into the stock firmware again and seems to be completely ignoring the flash drive after a few blinks.

Anybody else have any idea what I'm doing wrong here? I don't think I need to remove the read/write screw as I'm not changing the coreboot firmware, but I tried that as well and it made no difference. Before each attempt I've also been flashing back with my Google WiFi recovery firmware as well.


Two things I learned:

  1. You have to write the image using the OnHub Recovery Tool, as someone else mentioned in the forums.
  2. The LED no longer just "goes out". It will now flash blue and then go solid blue. It seems somewhere in the OpenWRT snapshots, someone added code to control the LED when it boots. It will now go solid blue.

I don‘t have one of those, so my knowledge is basically zero on those devices.

But I remeber frequent forum posts for Google Wifi for such flash issues.
One of them was, that you might need a USB hub and not every hub working successfully for that purpose: Google Wifi flashing - help - #25 by fakemanhk

If that does not help, maybe try forum-searching for Google Wifi, there is a lot more threads, maybe those have some more input that is of help for you.

Yeah I noticed that about the USB hub thing, but I purchased the same hub several other people have used and it works without issue for the Google Recovery image to reinstall the stock firmware, so I'm thinking it's not that. Otherwise, I wouldn't expect it to boot the stock recovery fine and reinstall to stock.

I tried using the search feature in the forums, but unfortunately it just returned zero results for "Google WiFi".


I managed to figure it out. It appears someone added code to control the LED now so the wiki is out of date. Also, you have to write the image using the OnHub Recovery Utility, rather than DD'ing the image. Seems that shouldn't be necessary because the partition tables look identify, but there must be something weird going on with the recovery tool. I'll dig more and submit wiki edit suggestions once I'm fully up and running.