Flash tplink wdr4300

No matter what I do the tftp transfer times out.

Using an unmanaged switch in the middle, not using an usb ethernet adapter. On the laptop I can tftp self. I have tried the factory firmware & the actual goal of 22.03.5. I hold down the routers reset button when powering up for several seconds and get a fast blinking asterisk light, 2nd from the left.

Few questions:
The docs say when in recovery mode, the routers IP address will be I have ran ping attempting to hit several addresses and power cycled and triggered recovery. The only ping response I ever get is Should I be able to ping

Is the recovery window small or as long as the asterisk light is blinking I should be able to tftp?( Iv tried over and over to catch an elusive window)

What else can I try?


The bootloader contains only a very minimal networking stack, it does not answer pings.

Running wireshark on the TFTP server should show a request incoming from the router. If this request comes in but is not answered, the problem is almost certainly a firewall in the TFTP server. wireshark captures packets from outside the firewall.

If you have another PC try TFTP from your server to the test PC. All firewalls in the TFTP server machine need to be disabled.

1 Like

push-button tftp recovery support was only retrofitted to these devices in later (2013?) OEM firmware upgrades (which replaced u-boot as well), it's perfectly possible that you device doesn't have it - in which case you'd need serial console access (which is economically questionable for these devices).

1 Like

OK, Im going to hold my breath for a bit longer that it is post 2013. Im also pretty sure this had openwrt on it at one time.

@mk24 thanks, so if i get a ping response on am I past the bootloader window, or is the rapid asterisk light mean Im still there?

I'm able to get the bin from the the tftp host via another computer - no firewall issues. I can see my computer connect in the tftpd logs but I do not see the router attempting to connect.

Still hopping its a user error. From the computer running tftpd and from the server's file directory:

put wdr4300v1_tp_recovery.bin

Then power cycle the router exactly as described https://openwrt.org/toh/tp-link/tl-wdr4300_v1#flashing_via_tftp

The procedure described in

is correct, it's the router fetching the factory image from your tftpd running at

For it to work, these conditions must be met:

  • young enough OEM u-boot installed (big 'if', again, it was only retrofitter later in the OEM upgrade cycle)
    • and yes, the bootloader must remain undamaged
  • tftpd running on the right IP
    • and not dropping the link at the wrong time (this is what an unmanaged switch helps to avoid)
  • getting the timing right for the button press (not too difficult in this case, but it might still need more than one attempt).

wireshark (or alternative means of packet sniffing) on the side of the tftpd will answer the question if the bootloader is requesting anything over tftp in the first place. If it does, there's still the potential for the bootloader rejecting the image as invalid (wrong region, hardware ID clobbered, etc.), but in this case it would have fetched the complete image and just decided not to flash it (reboot).

(if the bootloader is new enough and undamaged, it works reliably).

1 Like

if the bootloader is new enough and undamaged,

Ya, first time Iv had any trouble like this. The device must be borked.

Thanks for the help.

Have you updated the OEM firmware to the latest version?

Does the device work normally with oem firmware?

@d687r02j8g pull this one out of "storage" pretty sure its had OpenWRT on it since that what I do with every router I get.

Only access I get is 3 pings on a power cycle unless its in recovery mode which will answer pings continuously.

If it already has openwrt. Why can you flash it normally instead of tftp? You said you can ping can you SSH to that IP?

No response to SSH and I only get 3 pings on boot unless its in recovery mode in which sshd isnt running right?

Yes, in OpenWrt's recovery mode the dropbear server works with an IP, but you have to connect to LAN1 port to successfully connection.

I got this device too and I don't have problems following the steps described at its wiki page, remember, that for revert to OEMs firmware, you've to follow the process described at the device's wiki page.

My recommendation is that flash the OpenWrt firmware from the web interface if you're in the OEM firmware, forget about to do it by TFTP, is a headache if you don't flash the 2013 firmware before.

PS.: My hardware revision is 1.0, I don't know yours, with this hardware revision there aren't problems, what's yours? And other thing, about how to enter in failsafe mode, mine is 1.0 but the only way to enter in failsafe mode is press quickly and repeatedly the WPS/Reset button until the asterisk light blinks very fast, once time this happens, if you make a ping to, the router should respond.

@Raskaipika Awesome. I know have shh access in failsafe mode (19.07)! Getting to failsafe as in the doc works fine for me. Just didnt know I had dropbear.

1 Like

Let's go to recover your device, RESTORE to clean state following the procedure "Soft Factory Reset" described at wiki as first recovering method (YOU HAVE TO KNOW that this process restore the firmware to OpenWrt factory state, you'll lost your config).

Once time you recover the device, upgrade directly to the lastest version (22.03.5 sysupgrade.bin) without keeping config, flashing trough the web interface.

After upgrade, begin to configure / play with your device, regards.

Ya, all good now. Had do do sysupgrade over ssh and never figured out why I couldnt tftp, but hey now I have a decent router with current OpenWRT.

Very impressed with how helpful everyone is has been in helping me quickly get to a solution.


Those are great news!!, Now that you got the TP-Link WDR4300 working like a charm with the lastest version 22.03.5, I recommend you to take a look to the pepe2k Uboot MOD, you can read about it at the device's wiki page. It's recommended because among other things, it allow you to flash a firmware in an emergency case from its own web server at the beginning of the booting process, but you need to use a USB-TTL cable to make it work.

This device works great for a simple tasks nowday, it is a single core an old, but if your Internet is around 300 Mbps you will be fine with it because in OpenWrt firmware for this device, there isn't NAT hardware, but for pure switching, this device is great.

P.S.: If your problem is solved, mark the correspond post as solution and / or edit the title of the thread with "[SOLVED]" at the beginning, thanks.

While u-boot_mod is indeed great, I wouldn't quite jump to it now - flashing it is not quite for the faint of heart (and you will have to build it yourself, with an older toolchain)…

1 Like