Flash on Zyxel NR7101

sorry , yes SN - I already had used SN, but PW does not work

1 Like

I got the root & supervisor password from zyxel support by incident in a teamviever support session.
the password from the generator is wrong calculated
i tried the calculator on 2 new installed machines.


A post was split to a new topic: Zyxel NR7101 bricked?

Following the upgrade instructions, you can upgrade your modem to version 11A03

at + qfotadl = "http://get.dyn.mork.no/nr7101/RG502QEAAAR01A04-R11A03.zip"

What will this command look like, if possible, to upload the firmware in version: RG502QEAAAR11A07M4G_01.001.01.001

Ok I did it myself

Is there any way to prevent the qmi protocol from crashing the router as the speed is above 200mbit / s?

1 Like

Alternate Source: and for the file index.

Can anyone here using zyxel nr7101 check such a thing. On 7101 I have openwrt version 22.03 installed. The modem works as qmi. When the router turns on for me and establishes the connection itself, I have the maximum speed I can achieve from the operator (about 130mb/s). As soon as I execute the ifdown wan and then ifup wan command, the maximum speed I can get to about 15mb / s. (the same eNodeB - LAC - CID) Only restart helps then I have full speed again. I tested on the same card in the same place in the samsung A8 and netgear mr1100 and the speed is always maximum there. Note interesting stuff. When I run the command iperf -c ping.online.net from the console - the speed is also maximum. It turns out that the problem is with qmi - lan or router - lan. What is wrong? Why do the above commands cause a drop in speed?

Had this, too and that helped:

picocom /dev/ttyUSB2

Thank you catfriend1 for the advice. Unfortunately, these commandments do not make any difference. Then the router itself on speedtest has about 30 and the computer with lan has 13. Additionally, while testing the cards of Polish operators, I discovered that this problem occurs on the orange and plus cards. There is no problem with the play operator. I don't know yet about T-Mobile because I don't have their card. But either way it's amazing

1 Like

Hmm, I'm on T-Mobile.

Hi everyone, who can I send the 7101 to to unlock it, obviously paying? I am profane. thank you

Strange, my speed stays at maximum possible (usually a 100....200 MBit/sec up/down) and after some restarts plus some days, it gets just LTE "low" speed (10...30 MBit/sec).

After this speed drop occured, I did a waveform bufferbloat test:

My uptime is: 5h 18m 40s (Firmware: OpenWrt SNAPSHOT r19796-498c15376b / LuCI Master git-22.137.71281-d6dbedd)
AT+QENDC shows "+QENDC: 0,1,0,0"

I'm experimenting with the commands to find the relevant commands which reinstante the full 5G-NSA speed. Now doing:

picocom /dev/ttyUSB2


FATAL: read zero bytes from port
term_exitfunc: reset failed for dev UNKNOWN: Not a tty

After that, the full speed is there again :-).

What would be the best way to script this to do a cron job?

Maybe that can help: https://openwrt.org/docs/guide-user/network/wan/wwan/at_commands

Everything was working fine regarding the speed - I just did a reboot out of curiosity if it will be "high" or "low" speed afterwards. It's still high speed after reboot:

Catfriend1 Can you check, for example, for 5 minutes the ping to the router while connected to it via wifi. Every now and then there is a timeout for me. The cable is ok all the time. Only wifi has a problem. I do not know if my copy is like this or if there is a bug on openwrt for this model

1 Like

Gents just picking this up since one of these devices is on its way to me now.

What is everyone's overall experience with these devices? Are they reliable?

@Catfriend1 did you figure out a solution in the end?

In general would you guys recommend installing OpenWrt on this device?

And also, has anyone tried to work out how to provide an LTE-ethernet bridge like bridge mode or what Zyxel calls IP pass through?

Yes, mine is working fine. But the device needs daily reboots to prevent sudden disconnects from the mobile network during the day. Additionally, I'm using watchcat to restart the modem's network interface is Google is no longer ping -able.

IP passthrough can be done, but only makes sense for me when using t-d1 Telekom APN which provides an externally reachable public ipv4 address.

Thanks for the response.

Why the daily reboot? Is that just something to do with your ISP? Would that also have been needed in the stock firmware?

How? I've browsed through this forum on this topic and haven't been able to find any suggested approach even just an outline.

Years ago, I've read that passthrough relies on setting up a fake small subnet where the ISP gateway is valid, the router IP is only locally valid (not routed via WAN) and a DHCP service running on the router hands out the Public WAN IPv4 address to another device on your network plus ISP gateway for IP passthrough.

Yes and yes. I'm not sure if the modem dies or Telekom does disconnect/block a long running mobile connection session. About 24 ... 48 hours after all goes well, my public WAN IP is still there but no packets arrive/can be sent on the wwan4 interface anymore. This happens with Openwrt and stock firmware. Reboot does help me out here. Stock firmware does not support to reboot every day.

Would something like this help:

I wrote that for Asus routers that have a problem with e.g. ISP wan IP refreshes causing loss of internet connectivity. In your case does the loss of connectivity result in NO-CARRIER? Because if so perhaps you could efficiently react accordingly with something like this script.

1 Like

Looks good to me :). But honestly I won't find chance to test it. My 5G ISP contract will expire 17/11/2022 and I'm moving back onto DSL. Will then sell the Zyxel.