Zyxel NR7101 bricked?

Hello. This is my first post on this forum. I have zyxel nr7101 version from telnor. Doesn't run me dhcp. I do not know if this is a problem in their configuration or if I have a damaged RJ45 port section. Certainly, the power supply does not work after af / at (for some reason it broke in the previous user, maybe later I will be interested in it and fix it). However, it works like I connected directly to the 12V board. In the uart console, when I put the plug into the RJ45 port, I see up and when I remove it down. I do not know if this means that the data bus is ok and the telnor has simply disabled dhcp or I really have a damaged RJ45 port. Can it somehow be clearly checked?

Besides, I have a log:

Z-LOADER V1.30 | 06/03/2020 08:39:30

NetLoop, call eth_halt!

NetLoop, call eth_init!
Trying Eth0 (10/100-M)

Waitting for RX_DMA_BUSY status Start ... done

ETH_STATE_ACTIVE !!
Multiboot Listening ... 0

Booting image at bc14017c ...

Image Name: OpenWrt Linux-3.10.14
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 14707522 Bytes = 14 MB
Load Address: 80001000
Entry Point: 80001000

This entry worries me:

NetLoop, call eth_halt!

NetLoop, call eth_init!
Trying Eth0 (10/100-M)

Is it ok?

I don't have in my log:

Hit ESC key to stop autoboot: 1

Is it normal?

Will you help?

@bmork any ideas?

Looks normal to me, but obviously incomplete.

The device page has full boot logs for both OEM and OpenWrt, including the bootloader part of the logs. Should be fairly easy to compare with those if you are in doubt: https://openwrt.org/toh/zyxel/nr7101#bootlogs

The Telenor factory config sets the device up as a "bridge". There won't be any DHCP addresses available for the LAN port unless it has a mobile network connection. And the default APNs are tied to the SIM provided with the device. Which implies that an active "Trådløst Bredbånd" service is required for DHCP on the LAN port,unless you change OEM configuration or install OpenWrt.

1 Like

Does this router (from telnor) even have any static IP address through which I can go to ssh and http?

How to check what is its current static address? Ultimately, I want to have openwrt on it. Everything else is dentures, not soft

Okay, after disabling the commands and checking with ifconfig, I know that it reports to 192.168.2.1. The webgui pops up. Someone knows what the password can be. Admin and 1234 not working. root and password supervisor doesn't go either