[Fix]Try to make Telekom Malaysia UniFi VLAN working

Hi,
I try to make PPPoE in Telekom Malaysia UniFi VLAN 500 work, I have RT-AC1300UHP for testing, Dir-842 from Telekom Malaysia UniFi. Follow the instruction from https://telegra.ph/Guna-router-OpenWRT-sebagai-router-Unifi-01-04, but RT-AC1300UHP Always connection attempt failed, Dir-842 Need to keep not mod until RT-AC1300UHP work, How to fix it?

Update: Because Rt-AC1300UHP Needs to do more work, Swap to dir-842 or archer c7 to fix the problem.

Pic:https://imgur.com/a/Y04NKdX

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:f73c:40a8::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '04:92:26:88:9c:d4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.1/24'
        list ipaddr '192.168.1.3/24'

config device
        option name 'eth1'
        option macaddr '04:92:26:88:9c:d0'

config interface 'wan'
        option proto 'pppoe'
        option username 'name@unifi'
        option password 'pass'
        option ipv6 'auto'
        option device 'unifi.500'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

config device
        option type 'bridge'
        option name 'unifi'
        list ports 'eth1'

config bridge-vlan
        option device 'unifi'
        option vlan '500'
        list ports 'eth1:t'

Why is unifi.500 here. Chances are it should be eth1.500.

2 Likes

Remove these. You are mixing swconfig and dsa syntax - these cannot be mixed, and your device is swconfig.

1 Like

Like this?

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:f73c:40a8::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '04:92:26:88:9c:d4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.1/24'
        list ipaddr '192.168.1.3/24'

config device
        option name 'eth1'
        option macaddr '04:92:26:88:9c:d0'

config interface 'wan'
        option proto 'pppoe'
        option username 'acc@unifi'
        option password 'pass'
        option ipv6 'auto'
        option device 'eth1.500'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

Yes. Reboot the router and see if it works

Hmmm, No, Still connection attempt failed after Reboot, Pic:https://imgur.com/a/YyDbViG

hi,

in my experience PPPOE only works if the telekom provided device is a modem or running in modem mode. then your openwrt router can terminate the PPPOE connection. normally telco device gives you a DHCP address. so if you not sure if the telco box (the one with the cable from the provider) is in modem mode or not, change the wan interface to have dhcp protocol and see if that helps.

Hi, Actually I get is gpon from Huawei plus Dir-842 from D-Link, So is hard to say the gpon one is making trouble, I try same hardware combination, different ISP, is working fine, So I don't know what cause the problem.

I want the router part least firmware to openwrt.

Thanks

yes this GPON is the telco device. but usually they are configured to give out DHCP address and they build up the pppoe connection internally (you'll need to add username/password to gpon device. it may have been done when telco installed the service in your location). so any device you directly connect to gpon receives a dhcp address and no need to deal with pppoe.

but if you connect such gpon to an openwrt device via wan port of owrt then it will cause double NAT which is not so good. in such case you have to ask your telco to put gpon in "modem or bridge mode" which means the gpon device is just passing through everything and your owrt device must build up the pppoe connection on the wan interface.

you can test as said: connect directly a pc with dhcp on and see if receiving an ip address, or connect your openwrt device with dhcp protocol on wan interface. in both case if gpon is in usual mode it will give a dhcp address.

OK, but the pppoe account is type in dir-842......

Anyway I try connecting my computer direct, and my computer say is lost connection.

Or I need to connect to port use by Dir-842?

if you have to enter username/password into dir-842 then most probably gpon running already in modem mode.

then replace dir-842 with owrt router , using the same cable to plug it to owrt's WAN port. eth1 is usually the wan port in owrt, first try to use that without VLAN notatation (ie. eth1.500).

So is just eth1?

yes, try a systematic way: eth1 first, if works great.

then next step, if really your gpon is using VLAN then you have to setup VLAN.

For what it's worth, my ISP needs VLAN 10 tagging on the WAN for their fiber connection and I set it up yesterday. Below is on DSA and my device uses port 8 (p8) as WAN port.

config device                                                            
        option name 'p8'                                                 
                                                                         
config device                                                            
        option type '8021q'                                              
        option ifname 'p8'                                               
        option vid '10'                                                  
        option name 'fiber'

config interface 'wan'
	option proto 'pppoe'
	option username '..........'
	option password '..............'
	option ipv6 '1'
	option device 'fiber'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'

Remove 192.168.1.3 IP from Lan interface.

Hi, I try just eth1, eth1.500, connection attempt failed. So what now?

What the ****, I try https://youtu.be/zMze7luKmBg, use dir-842, just change from 35 to 500, and just work, *************

The RT-AC1300UHP uses the ipq4018 chip, which has problems with VLANs. Later OpenWrt has solved some of these problems, but I don't know exactly how to configure it. Generally you can't just put a VLAN number on the port.

Flash the snapshot version with default settings (check the box to not save settings while flashing) and post the default network config.

Ummm, So your meaning is RT-AC1300UHP has a bug, Openwrt try to fix the bug In the snapshot version?

I don't want to deal with this thing, Swap to dir-842 or archer c7 fix my problem, Thanks for the help.

How fast is your service? Typical fiber speed (> 100 Mb) would demand a lot more CPU than either of those two have. The 4018 would be good for that, but I think we need to wait for help from someone with direct experience on that hardware.