Fix a bricked Zyxel NWA55AXE

Hi All,

I managed to brick a Zyxel NWA55AXE (link)

I tried to set it up as a wireless repeater, but after 'cleaning' the setup, I did something very wrong -no clue what ;-).
The device now is bricked: that is I can no longer access it: maybe somebody else has some ideas.
Situation: the device is not providing a wireless network anymore (don't see an SSID). The ethernet port when doing a power up/down (by unplugging the Ethernet port and plugging it back: device is powered via ethernet), comes up shortly -there are lights blinking- and after about 5-10 seconds 'stops'.
My main router -linksys, after a reboot shows the device shortly as "Online", with the correct MAC address, but only with an IPV6 address.
The Zyxel ZON tool that has a potential for fixing a bricked zyxel device, is not finding the device.

Any clues how I can work around this issue.
Help appreciated ;-).

edit: as the device has not reset button, it makes live hard :wink:

Try ssh to the IPv6 address.


thanks for the support: ssh gives an 'port22 invalid argument' failure.
ssh ssh fe80:0000:0000:0000...
ssh: connect to host fe80::baec:a3f0... port 22: Invalid argument

But I found out I can ftpt into the ipv6 address. that gives a status 'Connected to...'.
I will check first why I get this ssh error. I guess if I get ssh working, the solution will be easier.
Actually funny I can tftp into the device, while my router gives the device not as 'offline'.

When you use the link local addresses, you need to specify the interface, e.g ssh fe80::1234%eth0

1 Like

Maybe the tools from Zyxel will help you.
You can find instructions and programs at the following URLs:äte-Reset bzw. oder

1 Like

Another example of the utility of a buttonless reset feature?

1 Like

In my case, the Zyxel tool worked. The device could then be added to the Nebula Cloud again. The device then has to be removed from there again and it is back in the delivery state.
If the recovery utility (version 1.2.0) does not work, there is another way described in git via the serial interface + TFTP at;a=commit;h=2050bc4f64e3824d6a632cce5fabc0b816ea0508

1 Like

Thanks all for the feedback.
So far i didnt find a solution yet. For sure the ssh is not working (also with indicatind the correct interface).

I have to check the other solutions provided here.

@cmid from which situation did you start; was the device still visible on the network (like ping worked, there was still a ssid...).

I started from the point the device was fully functional but bound to another Network with a different SSID.

1 Like

If nothing else works, see serial console instructions here:;a=commit;h=a0b7fef0ffe4cd9cca39a652a37e4f3ce8f0a681


I am going to use the serial port to get access again; I started a topic on a first small issue I hit...

the good: I can connect to via the UART connections to the device and in Putty I see all the boot info of the device...
Like last for line:
[ 0.000000] MIPS: machine is ZyXEL NWA55AXE
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
Please press Enter to activate this console.

But I cannot seem get any key back to the device... Like I only see what the router spits out, but I cannot communicate with it.

How do I communicate with the device?

back to unbricking...
So I managed to connect over the UART.

The default solution is to load a initramfs: but even for this you have to have the network working... (as you need to tftp the file to the device over TCP/IP). But my network is not working...

I think I need to start the ethernet Interface first...
this is the status here:
root@(none):/# ip link show
1: lo: mtu 65536 qdisc noop state DOWN qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
link/ether b8:ec:a3:e2:b4:70 brd ff:ff:ff:ff:ff:ff
3: lan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether b8:ec:a3:e2:b4:70 brd ff:ff:ff:ff:ff:ff

what do I have to start to get the ethernet port up and working?

(just posting while I am checking how to fix this).

ps: I guess if I get the network up and running I can connect again to the device to the gui and do the reset from there...

And problem fixed..
I ran "firstboot' when in being in the console (not 100% sure if I was in failsafe or just in the console), and a reboot and all is fine again...

root@OpenWrt:/# firstboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
/dev/ubi0_1 is mounted as /overlay, only erasing files
root@OpenWrt:/# reboot


And I bricked it again...

I wanted to install the package wpad-mesh-openssl; for this I wanted to remove the pre-installed wpad package (I think it was wpad-basic-wolfssl, not 100% sure); while de-installing this package the router became unresponsive for about 5 minutes.
No reaction anymore on the IP-address (dhcp). I did a power-off reboot and now the device is stuck again: wifi doesn't come up and I don't see it appear in my LAN.

I guess I have to get the UART-USB adapter again...

I wonder if the Zycast tool can work here - see:

1 Like

I checked this reference to flash: but this router NWA55AXZ has no 'Multiboot Listening..." in the log; so I guess it should not work.