Firmware unknown for GL-AR300M

Hi all,

just wanted to upgrade my GL-AR300m from OpenWRT 2.25 (OpenWrt Chaos Calmer 15.05 / LuCI 15.05-54-gfd60055 Release (git-15.363.78009-956be55) to the current LEDE Firmware linked in the device page (
When I upload this firmware I get the following error promt:

Verification result Error: Firmware is not for this hardware.
So I sadly can't upgrade to this Firmware...

I'm not really a professional, so I would prefer any easy solution for this problem. Is there maybe another version which works?
Thanks already in advance!


Dear Hellle

I also bought a GL-AR300M (mini router with black plastic case) 2 weeks ago
I have tried to update the firmware from web-console
(hold reset button then plug the power , this web-console seems was started by uboot)
I don't remember the error messages
but I failed everytime just like you when i want to flash a new image into router
this router was made by a Chinese manufacturer 'GL-inet'
I've ask for their help, the techical supoprt guy told me
"there is a problem in current version of uboot, you probably need to update uboot"
then he gave me a file called 'uboot_for_gl-ar300m.bin'
and told me i need to update it by myself
the whole procedure could refer here:

but after some efforts i realized the instructions in docs doesn't help
I've installed TFTP service on my laptop and put the uboot file into root directory of TFTP (
connected into uboot console of router and executed command 'run lu'
but it always shows 'Loading : T T T T T T T T' then the update procedure was dead

I am so sorry that I cannot offer a solution for your question
I suspect the problem (cannot update firmware) maybe caused by its buggy uboot
but I can not sure that
I also tried to ask help from GL-inet guys these days but I doesn't get response :expressionless:

Puh, no good news :frowning:
But thank you anyway for your response. Keep me up to date here please for the case you will get a reply from the vendor or finding another way to upgrade to LEDE. I think more people beside us could be interested in it. Thank you.

you are welcome
i will keep contacting the GL-inet guys and ask for their help
if they tell me a solution for this problem i will post it here soon.:slight_smile:

Are there some news meanwhile?

Dear Hellle

sorry for late reply, i 've contacted GLI's tech support department,
finally they answer my question 9 days ago (2017/5/11)
the technical guys told me the 'T T T T T ' error messages indicated that router doesn't find uboot_for_gl-ar300m.bin from TFTP server , they ask me to check file name is correct and firewall rules on TFTP server doesn't block GL-AR300M router then try again, but i just moved from rent place back to my home,
so my GL-AR300M was packaged in one of all my boxes, i have to unpack all of my boxes and find it among many of my stuff,then try to update u-boot again, i remember that buggy u-boot version number of my current GL-AR300M is 1.1.4, i don't know whether new u-boot will make it behave like a normal router but according GL-inet guys messages it worth to try, another posibility is this router has 2 flavors of storage media (NOR/NAND), so if you follow instructions here

you need carefully to make sure which flavor of image you are uploading
in webUI there are 2 buttons called 'Update nand firmware' and 'Update nor firmware',they need correct image format for updating successfully
i wanna find my router and try to update u-boot first then answer your question but i cannot find it right now.....(it must be in one of many of packaged boxes):no_mouth: