Firmware Selector WDR4300 v1 non existing default packages listed

Unsupported package(s): gpio-button-hotplug, kernel, mac80211

device : TP-Link TL-WDR4300 v1

could be, who knows, zero openwrt version posted.

hard to boot a router without it, one can only hope it's already in there.

another non-existing module/package.

unable to custom build

put banana and orange in the list of packages too, they also DO NOT exist ...

any idea how I can proceed?

by finding out if the packages you want actually do exist ?

also, by paying attention.

ah, you seem to be misunderstanding, may be you did not try to reproduce the issue, I did not put any nonexistent package as per image above, only add bash

misleading with predefine installed packages when custom built is selected

indeed, I misunderstood, I'll also alter the subject of this thread ...

perhaps @aparcar can help here ... ?

as a workaround use the default image, install bash post upgrade ?

can this be solved some way?
5 devices to be reconfigured remotely with the help from noobs in IT

probably, but the time it'll take depends on if the issue's in the online image builder, or elsewhere ...

offline image builder then, but that's a steep learning curve, if you haven't done it before.

1 Like

sure will give it a go, any step by step link?

1 Like

I wonder if it is just a temporary buildbot upload error or similar, (trying to do just when buildbot is uploading a new build ?)

There have also been similar LuCI bug reports in the last few days, (but the issue is not related to LuCI)

So, this might be a bit wider?

This might be fallout from

as the failing packages gpio-button-hotplug, kernel, mac80211 are built from kernel sources, and do not have a proper package files. (well, mac80211 has Makefile, but is done from kernel backports)

cc @feckert @hauke @aparcar

1 Like

I deployed a new version of the upgrade server, could you please give it a try? It worked with firmware selector and the LuCI app. For the CLI I have to add some more details.


custom built online not working for any device!

custom build still not working:

Yes, that's what this whole thread is about...

1 Like

Should work again, was a problem with CORS