Filesystem is randomly mounted in read-only after normal reboot/power loss

I run OpenWrt on x86 with ext4 image, but recently I noticed my system is being mounted in read-only I ran e2fsck/fsck sometime it finds some errors and fixes them, and sometimes it shows that the filesystem is clean

I also enabled the file system check from the web GUI but I noticed some errors in the kernel logs during the boot

[    4.287271] EXT4-fs (sda2): mounted filesystem without journal. Opts: (null)
[    4.294368] VFS: Mounted root (ext4 filesystem) readonly on device 8:2.
[   10.915386] block: attempting to load /etc/config/fstab
[   10.924471] block: check_filesystem: /usr/sbin/e2fsck returned 8
[   11.305190] EXT4-fs (sda2): re-mounted. Opts: (null)
[   11.323376] mount_root: switched to extroot
[   11.406749] EXT4-fs (sda1): mounted filesystem without journal. Opts: (null)

strangely enough when the fsck shows that the system is clean. running mount -o remount,rw / is enough to re-mount in r/w

I have been debugging this for a while with no avail, and I do not want to do a clean install as I have a lot of configuration on the system

It seems to be some problems with package block-mount. Similiar issue is mentioned in with some solutions provided.

OpenWrt R22.10.20

Whatever you linked isn't official OpenWrt.

@coolsnowwolf may know more, as it appears to be his Git site.