Fibocom FM350-GL Support

Kindly share it here in this thread, so everyone could make use of it?

2 Likes

before proceeding make sure picocom is installed on the computer

sudo apt install picocom -y

How to have an active Fibocom FM350-GL modem in PCIe mode active after a system reboot

  1. copy & paste the following script into /usr/local/bin directory as shutdown-fibocom.sh
    --make sure permissions are 0755
#!/bin/bash

# AT command to send
AT_COMMAND="AT+CFUN=15"  # Replace with your desired AT command

# Device path
DEVICE="/dev/wwan0at0"

# Ensure picocom is installed
if ! command -v picocom &>/dev/null; then
    echo "Error: picocom is not installed. Please install it with 'sudo apt install picocom'."
    exit 1
fi
  1. Create the following systemd service
    --easiest way copy the following script as shutdown-fibocom350gl.service
    paste into /etc/systemd/system folder
    make sure permissions are 0644
# Run picocom to send the AT command and exit
echo -e "$AT_COMMAND\r" | picocom "$DEVICE" -b 9600 --quiet --exit-after 2000

# Check if the command was successful
if [ $? -eq 0 ]; then
    echo "AT command '$AT_COMMAND' sent successfully to $DEVICE."
else
    echo "Failed to send AT command to $DEVICE."
fi[Unit]
Description=Reset Cellular Modem Before Shutdown
Before=shutdown.target reboot.target
DefaultDependencies=no

[Service]
Type=oneshot
ExecStart=/bin/bash /usr/local/bin/shutdown-fibocom.sh
RemainAfterExit=true

[Install]
WantedBy=halt.target reboot.target shutdown.target

3 enable the service to start on boot

sudo systemctl enable shutdown-fibocom350gl.service
  1. Restart systemd daemon
sudo systemctl daemon-reload
  1. Restart computer, the modem will now be active after a reboot
2 Likes

OK, but this will not work on OpenWrt and thus needs to be adapted first.

1 Like

Im not sure if openwrt even uses systemd
With the instructions in previous post someone may be able to adapt this setup to openwrt.
This is the only way,I have ever figured out to get FM350-GL to work in PCIe mode, on a reboot.
Otherwise the machine has to be powered down,,,which is not practical at all.
Someone should be able to craft an init command at shutdown/reboot and get the same effect in openwrt.

The preinit and shutdown hooks in OpenWrt allow you to inject custom commands into the system's boot and shutdown processes.

  1. Edit Shutdown Script: Create a script in /etc/hotplug.d/ under the appropriate trigger (e.g., net):
echo '/etc/shutdown-fibocom350gl.sh' > /etc/hotplug.d/net/99-fbc350gl-shutdown
  1. Ensure Permissions: Make sure the script and hook files are executable:
chmod +x /etc/hotplug.d/net/99-fbc350gl-shutdown

Thanks you for the info,

Worth noting. The modem will actually work fine in PCIe mode, if a full system shutdown is performed....after starting again.
Where the modem will not function corrcetly is a system REBOOT,,It no longer shows up .

I assume the system shutdown init your provided is used as a system reboot as well.
I am really rusty on init stuff...now.

Thanks

@AndrewZ @mrhaav I have connected the FM350GL in USB mode using the usb sled on linksys wrt1900acs . I have used @mrhaav 's ATC program to dial to isp. Unfortunately, my isp is T-mobile and support only IPv6 . Though ATC program dials and assigns the ipv6 and dns correctly to eth1 interface. But my routing does not work and i am not able to perform dns resolution and ping successfully..

@AndrewZ Could you pls check if the routing makes any sense for ipv6. i am not very good in ipv6, i could not make it work. The same gateway address for the eth1 works in linux ubunutu laptop though.It should be something to do with routing i believe.But i could not identify whats causing it.

root@Fibocom:/lib/netifd/proto# ifconfig eth1
eth1 Link encap:Ethernet HWaddr 00:00:11:12:13:14
inet6 addr: 2607:fb91:1509:4f47:200:11ff:fe12:1314/64 Scope:Global
inet6 addr: fe80::200:11ff:fe12:1314/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:104 (104.0 B) TX bytes:1958 (1.9 KiB)

root@Fibocom:/lib/netifd/proto# ip -6 route show
default from 2607:fb91:1509:4f47::/64 via fe80::b46d:57ff:fe45:4545 dev eth1 proto static metric 512 pref medium
2607:fb90:ec1b:5bc9::/64 dev br-lan proto kernel metric 256 expires 6674sec pref medium
2607:fb91:1509:4f47::/64 dev br-lan proto static metric 1024 pref medium
unreachable 2607:fb91:1509:4f47::/64 dev lo proto static metric 2147483647 pref medium
fd45:24b2:629a::/64 dev br-lan proto static metric 1024 pref medium
fd45:24b2:629a::/60 dev br-lan proto kernel metric 256 expires 6775sec pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium

root@Fibocom:/lib/netifd/proto# ip -6 rule show
0: from all lookup local
32766: from all lookup main
4200000000: from 2607:fb91:1509:4f47::1/64 iif br-lan unreachable
root@Fibocom:/lib/netifd/proto# ifconfig br-lan
br-lan Link encap:Ethernet HWaddr 60:38:E0:0A:07:81
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: 2607:fb91:158c:8b72::1/64 Scope:Global
inet6 addr: 2607:fb90:ec99:179e::1/64 Scope:Global
inet6 addr: 2607:fb90:ec99:6f2::1/64 Scope:Global
inet6 addr: 2607:fb91:1514:1905::1/64 Scope:Global
inet6 addr: 2607:fb91:1529:4e76::1/64 Scope:Global
inet6 addr: 2607:fb90:ec9c:95d1::1/64 Scope:Global
inet6 addr: fd45:24b2:629a::1/60 Scope:Global
inet6 addr: 2607:fb91:1509:4f47::1/64 Scope:Global
inet6 addr: fe80::6238:e0ff:fe0a:781/64 Scope:Link
inet6 addr: 2607:fb90:ec1b:5bc9::1/64 Scope:Global
inet6 addr: 2607:fb90:ec5b:14ce::1/64 Scope:Global
inet6 addr: 2607:fb91:15a5:a768::1/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:42160 errors:0 dropped:0 overruns:0 frame:0
TX packets:96791 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3226002 (3.0 MiB) TX bytes:34037287 (32.4 MiB)

Hi
Can you set Activate AT debugging to All and power reset your router?
Please, paste the syslog from netifd and dnsmasq.

Paste it as Preformatted text,
image

Hi @mrhaav , please find the logs for netifd and dnsmasq. also adding the ifconfig after the ATC eth1 interface came up


Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.452394] usb 3-1: new SuperSpeed USB device number 2 using xhci-hcd
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.487602] rndis_host 3-1:1.0 eth1: register 'rndis_host' at usb-f10f8000.usb3-1, RNDIS device, 00:00:11:12:13:14
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.489159] option 3-1:1.2: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.489263] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.490794] option 3-1:1.3: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.490952] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB1
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.491887] option 3-1:1.4: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.491995] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB2
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.493748] option 3-1:1.6: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.493842] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB3
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.496178] option 3-1:1.7: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.496274] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB4
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.496827] option 3-1:1.8: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.496924] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB5
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.497697] option 3-1:1.9: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.497786] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB6
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.540388] option 3-1:1.5: GSM modem (1-port) converter detected
Sun Jan  5 15:10:09 2025 kern.info kernel: [   36.540529] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB7
Sun Jan  5 15:10:09 2025 user.notice fm350-gl: Serial USB driver loaded for 0e8d:7127
Sun Jan  5 15:10:11 2025 daemon.notice netifd: wwan1 (3347): Initiate modem with interface eth1
Sun Jan  5 15:10:13 2025 daemon.notice netifd: wwan1 (3347): SIMcard ready
Sun Jan  5 15:10:14 2025 daemon.warn odhcpd[3031]: No default route present, overriding ra_lifetime to 0!
Sun Jan  5 15:10:16 2025 daemon.notice netifd: wwan1 (3347): Fibocom Wireless Inc.
Sun Jan  5 15:10:16 2025 daemon.notice netifd: wwan1 (3347): FM350-GL
Sun Jan  5 15:10:16 2025 daemon.notice netifd: wwan1 (3347): 81600.0000.00.29.23.06
Sun Jan  5 15:10:16 2025 daemon.notice netifd: wwan1 (3347): Configure modem
Sun Jan  5 15:10:26 2025 daemon.notice netifd: wwan1 (3347): Activate modem
Sun Jan  5 15:10:30 2025 daemon.notice netifd: wwan1 (3347): +CIREPI: 0,0
Sun Jan  5 15:10:30 2025 daemon.notice netifd: wwan1 (3347): +EONSNWNAME: 1, 0, "T-Mobile", 0, "T-Mobile"
Sun Jan  5 15:10:30 2025 daemon.warn odhcpd[3031]: No default route present, overriding ra_lifetime to 0!
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): AT+COPS=3,0;+COPS?;+COPS=3,2;+COPS?
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): +COPS:0,0,"T-Mobile",11
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): +COPS:0,2,"310260",11
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): Registered to T-Mobile PLMN:310260 on NR
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): Activate session
Sun Jan  5 15:10:31 2025 daemon.notice netifd: wwan1 (3347): OK
Sun Jan  5 15:10:34 2025 daemon.notice netifd: wwan1 (3347): AT+CGACT=1,1
Sun Jan  5 15:10:34 2025 daemon.notice netifd: wwan1 (3347): +CGEV: ME PDN ACT 1
Sun Jan  5 15:10:34 2025 daemon.notice netifd: wwan1 (3347): OK
Sun Jan  5 15:10:35 2025 daemon.notice netifd: wwan1 (3347): AT+CGPADDR=1
Sun Jan  5 15:10:35 2025 daemon.notice netifd: wwan1 (3347): +CGPADDR: 1,"0.0.0.0.0.0.0.0.10.211.253.81.78.35.14.254",""
Sun Jan  5 15:10:35 2025 daemon.notice netifd: wwan1 (3347): OK
Sun Jan  5 15:10:36 2025 daemon.notice netifd: wwan1 (3347): AT+CGCONTRDP=1
Sun Jan  5 15:10:36 2025 daemon.notice netifd: wwan1 (3347): +CGCONTRDP: 1,,"fast.t-mobile.com","","","253.0.151.106.0.0.0.0.0.0.0.0.0.0.0.9","253.0.151.106.0.0.0.0.0.0.0.0.0.0.0.16","","",0,,1436,,,,,,,1,1,0,"1",0,65535
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Interface 'wwan1' is now up
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Network device 'eth1' link is up
Sun Jan  5 15:10:36 2025 daemon.notice netifd: wwan1 (3347): JSON: { "name": "wwan16", "ifname": "@wwan1", "proto": "dhcpv6", "extendprefix": "1", "dns": [ "fd00:976a:0000:0000:0000:0000:0000:0009", "fd00:976a:0000:0000:0000:0000:0000:0010" ], "zone": "wan" }
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Network alias 'eth1' link is up
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Interface 'wwan16' is enabled
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Interface 'wwan16' has link connectivity
Sun Jan  5 15:10:36 2025 daemon.notice netifd: Interface 'wwan16' is setting up now
Sun Jan  5 15:10:36 2025 daemon.notice netifd: wwan1 (3347): OK
Sun Jan  5 15:10:36 2025 daemon.err odhcp6c[6815]: Failed to send RS (Address not available)
Sun Jan  5 15:10:36 2025 user.notice firewall: Reloading firewall due to ifup of wwan1 (eth1)
Sun Jan  5 15:10:37 2025 daemon.warn odhcpd[3031]: No default route present, overriding ra_lifetime to 0!
Sun Jan  5 15:10:37 2025 daemon.err odhcp6c[6815]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan  5 15:10:50 2025 daemon.notice netifd: Interface 'wwan16' is now up
Sun Jan  5 15:10:50 2025 daemon.notice netifd: Interface 'wwan16_4' is setting up now
Sun Jan  5 15:10:50 2025 user.notice firewall: Reloading firewall due to ifup of wwan16 (eth1)
Sun Jan  5 15:10:50 2025 user.notice upnp daemon: external interface not found, not starting
Sun Jan  5 15:10:50 2025 daemon.err miniupnpd[7117]: STUN: Cannot get IP address for ext interface
Sun Jan  5 15:10:50 2025 daemon.err miniupnpd[7117]: Performing STUN failed. EXITING
Sun Jan  5 15:11:03 2025 daemon.notice netifd: Interface 'wwan16_4' is now down
Sun Jan  5 15:11:03 2025 daemon.notice netifd: Interface 'wwan16_4' is setting up now
Sun Jan  5 15:11:16 2025 daemon.notice netifd: Interface 'wwan16_4' is now down
Sun Jan  5 15:11:16 2025 daemon.notice netifd: Interface 'wwan16_4' is setting up now
Sun Jan  5 15:11:29 2025 daemon.notice netifd: Interface 'wwan16_4' is now down

dnsmasq was not appearing in log, so i enabled the log to a file and pasted the output since the boot the openwrt


Jan  5 15:28:04 dnsmasq[3800]: started, version 2.90 cachesize 8192
Jan  5 15:28:04 dnsmasq[3800]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Jan  5 15:28:04 dnsmasq[3800]: UBus support enabled: connected to system bus
Jan  5 15:28:04 dnsmasq-dhcp[3800]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for test
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for onion
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for localhost
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for local
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for invalid
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for bind
Jan  5 15:28:04 dnsmasq[3800]: using only locally-known addresses for lan
Jan  5 15:28:04 dnsmasq[3800]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Jan  5 15:28:04 dnsmasq[3800]: read /etc/hosts - 12 names
Jan  5 15:28:04 dnsmasq[3800]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Jan  5 15:28:04 dnsmasq-dhcp[3800]: read /etc/ethers - 0 addresses
Jan  5 15:28:05 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:05 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:05 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:05 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:05 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:05 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:05 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:05 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:05 dnsmasq[3800]: read /etc/hosts - 12 names
Jan  5 15:28:05 dnsmasq[3800]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Jan  5 15:28:05 dnsmasq-dhcp[3800]: read /etc/ethers - 0 addresses
Jan  5 15:28:07 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:07 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:07 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:07 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:07 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:07 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:07 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:07 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[A] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:10 dnsmasq[3800]: query[AAAA] push.services.mozilla.com from 192.168.1.130
Jan  5 15:28:10 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:11 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:11 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:11 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:11 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:11 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:11 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:11 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:11 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:12 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:12 dnsmasq[3800]: read /etc/hosts - 12 names
Jan  5 15:28:12 dnsmasq[3800]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Jan  5 15:28:12 dnsmasq[3800]: read /tmp/hosts/odhcpd - 2 names
Jan  5 15:28:12 dnsmasq-dhcp[3800]: read /etc/ethers - 0 addresses
Jan  5 15:28:13 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] detectportal.firefox.com from 192.168.1.130
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:13 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:13 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: query[AAAA] example.org from 192.168.1.130
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: query[A] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 192.168.1.130
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:14 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:16 dnsmasq[3800]: query[A] wpad from 192.168.1.130
Jan  5 15:28:16 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:16 dnsmasq[3800]: query[AAAA] wpad from 192.168.1.130
Jan  5 15:28:16 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:24 dnsmasq[3800]: query[A] wpad from 192.168.1.130
Jan  5 15:28:24 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:24 dnsmasq[3800]: query[AAAA] wpad from 192.168.1.130
Jan  5 15:28:24 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:26 dnsmasq[3800]: query[A] anonymous-communication.ghostery.net from 192.168.1.130
Jan  5 15:28:26 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:26 dnsmasq[3800]: query[AAAA] anonymous-communication.ghostery.net from 192.168.1.130
Jan  5 15:28:26 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:26 dnsmasq[3800]: query[A] anonymous-communication.ghostery.net from 192.168.1.130
Jan  5 15:28:26 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:26 dnsmasq[3800]: query[AAAA] anonymous-communication.ghostery.net from 192.168.1.130
Jan  5 15:28:26 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:29 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:29 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:29 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:29 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:29 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:29 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:29 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:29 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:31 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:31 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:31 dnsmasq[3800]: query[A] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:31 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:31 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from ::1
Jan  5 15:28:31 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:31 dnsmasq[3800]: query[AAAA] 0.openwrt.pool.ntp.org from 127.0.0.1
Jan  5 15:28:31 dnsmasq[3800]: config error is REFUSED (EDE: not ready)
Jan  5 15:28:52 dnsmasq[3800]: query[A] wpad from 192.168.1.130
Jan  5 15:28:52 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:52 dnsmasq[3800]: query[AAAA] wpad from 192.168.1.130
Jan  5 15:28:52 dnsmasq[3800]: config wpad is NXDOMAIN
Jan  5 15:28:55 dnsmasq[3800]: reading /tmp/resolv.conf.d/resolv.conf.auto
Jan  5 15:28:55 dnsmasq[3800]: using nameserver fd00:976a::9#53
Jan  5 15:28:55 dnsmasq[3800]: using nameserver fd00:976a::10#53
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for test
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for onion
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for localhost
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for local
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for invalid
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for bind
Jan  5 15:28:55 dnsmasq[3800]: using only locally-known addresses for lan
Jan  5 15:28:55 dnsmasq[3800]: read /etc/hosts - 12 names
Jan  5 15:28:55 dnsmasq[3800]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Jan  5 15:28:55 dnsmasq[3800]: read /tmp/hosts/odhcpd - 4 names
Jan  5 15:28:55 dnsmasq-dhcp[3800]: read /etc/ethers - 0 addresses
Jan  5 15:28:55 dnsmasq[3800]: query[AAAA] ipv4only.arpa from 127.0.0.1
Jan  5 15:28:55 dnsmasq[3800]: config error is REFUSED (EDE: network error)
Jan  5 15:28:55 dnsmasq[3800]: query[AAAA] ipv4only.arpa from ::1
Jan  5 15:28:55 dnsmasq[3800]: config error is REFUSED (EDE: network error)
Jan  5 15:28:57 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:57 dnsmasq[3800]: config error is REFUSED (EDE: network error)
Jan  5 15:28:57 dnsmasq[3800]: query[A] example.org from 192.168.1.130
Jan  5 15:28:57 dnsmasq[3800]: config error is REFUSED (EDE: network error)

config of resolvconf file


cat /tmp/resolv.conf.d/resolv.conf.auto
# Interface wwan16
nameserver fd00:976a::9
nameserver fd00:976a::10

ifconfig after the eth1 interface is up


ifconfig
br-lan    Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdd1:20e7:4885::1/60 Scope:Global
          inet6 addr: 2607:fb90:ec1d:927::1/64 Scope:Global
          inet6 addr: fe80::6238:e0ff:fe0a:781/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:1450 errors:0 dropped:0 overruns:0 frame:0
          TX packets:986 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:158750 (155.0 KiB)  TX bytes:1068958 (1.0 MiB)

eth0      Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          inet6 addr: fe80::6238:e0ff:fe0a:781/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1508  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1024 
          RX bytes:0 (0.0 B)  TX bytes:1712 (1.6 KiB)
          Interrupt:44 

eth1      Link encap:Ethernet  HWaddr 00:00:11:12:13:14  
          inet6 addr: fe80::200:11ff:fe12:1314/64 Scope:Link
          inet6 addr: 2607:fb90:ec1d:927:200:11ff:fe12:1314/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:104 (104.0 B)  TX bytes:3073 (3.0 KiB)

lan1      Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan2      Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan3      Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan4      Link encap:Ethernet  HWaddr 60:38:E0:0A:07:81  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:344 errors:0 dropped:0 overruns:0 frame:0
          TX packets:344 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:24872 (24.2 KiB)  TX bytes:24872 (24.2 KiB)

phy1-ap0  Link encap:Ethernet  HWaddr 60:38:E0:0A:07:82  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1449 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1560 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:179030 (174.8 KiB)  TX bytes:1142866 (1.0 MiB)

wan       Link encap:Ethernet  HWaddr 62:38:E0:0A:07:81  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



ip -6 route show
default from 2607:fb90:ec1d:927::/64 via fe80::b46d:57ff:fe45:4545 dev eth1 proto static metric 512 pref medium
2607:fb90:ec1d:927::/64 dev br-lan proto static metric 1024 pref medium
unreachable 2607:fb90:ec1d:927::/64 dev lo proto static metric 2147483647 pref medium
fdd1:20e7:4885::/64 dev br-lan proto static metric 1024 pref medium
unreachable fdd1:20e7:4885::/48 dev lo proto static metric 2147483647 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium


ip -6 rule show

0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2607:fb90:ec1d:927::1/64 iif br-lan unreachable

i have configured the RA firewall rule as given in the ATC github repo

Adding the firewall rules,i did not modify anything as far as i know . please see if this helps as well

cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'
        option flow_offloading_hw '1'
        option fullcone '0'
        option fullcone6 '0'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'
        list network 'wwan1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option family 'ipv6'
        list proto 'icmp'
        option src 'wan'
        list src_ip 'fe80::1'
        option target 'ACCEPT'
        option name 'Allow Modem RA'

I can´t see anything that are obvious wrong in your config. The modem setup the session in a correct way.
It looks like you are using 464xlat, or?
Have you tried to run without 464xlat and verified that IPv6 is working?
According to @cr08 and FM350-GL T-Mobile (US) No CLAT/XLAT/IPv4 address provided you need to change the DNS servers to get 464xlat to work.

1 Like

Thanks @mrhaav for checking and verifying . I do use the 464xlat for ipv4 . Let me check with 464xlat and I will see if pure ipv6 only works .
Thanks
:+1:

what do you get for return of
'ip route' command
You most likely cannot even ping 8.8.8.8 correct?

T-Mobile should work without any problems with this modem.

1 Like

Yeah. Short version of my experience with these modems and T-Mobile is that IPV6 seems to work just fine and is T-Mobile's primary connection type. IPV4 is not provided by default from the modem even with the IPV4V6 PDP type turned on (compared to other modems I've tried that will provide a V4 address without an issue).

Installing the 464xlat package on OpenWRT even with the default configs it doesn't supply a V4 connection. I had to manually set DNS settings on the main modem connection to Google's DNS64 addresses (specifically DNS64, not just the general V6 DNS addresses!) and even then while it would provide a 464xlat V4 address (it'll show in ip route as I recall but not the interface list, ie: ip a. But it's been a hot minute since I've messed with this) it wasn't super reliable.

I've since moved these modems to another board and another largely stock Ubuntu OS based system for reasons and still run into this with a modified ModemManager. I've even had one other user on this platform confirm the same findings with the FM350-GL and T-Mobile.

If V4 is needed, the only workaround I've found is disabling 5G SA mode and using 5G NSA which allows the modem to provide a V4 address natively. It has been pretty rock solid reliable for me. I'd love a proper fix that allows SA to be used with IPV4 but so far have had no luck.

Hi @cr08 ,

After lot of fiddling around ,I was able to get finally ipv4 address in LTE-ENDC mode with T-Mobile same config.

In order to force the fm350 in LTE-ENDC i had to supply this "AT+ GTACT=17,3,6,0". ,which I believe 17 - is mixed mode LTE/NR-RAN , 3- LTE preference 1 and 6 - NR-RAN second preferrence,0 - for all bands . This pushed the modem to LTE-ENDC ,now I get ipv4 and ipv4 DNS . Now it's routable and working .

1 Like

Yeah, you're essentially doing a roundabout way of setting 5G NSA mode then. LTE-ENDC = 5G NSA. I think I had tried this command myself when I was originally troubleshooting and was unsuccessful for some reason. It may be covered in some old comments in this thread that I'd have to go back to.

FWIW, my method seems to be a bit more straightforward at least in my own experience: Fibocom FM350-GL Support - #172 by cr08

That said, if your method works that's cool! Not a bad idea to keep the option in my link in mind too. I think in the case of the commands you're using, there's still the option with that secondary preference for it to potentially choose 5G SA mode? Don't quote me on that.

1 Like

Hi , yes you right . I actually did follow the same 4pda threads and your AT commands reference. Somehow for me AT+E5GOPT ,did not put me on NSA ,rather it did not connect to any network . Then I reset it back to 5GOPT to both NSA and SA ,it started connecting to only SA and IPV6 only .

Then only I started playing with AT+GTACT, it works for ipv4 ,either way .

Sure I will try more digging on AT+GTACT and share any positive results .

1 Like

While I'm thinking about it, has anyone had any luck getting the GPS/GNSS functionality of this card to work?

I've been messing with it off and on I've been able to get as far as sending an AT+GTGPSPOWER=1 command to the NMEA port (doesn't seem to work on the AT port) and with GPSD properly attached, I can get some output from cgps but all sats show 0 signal and 0 SNR. It does list sats though. But not sure if this is potentially from agps or not. I do have to periodically send the GTGPSPOWER command too. Seems that at times I lose the output from cgps and that wakes it up again.

Also the other GPS related AT commands in their documentation I have tried but many error out. It's been a while since I've played with those specifically so don't have the best memory of that work.

I know this is OpenWrt forum,,but this is somewhat relevant to the thread going on here.

These modems, will work without any monkeying,on a default install of Debian Trixie, 13 .in PCIe mode.
All i had to do is enter the appropriate APN,for the sim card using,,,both T-MO and Verizon,and they worked without any firmwaring,,,yada,,yada,,,
One caveat is in PCIe mode when rebooted the modem would disappear...After some finagling,come to find out when rebooted the modem come s back up,in fastboot mode.
After some wranging finally figured out a shutdown /reset service for the modem,using picocom,at reboot that circumvented this problem.
Also, SMS,,also works out of the box,as well.
I used nm-connection-editor,to enter the APN,and sets up the connection,As simple as you can get.
Also,ModemManager does shows stats for this modem as well.
Didnt try anything with GPS,it does shows some stats for the simple gps stuff in ModemManager I know,,dont remember what all was showing.

One technical question regarding antenna design with this card (I am currently upgrading from LTE and thus not familiar with 5G): GNSS is handled in the same bands as 5G receive and thus one does not need a special antenna, right?