Fastweb Italy FTTC/FTTN partial config

Having been battling to get the connection working on the above service I have a partial success on an AVM 7360v2 with 21.02.2.
Network config as follows;

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0a:f543:38e8::/48'

config dsl 'dsl'
	option tone 'av'
	option ds_snr_offset '0'
	option annex 'b'
	option line_mode 'vdsl'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.2'

config interface 'wan'
	option proto 'dhcp'
	option device 'dsl0.100'
	option hostname '*'
	option vendorid 'SERCOMM VD4225R.FW' # make/model of the fastweb nexxt No idea if this is 'right' but it is right enough to work.
	option clientid ' --Cloned-- '

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config device
	option name 'dsl0'
	option macaddr ' --Cloned-- '

config interface 'wan_6'
	option proto 'dhcpv6'
	option clientid ' --Cloned MAC-- '
	option reqaddress 'try'
	option device 'dsl0.100'
	option reqprefix 'auto'

config device
	option name 'dsl0.100'
	option type '8021q'
	option ifname 'dsl0'
	option vid '100'

it must have the MAC of the ISP provided modem or it won't work at all, it appears it also needs something in the vendor ID, as noted I'm not entirely sure if I hit the nail on the head first time or if it just requires something in vendor ID, but it will not issue DHCP without it.

on to what I've not got working;
IPv6, the ISP modem definitely had it, and the ISP supports it, Openwrt automagically generates the wan_6 alias interface - which suggests the presence of IPv6 - then does nothing with it. I've tinkered with the settings and got nothing so I'm open to suggestions.

if anyone has access to the wiki already then by all means add the information.

i'm on fastweb fttc, all i did was add/install the 6rd package for ipv6, check/enable ipv6 on myfastweb account page and that's it.. it automagically works, no need to create/edit the wan_6 interface.

and when you edit the interface.

any suggestions would be gratefully received.

edited interface 'wan'

config interface 'wan'
	option proto 'dhcp'
	option device 'dsl0.100'
	option hostname '*'
	option vendorid 'SERCOMM VD4225R.FW'
	list ip6class 'wan_6'

and it appears to be pulling the IPv6 prefix from the interface-that-doesn't-completely-exist - gateway is really odd, no DNS listed.
the network is configured to use a custom (PiHole) DNS anyway.

I get a ping6 response from google.com on a windows10 pc on the network - which frankly is testament that it works somewhow

I'm not gonna lie; it works but it feels like a bit of a fabricobble.

add the virtual interface wan_6 to wan firewall zone and it should simply.work no need do edit the virtual interface, at least thats what i did.. no expert here YMMV.

Edited etc/config/firewall to put that interface in wan, which makes me feel a bit more comfortable, but if I remove the prefix setting from the main DHCP client, I lose IPv6 connectivity.

FWIW i use slaac for ipv6 address in my lan (isp give a shitty /64 anyways), don't really know if it makes much of a difference.. but this is my /etc/config/dhcp. don't think i can help more than this, as i said no expert here.

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option leasetime '12h'
        option limit '50'
        option ra 'server'
        option force '1'

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '--------'

config dsl 'dsl'
	option tone 'av'
	option ds_snr_offset '0'
	option annex 'b'
	option line_mode 'vdsl'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.178.2'
	list dns '-----------' #I'm using a pihole local DNS
	list ip6class 'wan_6'
	option ip6assign '64'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config device
	option name 'dsl0'
	option macaddr '-- your ISP supplied device MAC --'

config device
	option name 'dsl0.100'
	option type '8021q'
	option ifname 'dsl0'
	option vid '100'

config interface 'wan'
	option proto 'dhcp'
	option device 'dsl0.100'
	option hostname '*'
	option vendorid 'SERCOMM VD4225R.FW' #my best-guess for the fastweb NEXXT DSL modem/router

config interface 'wan_6'
	option proto '6rd'
	option peeraddr '81.208.50.214'
	option ip6prefix '2001:b07::'
	option ip6prefixlen '32'


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.