Failsafe mode does not allow connection

I am trying to setup a TP-Link Archer C60 as a repeater for extending my LAN via WiFI.

I managed to flash the router with OpenWrt 18.06.4, installed relayd and it still worked.
I then followed the process described in " Wifi Extender or Repeater or Bridge Configuration" -

After completing the final stage I lost connection from the laptop I used for the configuration - and any attempt to reconnect failed since then (including trying with manual IP addresses in both the subdomains required by the configuration).
All attempts has been carried out using the LAN interface on the router.

I followed the instructions on how to enter failsafe mode - and the power LED indeed flashes as expected when entering failsafe mode.

I expected that I would now get access to (as described in the docs) - but I got "no route to host",
I switched the laptop to DHCP - and then after a rather long time (10 seconds or more) the laptop got an IP ( - but still no connection to

I tried to ping all adresses in the subnet - no response except for the laptop itself.

I then followed the instructions ín

  • but this does not work either (only reaction is that the power LED turns on).

So I am looking after some hints on how to proceed.

Best regards
Martin Berg

Try with the WAN port too.

Apart from that, the reset button should still force a firmware reset.

Wait for the device to boot completely (or get into failsafe mode) and then keep the reset button pressed for at least 5 seconds (do it for say 10 seconds to be safe), and then when you release it the device should reboot and reset to default config (any package you installed will be erased, any config will be back to default).

It's kind of weird that this isn't mentioned in the wiki page. If you confirm that this still works, I'll update the wiki page.

In case someone is curious about what happens when you press the reset button, this is the script controlling all reactions to pressing it.

Perfect, that worked - I now can communicate with the router again.

Actually I had to restart the router to make it work - it seems that the process I followed to restart in the rescue firmware partition left the router in a state where nothing worked.

To clearify, the process described for the rescue firmware is:
**** Trigger the rescue function by pressing and holding the reset button of the device and then turning the device on (or plug in the power cord).***
**** You can release the reset button after a few seconds.***

Which is the opposite of the sequence for the factory reset (turn router on,
then press reset)

Thank you very much for the help.

I probably still face problems achieving what I originally intended - but that will be in another post

Best regards


Thanks for clarifying, I've added a infobox in that page to redirect people to try out the OpenWrt-specific Reset (which is what actually worked) or Failsafe mode first.

The page you followed describes procedures that rely on the device's bootloader to do something, usually either switch to a recovery partition or to listen to a tftp server for a firmware image to load.
And if that fails the system will remain stuck in that state (bootloader recovery stage) until you pull the plug.

What this "recovery" does varies by device/revision and whatever and is device-specific, it's more of a last resort in case OpenWrt does not boot at all.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.