Failed to download the package list - Wget returned 4

Hi guys, I'm having trouble updating packages via opkg, due to an error shown:

root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/base/Packages.gz

Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/luci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/luci/Packages.gz

Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/routing/Packages.sig
Signature file download failed.
Remove wrong Signature file.
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/telephony/Packages.sig
Signature file download failed.
Remove wrong Signature file.
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/routing/Packages.sig, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/23.05.0/packages/mips_24kc/telephony/Packages.sig, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

You have a DNS configuration problem.

how can i fix it?

Go here and let's see who is handling you DNS lookups. Choose extended test.

snip the results and leave out your ip address.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

Run the calls given by @psherman.

It's here:

root@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.134",
	"hostname": "OpenWrt",
	"system": "Atheros AR9344 rev 2",
	"model": "TP-Link TL-WDR3600 v1",
	"board_name": "tplink,tl-wdr3600-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.0",
		"revision": "r23497-6637af95aa",
		"target": "ath79/generic",
		"description": "OpenWrt 23.05.0 r23497-6637af95aa"
	}
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd26:29e7:c4dd::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr '.........'

config interface 'wan'
	option device 'eth0.2'
	option proto 'pppoe'
	option username '.....'
	option password '......'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'


In LuCI:
Interfaces/lan/advanced settings do you have a Use custom DNS servers entry?

So this appears to be the main router for your network... let's take a look at a few other things:

From an ssh session into the router, run ping tests to the following:

If the third ping test succeeds, run this:

wget https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/packages/Packages.gz

If that fails, let's see the output of

date
1 Like

Date...

How did I forget that? :expressionless:

no, I don't

1.1.1.1:

root@OpenWrt:~# ping 1.1.1.1 
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=59 time=4.707 ms
64 bytes from 1.1.1.1: seq=1 ttl=59 time=2.210 ms
64 bytes from 1.1.1.1: seq=2 ttl=59 time=3.683 ms
64 bytes from 1.1.1.1: seq=3 ttl=59 time=1.597 ms
64 bytes from 1.1.1.1: seq=4 ttl=59 time=1.737 ms
^C
--- 1.1.1.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.597/2.786/4.707 ms

  • 151.101.2.132:
PING 151.101.2.132 (151.101.2.132): 56 data bytes
64 bytes from 151.101.2.132: seq=0 ttl=60 time=19.998 ms
64 bytes from 151.101.2.132: seq=1 ttl=60 time=16.406 ms
64 bytes from 151.101.2.132: seq=2 ttl=60 time=20.963 ms
64 bytes from 151.101.2.132: seq=3 ttl=60 time=18.185 ms
64 bytes from 151.101.2.132: seq=4 ttl=60 time=14.547 ms
64 bytes from 151.101.2.132: seq=5 ttl=60 time=14.524 ms
^C
--- 151.101.2.132 ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 14.524/17.437/20.963 ms

downloads.openwrt.org:

root@OpenWrt:~# ping downloads.openwrt.org
PING downloads.openwrt.org (2a04:4e42::644): 56 data bytes
^C
--- downloads.openwrt.org ping statistics ---
10 packets transmitted, 0 packets received, 100% packet loss

Ok... the issue is IPv6 related.

delete the last line here:

reboot and try again.

It's working now, thanks. Where can I read about the problem and understand a bit more?

The short story is IPv6 is seldom set up correctly by ISPs and if they do, they charge extra.

You can watch this guy explain why despite diving in, he gave up on it.

1 Like

I don't know where there is good documentation about it, but what we saw in your tests was that IPv4 addresses worked without an issue, but the DNS query for the downloads site returned an IPv6 address which you could not reach. This suggests that your ISP doesn't provide IPv6 or there is some other upstream issue with the IPv6 services. Therefore, by removing the IPv6 configuration, we told OpenWrt to only use IPv4, including for DNS queries.

This is not true in my experience, although I cannot rule out that some ISPs might charge for IPv6.

They/some charge to keep/static the /48 from randomly changing. Work arounds are SLACC and DHCPv6

Now, to be fair: I don't do IPv6 so I might have some of the initialisms completely wrong but my understanding is to get an IPv6 'address' working anywhere (e.g. new ISP) requires you to go through a lot of paperwork and justify why you want it.

Its in the video.

For whatever reason, IPv6 is not working for the OP -- either the ISP is not truly dual-stack, or there are issues with their configurations. I would not expect that IPv6 would cost extra, though...

Static IPv6 vs dynamic would certainly be a service for which an ISP could charge.... just as many do for static IPv4 addresses. However, static vs dynamic IPv6 is not required for general operation and is likely not related to the problem experienced here.

1 Like

Their results imply zero IPv6 from the ISP.

But I did not mean to explain why they had the failure, just the normal issue with it.

If OpenWrt wants to do a page on IPv6 and cover all the bases, I wish them luck and success.