F2FS-fs (loop0): f2fs_check_nid_range: out-of-range nid=4f525453, run fsck to fix

I am seeing these messages on the console. How can I run fsck on the root partition? I am running openwrt in a VM with the squashfs image.

I tried the suggestion at How to force fsck at boot? - #14 by iwman, but I don't see the messages during boot, and the messages persist after boot.

Maybe the disk of the VM is too small for overlay to fit..?

Thank you for your response. The router having the problem was running 21.02.1. I used the combined-ext4 image to create the VM, and then used the squashfs image to upgrade it. The VM has 384MB memory and 1 vCPU.

I have not performed very extensive testing, but it is not happening in 21.02.0, but does happen in 21.02.1. I've tried upgrading from the same 21.02.0 snapshot twice now with the same results. I did not notice any errors during either upgrade attempt.

I tried to boot the VM using tinylinux core just to fsck the disks, but sda2 is a squashfs and I've not yet explored how to run fsck on it. Your expertise is appreciated. Thanks again.

[EDIT]: The virtual disk image is 252.50 MB

I resolved to start with a fresh 21.02.1 image and restored my configuration from my 21.02.0 image.

It appears to be working, and I am not seeing those out-of-range nid messages. Not sure why this works, but upgrading doesn't. May have something to do with a corrupted disk, but unless someone can furnish me with a recipe for fdisk'ing the old image, I am going to stick with this.

I'll mark this solved if I don't hear anything back in a few days.

Closing this as solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.