Extroot mount problem

My router is Linksys EA7500 v2 with last snapshot. I can't mount partition as /overlay. Looks like it's not working. /mnt/sda2 works properly.
My fstab:

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '1'

config mount
	option uuid 'df90e6a1-3441-4c52-b35f-0094108db26a'
	option target '/overlay'
	option enabled '1'

config mount
	option target '/mnt/sda2'
	option uuid '7ebc0917-1f89-4a02-bafe-5fc086b56030'
	option enabled '1'

Block info:

/dev/mtdblock10: UUID="590460753" VERSION="1" TYPE="ubi"
/dev/mtdblock6: UUID="1600617145" VERSION="1" TYPE="ubi"
/dev/mtdblock8: TYPE="jffs2"
/dev/ubiblock0_0: UUID="73df5b3d-b16f8f9e-199cf2cb-ba618f05" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/ubi0_1: UUID="6ea331c5-c6c6-4f4a-b84c-313a62efc86d" VERSION="w5r0" MOUNT="/overlay" TYPE="ubifs"
/dev/sda1: UUID="df90e6a1-3441-4c52-b35f-0094108db26a" VERSION="1.13" TYPE="f2fs"
/dev/sda2: UUID="7ebc0917-1f89-4a02-bafe-5fc086b56030" VERSION="1.13" MOUNT="/mnt/sda2" TYPE="f2fs"

And df:

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.3M      3.3M         0 100% /rom
tmpfs                   122.9M    248.0K    122.7M   0% /tmp
/dev/ubi0_1              24.8M      5.1M     18.4M  22% /overlay
overlayfs:/overlay       24.8M      5.1M     18.4M  22% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda2                12.4G    550.0M     11.9G   4% /mnt/sda2

Does the same happen when you use ext4 instead of f2fs?
Anything usefull in the logs?
Have you tried with higher values than 5 for option delay_root '5'?

Yes, I tried different fs and devices (HDD, pendrives).

Have you tried with higher values than 5 for option delay_root '5'?

I even tried 15 without success.

Reboot and collect the preinit stage log:

logread | sed -n -e "/- preinit -/,/- init -/p"
1 Like

Try the following workaround:

Still nothing.
New log: https://pastebin.com/PA1zccJB

1 Like
Wed Sep 30 19:33:45 2020 user.info kernel: [   11.889013] block: extroot: device not present, retrying in 5 seconds

may be try with a longer delay ...

have you "prepared/initialized" your overlay ?

1 Like