Extremly slow Wifi and disconnects

Thanks for your message. Unfortunately there is no Device pages for my Router, only a techdate page. Nevertheless there was an instruction how to install it as a commit: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=58e0673900ea585b03d3cc2f8917667faa3f977f
I did it the same way. And I already checked the Kernel and System Log. If I can establish a connection, I can see it in the log. But if the connection get lost and I couldn't reconnect, there is nothing in the Log. I made some researches but wasn't able to find any information about the drivers.. =/

its unlikely to help but you could try upping the log level in System > System > Logging > Log output level. i wonder too if there are any wifi connections apps that would trace the connection being established so you can see what is causing the rejected connection

Both are already set to Debug.. :wink:
I have this issue with all of my WiFi-Devices, not only my Smartphone. I still think that the problem is the connection. Because of the low connection, the connection get lost and can't reconnect again. I need to put my smartphone directly next to the router, to get a connection again. If I move 2 meters away from the router, the connection get lost. With the original and padavan firmware I can move more than 50 meters and still have a great connection. Think someone messed up something with drivers for this router.. =/ As you can see in the Screenshot -100dBM is not normal, if the smartphone is directly next to the router. With padavan I get ~-24dBM.

After some researches it seems like it has to do with my WiFi Drivers. According to the TechData Page I am using the MT26 drivers (MediaTek 7620). Can I update them and maybe also use the drivers from padavan or the original firmware? Thanks!!

sorry i only know enough to be dangerous, hopefully someone else can help ya. you could try searching the software page (or opkg) with the MT26 or MediaTek7620 keywords, maybe do a search without the numbers as well.

I have an Asus RT-N16.
The b43 and brcmsmac drivers are very slow.
The proprietary driver (kmod-brcm-wl, nas, wlc, wl) on OpenWRT does not work.
On LEDE, the proprietary driver works great (150Mb/s).
Therefore, I stay on LEDE.

1 Like

@AlexHink. Thanks for your message. I already thought about switching to LEDE. But the only reason why I switched to OpenWRT was the security. Asus don't provide any security-updates anymore since 2 years.. And I don't want to stick with an outdated firmware.. =/
I found some open source drivers on GitHub:



Is it possible to install them? They are not proprietary.

Sorry, I don't know.

"LEDE" is a name for certain releases during a period when there were two development branches. There is only a single branch now, called "OpenWrt".

The most-current drivers will be in master, with those in the imminent 18.06.02 release being those considered current and stable for general use. Older MediaTek wireless drivers, from what I have read, were not the best, but have improved significantly improved over time.

Installing drivers from an old kernel ("3.10.x kernel"), while they may work, is not recommended.

You should be aware of, from https://openwrt.org/supported_devices/432_warning

Usability issues

Insufficient RAM for stable operation

  • 32 MB can work for minimal router/AP functions, but may repeatedly “crash”, depending on your hardware and use case

Ok I see. Well, I made a few researches in this Forum. Seems like a lot of people with the MT7620 have similar issues.



So basically the open-source driver is pretty bad. No matter if 32MB or 64MB Ram. This could be a solution: https://github.com/Nossiac/mtk-openwrt-feeds
But I'm not sure if this is the correct stuff I need and how to install it. So sad that the Dev-Team hasn't fixed this Driver-Issue.. :frowning:

Your references are consistent with this, especially when you consider that people don't post "OMG, this works just like I had expected!"

  • September, 2017
  • June, 2018
  • April, 2017

The referenced github project hasn't had a meaningful commit in nearly a year.

I see driver-related changes in the OpenWrt ramips target within the last two months.

The OpenWrt project utilizes Linux kernels and drivers. In many cases, the changes need to be made by the Linux project. Even when the OpenWrt contributors, who are basically all volunteers, make patches to improve the code base, they may be rejected by the Linux project.

1 Like

Okay, I understand. Yeah, the drivers may have been improved significant. But at this moment they are unfortunately still not ready for regular use. =/
Like I mentioned in my first entry, the WiFi with Padavan Firmware works absolutely great. Padavan is also open-source. Are they having the same driver? I found this: https://bitbucket.org/padavan/rt-n56u/src/32a93db4026cc2cff585d7008373432d888fc1aa/trunk/vendors/Ralink/MT7620/?at=master
Would it be possible to install the drivers from Padavan or the original Firmware? I mean, there must be a possibility to improve the WiFi-Quality, right? I don't need 150Mbts at all. But at least 50 should be there.
Otherwise I need to go back to the Original Firmware, which wasn't updated for years.. >.<

Check https://bitbucket.org/padavan/rt-n56u

Unlikely that drivers can be mix-and-match installed. Exceptionally unlikely across major Linux kernel versions.

Balance your time against the reality that a device with 32 MB of RAM is on its last legs and that there are current, well-supported devices with reasonable resources available in the US$20 price class.

1 Like

Hmm.. off the top of my head, the low recieved signal strength sounds like a strong clue. Radio not being set to a sane power level for some reason?

Have you checked or tried turning up the TX power level?

Ofc I did. Like I mentioned in my first post, I tried so many different settings. Also configured the Wifi-config directly via SSH. This is not an issue of settings, its more about support and driver. It doesn't matter which settings I set. If I move 2m from my Router, I can't establish a connection. And even if my phone is exactly next to my Router, I get -100dBM. Thats absolutely ridiculous.

the solution are there for at least 2 MT7620A variants - iPA/eLNA and ePA/eLNA:WiFi connection dropped - Dropping frame due to full tx queue

why the maintainer do not want to merge it is beyond my comprehension

for internal amps only or MT7620N variant i do not have hardware to do the stuff

1 Like

@psyborg
So I should remove this patches:
701-rt2800-move-usb-specific-txdone-txstatus-routines-to.patch
702-rt2800mmio-use-txdone-txstatus-routines-from-lib.patch
703-rt2x00-do-not-check-for-txstatus-timeout-every-time-.patch
704-rt2x00-use-different-txstatus-timeouts-when-flushing.patch
705-rt2800-flush-and-txstatus-rework-for-rt2800mmio.patch
980-rt2x00-reduce-power-consumption-on-mt7620.patch

And install them:
https://patchwork.kernel.org/patch/10739037/
https://patchwork.kernel.org/patch/10743705/

Unfortunately I don't know how to uninstall/install patches. I made some researches but wasn't able to find something useful.. =/

I was experiencing reboots when doing speed tests via WiFi on my WNDR3700v2 with OpenWRT 18.06.1 and 18.06.2. Doing the same speed tests via Ethernet did not cause any issues.
Now it seems to have been fixed by using Smart Queue Management (SQM):
https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm

1 Like

No, it is absolutely not fixed. I tried the newest 18.06.3 and 18.06.4 Version. Also tried the newest development build. There is literally no fcking improvement at all!
The problem is not SQM or anything else. As I mentioned it 100 times, it's the shitty wifi drivers. They are absolutely unusable. They just once made a driver which can communicate with the WiFi, that's all. They don't work in practice. If i put my smartphone ON my router, I get a RX Rate of 12.0 Mbit/s and still a lot of disconnections. With the original Firmware and Padavan I get at least 144 Mbit/s up to 300 Mbit/s, even if I move 20 meters away. I'm not the only one with this problem. As I mentioned it, everyone with this router or similar hardware have this issue..
Even though I tried to reach the devs and tried to help, they weren't interested at all. They don't care if it works or not. That's why I'm done with OpenWRT. Sad to see how this project falls apart. After this thing with LEDE OpenWRT died. No real improvements, slow development etc. Things like these are why Open Source projects will never become as successful as proprietary stuff made by a company, sadly.

1 Like

SQM fixed the reboots during speed test over WiFi but the sporadic reboots where still happening. After flashing the OEM firmware to the Netgear WNDR3700v2 it still experienced irregular reboots. Must have been a hardware issue, I guess.

I have replaced it with a Linksys WRT3200ACM (OEM firmware) several months ago. Now I'm getting better WiFi speeds and everything is working - apart from OpenVPN. I'm not even sure whether I want to install OpenWRT. Maybe when I'll decide to use WireGuard sometime in the future.