Extending wireless to join two LANS

Hey guys,

First post. I've used the search function to try and answer this, as well as follow the on-line guide to extend a wireless connection but I am unable to get this to work. I have also found little information for hardware like mine, which has three radios.

I've attached a hastily drawn picture of what I am trying to accomplish, though doing that whilst feeding four small children was an accomplishment in itself!

I have a Netgear R8000 with 17.0.1.4 installed. I've been running LEDE on since the fork and have fumbled my way through and learned a lot in the process. I've found it easier to set everything up by ssh, however use luci-ssl for monitoring.

I'm in the middle of selling my house and find myself in a significantly smaller rental. Due to space constraints I have hardware stored at opposite ends of the house. I am also unable to run any cable discretely as it's a rental, or overtly, as the kids will eat it!

I have the R8000 router connected to ~15 devices over ethernet as well as the WAN. I am using two of the three radios (1x2.4GHz and 1x5Ghz), with the final 5GHz radio currently disabled. The house I'm temporarily in is small enough that I have no need to extend the wireless coverage as the single router is more than adequate. At the opposite end of the house I have another handful of devices, including a 35TB RAID array, connected to a second R8000 (shipping error!).

I am trying to get everything to see each other. In particular, I aim to reliably stream 4K from one side to the other. I was trying to use the unused radio to create a link, though I understand that the throughput would be halved. Ideally I'd find a way to bond the two 5GHz radios and drop everything back to 2.4GHz but that doesn't seem possible with the Broadcom chips. The online guide mentions using a second subnet and relayd on the 'to be' access point, but I must be doing it wrong.

I got some success using WDS Master/Client, seperate subnets and static routes but it was quite flaky.

Essentially I need to be able to stream data wirelessly whilst bridging the two lans.
Can anyone propose the best way to do this?

If the best course of action is to follow this guide, then I'll retrace my steps and post my configs...

04 pm

You setup is the typical "wireless extender"; you can use WDS (no need to use subnets or static routers) if the hardware allows it, or relayd.

Yes, if AP(WDS) to STA(WDS) works on that hardware, just bridge everything together in the LAN networks on both routers. From a routing perspective the same as having a cable.

Thanks. Yes WDS works natively however I was unable to browse any devices behind the second router. I tried disabling the firewall to no avail.

I'll have another look tonight.

Thanks for the replies

The firewall in the second router is not active, since everything is in the LAN bridge. It doesn't need its own WAN network. This is called "dumb AP". You need to turn off the DHCP server in the second router*, so that all the devices connected to it obtain their DHCP from the first router. This way they are told (by the first router) that the first router is the gateway to the Internet. The second router is transparently bridging all its local users (wired or wireless) to packets that go over the WDS bridge.

*both IPv4 and IPV6, which are separate settings.

This are my notes for relayd/igmp: https://gist.github.com/braian87b/821e9e4f399918510c55619192a31871
And this for WDS (when you have same hw): https://gist.github.com/braian87b/8a524a8ad74a36407a8f481e9d16a5c9

ok.

Excuse the verbose post but I started from scratch on the 'bridge' device and have just outlined everything I've done. A lot of my steps aren't relevant but have been included for completeness.

I've also attached two text files contain the network, wireless, firewall and DHCP configs for both devices...

===
Connect ‘bridge’ to USB-TTL and ethernet on local PC
tftp flash LEDE via serial to ‘bridge’
Change lan ipaddr 192.168.1.2 - no other settings changed

Connect ‘bridge’ to ‘router’ via lan ports.
Can’t ping 192.168.1.2 from LAN on local PC vial wireless
SSH into router
Can’t ping 192.168.1.2 from router on 192.168.1.1
Lost link to ‘router’ on 192.168.1.1

Connect ‘bridge’ back to local PC
Change local gateway to 192.168.1.2
SSH to ‘bridge’ on 192.168.1.2 - no response

Wireshark - ‘bridge’ still listening on default IP ‘192.168.1.1’
rm ~/.ssh/known_hosts
Change local PC gateway to 192.168.1.1
Disable local PC wireless
SSH to ‘bridge’ on 192.168.1.1
/etc/config/network still showing lan IP 192.168.1.1
Edit through vi
Change lan IP back to ‘192.168.1.2’
Enable ppoe WAN
Enable wireless
Reboot
Change local PC gateway to ‘192.168.1.2’
LEDE visible in wireless networks
SSH to ‘bridge’ on 192.168.1.2
Confirmed /etc/config/network and /etc/config/wireless settings

Changed local PC gateway back to ‘router’ 192.168.1.1
rm ~/.ssh/known_hosts

Connect ‘bridge’ to ‘router’ using lan ethernet ports
Connect to LAN via wireless using ‘router’ 192.168.1.1 as gateway
Cant ping 192.168.1.2 from local PC
SSH to ‘router’ on 192.168.1.1
Can’t ping ‘bridge’ 192.168.1.2 from ‘router’ 192.168.1.1

turn ‘bridge’ 192.168.1.2 ON and slap face :roll_eyes:

‘Bridge’ 192.168.1.2 LEDE wireless now visible
Can now ping ‘bridge’ 192.168.1.2 from LAN PC
SSH to ‘bridge’ 192.168.1.2
Can ping ‘Router’ 192.168.1.1
Unable to ping 8.8.8.8 from ‘Bridge’ 192.168.1.2
Add gateway=192.168.1.1 to /etc/config/network
/etc/init.d/network restart
Can now ping 8.8.8.8

Setup extroot on ‘bridge’ 192.168.1.2
edit /etc/opkg.conf > lists_dir ext /etc/opkg-lists
opkg update
wget returned 4
ping www.google.com - no response
Edit /etc/config/network > add option dns ‘192.168.1.1’
Ping www.google.com - success
opkg update && opkg install block-mount kmod-fs-ext4 kmod-usb-storage e2fsprogs kmod-usb-ohci kmod-usb-uhci fdisk
mkswap /dev/sda1
swapon /dev/sda1
makefs.ext4 /dev/sda2
makefs.ext4 /dev/sda3
mkdir /root/backup
Mount /dev/sda2 /mnt
tar -C /overlay -c . -f - | tar -C /mnt -xf -
sync && amount /dev/sda2
block detect > /etc/config/fstab
Edit /etc/config/fstab to enable swap, change target of /dev/sda2 to /overlay, change target of /dev/sda3 to /root/backup & enable
/etc/init.d/fstab enable
readlink -f /etc/rc.d/*fstab
Reboot

/dev/sda2 mounted to /overlay and indirectly /
/dev/sda3 not mounted
Add /dev/sda1 /dev/sda3 to /etc/config/fstab and reboot

opkg install luci-ssl
Confirmed radio2 on ‘router’ 192.168.1.1 Access Point WDS
Browse to 192.168.1.2
Change hostname to ‘bridge’
Join ‘LEDE’ on radio1- can browse internet
Delete radio2 config
Manually configure radio2 as Client WDS
Use same settings as Master and copy BBSID, network = LAN
Web page shows connected

Connect to radio2
can browse ‘Router’, ‘Bridge’ and WAN

Connect ‘Bridge’ 192.168.1.2 to switch - now has no physical link to router
Client on switch obtaining IP from DHCP server on ‘Bridge’ with DNS 192.168.1.2
Unable to ping ‘Router’ 192.168.1.1 from client on ‘bridge’ switch, can resolve ‘Bridge’ 192.168.1.2
Unable to ping ‘Bridge’ 192.168.1.2 over radio2 from original LAN PC

ISSUES:

‘Router and Bridge’ seem independently working if connected via ethernet - ??? Wireless ‘Bridge’
Need to disable DHCP on 'bridge' although don't think its the problem
Connected client PC to 'bridge' directly incase the Cisco switch was interfering as it's probably has some vlans still configured - still nothing
Connecting to Radio2 results in me being unable to see 'bridge'
?? ‘Bridge’ not working as wireless extender but rather a wireless bridge as it only seems to work when physically connected to the router.
Not tested, but I suspect that if I connected a device to the bridge whilst it was physically connected to the router, it would work....

Should be simple from here, but I will wait for feedback as prior experience has taught me that LEDE can be quite flaky if you start to mess with configs needlessly

** EDIT **
Can't seem to upload text files so will paste contents here - again sorry for the verbosity

Router config

root@Router:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdc4:fdbc:6048::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0.1'
option macaddr 'a0:04:60:2f:d3:e6'

config interface 'wan'
option proto 'pppoe'
option ifname 'eth0.2'
option ipv6 'auto'
option disabled '0'
option password ‘
option username ‘

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config device 'wan_dev'
option name 'eth0.2'
option macaddr 'A0:04:60:2F:D3:E7'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 5t'

root@Router:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
option compression '1'
option bursting '1'
option txpower '20'
option noscan '1'
option channel '153'
option country 'US'
option htmode 'VHT80'
option disabled '0'

config wifi-iface
option device 'radio0'
option mode 'ap'
option encryption 'psk2+ccmp'
option network 'lan'
option key ‘*’
option hidden '1'
option ssid 'The Shrubbery'
option wds '1'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
option txpower '20'
option bursting '1'
option noscan '1'
option compression '1'
option country 'US'
option channel '1'
option htmode 'HT40'
option disabled '0'

config wifi-iface
option device 'radio1'
option encryption 'psk2+ccmp'
option network 'lan'
option ssid 'Shrubs'
option mode 'ap'
option key ‘*’
option wds '1'

config wifi-device 'radio2'
option type 'mac80211'
option hwmode '11a'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
option txpower '20'
option compression '1'
option bursting '1'
option noscan '1'
option channel '40'
option country 'US'
option htmode 'VHT80'
option disabled '0'

config wifi-iface
option device 'radio2'
option mode 'ap'
option wds '1'
option network 'lan'
option encryption 'psk-mixed+tkip+ccmp'
option key ‘*’
option ssid '.'

root@Router:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

root@Router:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
option nonwildcard '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option force '1'
option ra_management '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

config host
option mac 'b4:18:d1:e5:8b:41'
option ip '192.168.1.40'
option leasetime '10m'
option name 'iMac-P'

config host
option name 'Mac-Mini'
option mac '88:53:95:2d:7b:c9'
option leasetime '10m'
option ip '192.168.1.13'

config host
option name 'SONOS_Boost'
option mac ' B8:E9:37:07:A3:2E'
option ip '192.168.1.70'
option leasetime '10m'

config host
option name 'SONOS_PlayBar'
option mac '00:0E:58:B3:68:4D'
option ip '192.168.1.71'
option leasetime '10m'

config host
option name 'SONOS_Kitchen'
option mac '00:0E:58:8D:83:B4'
option ip '192.168.1.72'
option leasetime '10m'

config host
option name 'SONOS_Matilda'
option mac '00:0E:58:8D:83:B2'
option ip '192.168.1.73'
option leasetime '10m'

config host
option name 'SONOS_Annabelle'
option mac '00:0E:58:58:8C:26'
option ip '192.168.1.74'
option leasetime '10m'

config host
option name 'SONOS_Bedroom'
option mac '00:0E:58:5C:E4:26'
option ip '192.168.1.75'
option leasetime '10m'

config host
option name 'SONOS_Pool'
option mac '00:0E:58:8D:83:C4'
option ip '192.168.1.76'
option leasetime '10m'

config host
option name 'SONOS'
option mac '00:0e:58:99:8f:46'
option ip '192.168.1.77'
option leasetime '10m'

config host
option name 'iMac-P'
option mac 'b4:18:d1:e5:88:5d'
option leasetime '10m'
option ip '192.168.1.11'

config host
option name 'iMac-K'
option mac 'b4:18:d1:e5:8b:41'
option leasetime '10m'
option ip '192.168.1.12'

config host
option name 'iMac-K'
option mac '68:5b:35:be:4c:37'
option leasetime '10m'
option ip '192.168.1.41'

config host
option name 'Printer'
option mac '6c:c2:17:d8:83:ce'
option ip '192.168.1.60'
option leasetime '10m'

config host
option name 'iPhone'
option mac '48:4b:aa:9a:21:50'
option ip '192.168.1.80'
option leasetime '10m'

config host
option mac '94:10:3e:43:2e:f9'
option ip '192.168.1.62'
option leasetime '10m'
option name 'Belkin-MeMo'

config host
option name 'DiskStation'
option mac '00:11:32:15:0D:E3'
option ip '192.168.1.4'
option leasetime '10m'

config host
option name 'iPhone'
option mac '48:4b:aa:9a:21:50'
option ip '192.168.1.30'
option leasetime '10m'

config host
option mac '04:D6:AA:AC:80:FC'
option ip '192.168.1.31'
option leasetime '10m'
option name 'Galaxy-Note8'
option dns '1'

config host
option name 'iPad'
option mac 'C8:F6:50:13:B8:C4'
option ip '192.168.1.32'
option leasetime '10m'

config host
option name 'MacBook'
option mac '8c:85:90:5b:da:01'
option ip '192.168.1.43'
option leasetime '10m'

Bridge config

root@Bridge:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd4a:51a1:4865::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option ip6assign '60'
option dns '192.168.1.1'

config device 'lan_dev'
option name 'eth0.1'
option macaddr 'e8:fc:af:f9:9e:73'

config interface 'wan'
option proto 'pppoe'
option ifname 'eth0.2'
option ipv6 'auto'
option disabled '0'
option password ‘
option username ‘

config device 'wan_dev'
option name 'eth0.2'
option macaddr 'E8:FC:AF:F9:9E:74'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 5t'

root@Bridge:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option disabled '0'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
option htmode 'HT20'
option disabled '0'

config wifi-device 'radio2'
option type 'mac80211'
option hwmode '11a'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
option htmode 'VHT80'
option disabled '0'
option channel '40'
option txpower '20'
option country '00'

config wifi-iface
option device 'radio2'
option ssid '.'
option mode 'sta'
option wds '1'
option bssid 'A0:04:60:2F:D3:E4'
option encryption 'psk-mixed+tkip+ccmp'
option key ‘*’
option network 'lan'

root@Bridge:~# cat /etc/config/firewall

config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT

config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT

config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

config forwarding
option src lan
option dest wan

config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4

config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT

config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT

config rule
option name Allow-DHCPv6
option src wan
option proto udp
option src_ip fc00::/6
option dest_ip fc00::/6
option dest_port 546
option family ipv6
option target ACCEPT

config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT

config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT

config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT

config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT

config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT

config include
option path /etc/firewall.user

root@Bridge:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

Hey there.

For your next comments, could you please either post your code snippets somewhere else and link them or make them collapsible?

I'm not a fan of WiFi interconnects at all.

Could you drop some information on how exactly you're going to place your APs?
Depending on the exact location there's a chance repeating isn't going to help you.

You clearly need to place both APs in a way they are in range of each other. Just assume both can handle 20m radius / 40m diameter and still have optimal signal strength there. I have no clue about the actual numbers, the only thing that matters is relation. You need to place both APs a little less than 20m apart so they are both in optimal range. The area between them is covered from both, hence twice. The AP on the left hand side adds 20m towards the left, the AP on the right hand side adds 20m towards the right. So in total, extending increases the covered area only by max 50%.

You can increase the covered area by putting the APs further apart, but that weakens the signal strength of your connection link. This might your clients think they are connected at full, say 300mbit each, not knowing about your AP connection to drop down to 50mbit or something.

If you're going that path, consider replacing the antennas of your WiFi cross link with monodirectional ones.

You can bridge nearly everthing.

If you're willing to trade in some CPU, you can bridge nearly every type of connection. You just need to add some layers of virtual links.

See:

See:
https://forum.openwrt.org/viewtopic.php?pid=360022#p360022

The idea:

  • One AP is WiFi AP,
  • Another AP is WiFi client
  • Static IPS on those interfaces
  • Gretap tunnel between them to create a link layer connection on top of an established IP layer.
  • Bridge physical vlan.
  • Repeat for every vlan.

I'm not telling you that's the way to go. I'm just saying there's always a way of bridging.

Reconsider wires

There are really thin rj45 cables available. They fit in floor strips, corners as well as doors and windows.

Always use none-overlapping channels

  • AP 1 should have one set of channels, say 1 and 36
  • AP 2 should have a different set, say 13 and 48
  • The cross link channel should have something else as well, say 42

That alone, however, voids WDS. WDS only works if all APs use the same channel - which means you cannot use your 3rd radio either.

Regards,
Stephan.

Thanks @golialive

I'm still trying to figure out the coding here - I'll edit and make the snippets collapsible as soon as I can figure out how! :slight_smile:

I'm not trying to repeat the signal as I have more than enough coverage. I am simply trying to provide a wireless link between to switches instead of a chunk of ethernet. Apologies, I probably could have explained this better initially.

Thanks for the links to cable - I'm not in this property long so this is just a temporary fix until I can hardwire everything. That being said, I will look to use the second router as a repeater eventually.

I agree with the premise of non-overlapping channels, however the R8000 has a bug in either the driver/lede implementation and as such you must use channels 153,1,40 in order to get all three radios working. It's been a documented bug for a few years now :frowning: It's a tad frustrating as I believe the official firmware supports bonding of the two 5GHz radios.

Sorry guys. Any tips from the configs?

I still can't get this to work :frowning:

All you need to do is explained in the client mode guide.

Have you tried the ones from my notes?

Those work really well... if you use them on any Atheros linking them on 2.4Ghz using WDS or not.
If you use other hw or 5ghz you will have ramdom problems
I already tested those configs on several hardware like, mr3020, mr3040, wr841n wr842n wr1043 v1&v2, wdr3600, wdr4300. have no problems at all so far.

Thanks again for all the input and support.

Do you recommend having a dedicated radio for the bridge, or will that make
little difference?

If you have USB on the router it will be a good idea to try an USB wifi dongle, but try to use a different channel on AP wifi-iface to avoid interference. Keep in mind that sometimes an additional USB wifi dongle for a repeater setup does make any difference at all on speed.

i think you have not disabled the dhcp server on 'bridge'.
you need the hosts on 'bridge' to get their address and gateway from your main router.