Exposing devices to WAN subnet

Hi, so I've recently put OpenWrt on my router, but I'm a bit overwhelmed by all the options for configuring the thing. My home basically has setup like in the image below, where I have a modem+router combo from my ISP. some devices in the living room connect directly to it. it then has another cable going to the office, where it goes into the OpenWrt router, which then attaches to a number of other devices. Now every device does get internet, but I do have a problem that the devices from the office and living room can't find each other. It seems the openWrt router is creating its own subnet (192.168.1.x). Both routers do run a DHCP server at the moment. I'm not sure if I need to run DHCP on the ISP router, as I would prefer to do it on the openWrt alone. Any hints how to configure the ISP router to use the openWRT one for DHCP, so also the living room devices get their IPs from it and are in the same subnet? Of course in a matter that all devices still connect to the internet. The purpose would also be, that devices to find each other in most applications. Thanks in advance!

Consider setup the open wrt router as dumb ap

Then you have one subnet with seamless access


Is this also possible while still running Adblock on the OpenWRT router, and sending DNS requests from all devices to it? It was the main reason I opted to install OpenWRT.

Yes that should be possible, first get it running according to the instructions.

After that you can disable dnsmasq on the isp router and enable dnsmasq on the openwrt router.
Asks for more specific instructions when you are there.


unfortunately I have not been able to achieve the "dumb" access point configuration successfully. I managed to set the openWRT router to have the ip, and the isp router to see it under that address. Unfortunately I don't seem to be able to ping or otherwise reach the ISP router in this configuration from any device, or via SSH from the openWRT router. I tried to configure the openWRT router via LUCI, and via editing the config files via SSH. Nothing seems to work.

You need to connect your OpenWrt router using its LAN port so that it is lan-lan. Did you do that?

The address here should be set on the lan interface. Did you set this address on the lan or wan interface?

Let's see your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thank you for the swift response! Your hunch that I plugged into the WAN instead of LAN port was correct!
I didn't register that specific point from the tutorial. But I re-did all the steps in the tutorial and plugged it into a LAN port, and it's working now. Thanks, you cured me from some lasting headache.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.