EX6150v2 wifi 5ghz drivers bug

hi,
running following below 5ghz wifi stopped to work ... is that some bug?

Thanks!

Model Netgear EX6150v2
Architecture ARMv7 Processor rev 5 (v7l)
Firmware Version OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d

Kernel Log:
https://paste.debian.net/1239844/

Any idea here? or no interest? thanks

Does LAN stop working too?

@frolic lan works fine, 2.4 ghz worked fine all clients active just 5g completely dropoff till reboot

SSH in to the router and run the following -

cat /etc/config/wireless

cat /etc/config/network

logread | grep STA

Redact the passwords in the option key sections of the wireless config results.

Post all results in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

hello, pls find attached details

cat /etc/config/wireless

root@OpenWrt-ext1:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT20'
        option channel '4'
        option txpower '16'
        option country 'CZ'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxxx'
        option encryption 'sae-mixed'
        option key 'xxxx'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option channel '56'
        option country 'CZ'
        option cell_density '0'
        option htmode 'VHT80'
        option txpower '14'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxxx5ghz'
        option encryption 'sae-mixed'
        option key 'xxxx'
        option wpa_disable_eapol_key_retries '1'

cat /etc/config/network

root@OpenWrt-ext1:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddc:69d5:f394::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.0.1.3'
        option gateway '10.0.1.1'

logread | grep STA

root@OpenWrt-ext1:~# logread | grep STA
Wed Feb 16 21:54:36 2022 daemon.info hostapd: wlan0: STA 00:0c:8a:4e:21:93 WPA: group key handshake completed (RSN)
Wed Feb 16 21:55:40 2022 daemon.info hostapd: wlan1: STA d4:91:0f:f1:b5:b0 WPA: group key handshake completed (RSN)
Wed Feb 16 22:04:56 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: associated (aid 2)
Wed Feb 16 22:04:57 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a8:db:03:31:35:21
Wed Feb 16 22:04:57 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 WPA: pairwise key handshake completed (RSN)
Wed Feb 16 22:15:08 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED a8:db:03:31:35:21
Wed Feb 16 22:15:08 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: disassociated due to inactivity
Wed Feb 16 22:15:09 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 01:07:06 2022 daemon.info hostapd: wlan0: STA cc:c3:ea:59:10:a5 IEEE 802.11: authenticated
Thu Feb 17 01:07:06 2022 daemon.info hostapd: wlan0: STA cc:c3:ea:59:10:a5 IEEE 802.11: associated (aid 1)
Thu Feb 17 01:07:06 2022 daemon.notice hostapd: wlan0: AP-STA-CONNECTED cc:c3:ea:59:10:a5
Thu Feb 17 01:07:06 2022 daemon.info hostapd: wlan0: STA cc:c3:ea:59:10:a5 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 01:27:24 2022 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED cc:c3:ea:59:10:a5
Thu Feb 17 01:27:24 2022 daemon.info hostapd: wlan0: STA cc:c3:ea:59:10:a5 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 01:27:25 2022 daemon.info hostapd: wlan0: STA cc:c3:ea:59:10:a5 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 02:29:16 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: associated (aid 2)
Thu Feb 17 02:29:16 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED f4:0e:01:38:33:39
Thu Feb 17 02:29:16 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 02:30:02 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: associated (aid 3)
Thu Feb 17 02:30:02 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a8:db:03:31:35:21
Thu Feb 17 02:30:02 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 02:36:53 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED a8:db:03:31:35:21
Thu Feb 17 02:36:53 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 02:36:54 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 02:37:01 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED f4:0e:01:38:33:39
Thu Feb 17 02:37:01 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 02:37:02 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 02:56:38 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: associated (aid 2)
Thu Feb 17 02:56:38 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED f4:0e:01:38:33:39
Thu Feb 17 02:56:38 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 02:58:50 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: authenticated
Thu Feb 17 02:58:52 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: authenticated
Thu Feb 17 02:58:52 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: associated (aid 2)
Thu Feb 17 02:58:52 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 03:04:39 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED f4:0e:01:38:33:39
Thu Feb 17 03:04:39 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 03:04:40 2022 daemon.info hostapd: wlan1: STA f4:0e:01:38:33:39 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 03:08:12 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: associated (aid 2)
Thu Feb 17 03:08:12 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a8:db:03:31:35:21
Thu Feb 17 03:08:12 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 03:15:28 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED a8:db:03:31:35:21
Thu Feb 17 03:15:28 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 03:15:29 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Feb 17 03:58:23 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: authenticated
Thu Feb 17 03:58:23 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: associated (aid 2)
Thu Feb 17 03:58:23 2022 daemon.notice hostapd: wlan1: AP-STA-CONNECTED a8:db:03:31:35:21
Thu Feb 17 03:58:23 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 WPA: pairwise key handshake completed (RSN)
Thu Feb 17 04:10:39 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED a8:db:03:31:35:21
Thu Feb 17 04:10:39 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: disassociated due to inactivity
Thu Feb 17 04:10:40 2022 daemon.info hostapd: wlan1: STA a8:db:03:31:35:21 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
root@OpenWrt-ext1:~#

thanks

In Europe, channel 56 is a DFS (radar) channel, which should be avoided.

In some geographic locations, it is illegal, and when a DFS radar channel fires up, your connection is dropped.

Complicating your issue is the 80 MHz channel width. It not only overlaps 6 other channels...but also, those 6 are DFS.

I would suggest picking a channel between 36 and 48, or 149 to 161.

Start with a channel width of 40 MHz.

So your log is showing deauthenticated due to inactivity (timer DEAUTH/REMOVE)

This is normal when devices go into sleep mode.

Try the following -

Uncheck "Disable Inactivity Polling".

Increase the value in "Station inactivity limit".

I set mine to 10 hours.

I have a couple of static devices that were getting kicked when I didn't want them kicked, so that solved it.

Keep in mind that some client devices do not support sae mixed.

I would use WPA2-PSK with AES for those that don't.

For those that do, set up a separate guest/IoT network specifically for them.