Ethtool shows gigabit, still getting fast ethernet (100 Mbit/s)

I'm having issues getting gigabit on my wan port on my TP-Link Archer C7 v2, i got it to accept 1000 Mbit for a few minutes before dropping back to 100.
Thinking it was a issue of running an old version of openwrt (18?) i flashed the newest version: OpenWrt 22.03.2 r19803-9a599fee93. Now i fail to get it to accept gigabit at all.

If i run ethtool it shows up as 1000 Mbit/s. But in the web interface i get 100 Mbit/s

I verified that i can get 1000 from the fiber box. I tried various cat 5e cables.

Why is ethtool showing 1000 and the web interface 100?

Your diagram displays LAN 4 connected at 1000baseT,

Disconnect cable from LAN 4 and connect to another LAN port, then check to see if it displays 1000baseT on the other LAN port.
If it does display 1000baseT, you know that issue is network cable used in other ports and/or devices connected to those other ports are not capable of running at Gigabit.

Changed LAN 4 cable to port 3, shows up as 1000 there as well. I cannot use this cable as wan cable, its 50 meters and mounted inside the walls :smiley:

There is no issue getting 1000 from the LAN ports (the other 3 devices aren't gigabit capable)

Tried a few cables that i know get gigabit elsewhere, still 100. But when i reverted back to the cable i started with i actually got 1000.

I suspect this will change, as it did before, after a few minutes back to 100.

Yeah, it went down to 100 after 20-30 mins...

There may be hardware damage to the WAN port. You can reassign the VLANs in the switch to make any of the ports work as WAN. Make it untagged in VLAN 2 and off in VLAN 1.

The CLI to interact with the switch is swconfig, e.g. swconfig dev switch0 show will report various status of all of the ports.


I changed the the wan cable to LAN 4 and changed as the pictures show, did i understand correct? :slight_smile:

Yes. Did it fix your issue?

Looks like it: it's been a few hours and still 1000!

Look inside the WAN RJ45 socket on the router to see if any of the pins are bent or damaged so they don't make good contact. Usually though the cause is hardware damage from lightning or other electrical stress.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.