Ethernet link speed limited to 100/Full in 18.06.0

I just upgraded my Ubiquiti RouterStation Pro from LEDE 17.01.4 to OpenWRT 18.06.0. Everything went smoothly except that eth0 is now only able to connect at 100/Full (previously it would connect at 1G/Full).

I'm not exactly sure what is causing the problem -- Nothing changed on the upstream switch (TP-Link T1600G-28PS 24 port Smart Gigabit PoE+ switch w/ 4x SFP ports).

I installed ethtool and here is what I'm seeing:

`ethtool eth0`
Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  100baseT/Half 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: No
	Link partner advertised FEC modes: Not reported
	Speed: 100Mb/s
	Duplex: Half
	Port: MII
	Transceiver: external
	Auto-negotiation: on
	Current message level: 0x000000ff (255)
			       drv probe link timer ifdown ifup rx_err tx_err
	Link detected: yes

I've tried forcing using ethtool to renegotiate, also tried forcing 1000M/Full on the switch.

I also tried setting the speed via ethtool directly, but it fails:

`ethtool -s eth0 speed 1000`

Cannot advertise speed 1000

And ethtool -s eth0 speed 1000 duplex full kills the link until I power cycle the device.

Any ideas? Is this possibly a bug? Or is there something else I can try?

Is the switch also reporting 100 Mb connection? In other words you might be connected at Gb but reporting incorrectly.

Flash back to the old version to rule out any hardware problem.

So the issue is solved and was not the fault of OpenWRT at all. But I'm more confused than when I started.

@mk24 - yes, the switch as reporting a 100Mbps connection

The above quote had me thinking that maybe something was wrong with a physical port or with my wiring, since the 'partner' is the switch and I know it can handle Gigabit with no issues (it is a lower-end enterprise grade smart switch, after all). So I started swapping out cables and I was able to get normal gigabit again. But when I put those cables mechanically into place (in my rack), it would drop down to 100Mbps again (wasn't checking if it was full/half each time, but I know sometimes I was getting 100/full). Maybe a bad physical cable making intermittent connection... so I try another one and get the same result (out of the rack = 1G, in the rack = 100M)... now I'm thinking maybe it is some strange electrical noise source, so I start powering down non-essential systems in the rack but the results don't change.

After rerouting the cable a few times, I did manage to get it to connect properly at 1G in the rack, but I really don't know what is going on. I'm 99% sure it is not mechanical (i.e. bad connectors, bad cables, bad hardware). I still think there may be some noise issue or something odd happening that will come back to haunt me later. But my guess is that whatever the cause, I would likely need a $5k+ cable tester (that does really advanced diagnostics and measurements) to find the problem.

Keep in mind, this is a small rack, and the total cable length from the switch to the RouterStation Pro is ~4 feet (2 cables -- a 1-foot patch cable from the switch to the patch panel, a 3-foot cable from the back of the patch panel to the device, and a keystone coupler in between; all of these parts are CAT6 rated Monoprice cables (pre-terminated) and couplers, and about a year old in very good physical condition, never been mechanically or electrically stressed, and even replacing these parts had no effect -- it seemed purely positional in nature)

So I remain confused, but the problem was not OpenWRT in the end.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.